No photos shown on WD photos App

Hi all,

I am using WD my Cloud.

I did try the followings and I still can’t see photos on my mobile:

  1. All files are stored under “Shared Pictures”
  2. All files are jpeg
  3. All files are now only be viewed by WD My Cloud on my PC that I could view they by window’s File Explorer before I put them under “Shared Pictures”
  4. I tried reboot

I am a user form HK, nice to meet you all, grateful you could help



Have you tried reinstalling the app?

You can go to settings on the UI and under cloud access click on configure and click on rebuild. This will help the unit to search for all the files of the unit.

Try going into the Settings, General, Cloud Access, Configure, then “Rebuild” the database. If that doesn’t work, also go to the Media tab in settings and click Rebuild.

Thanks for you two help.

I can see photos on the app now. It looks it really takes a lot of time to update.

But still I cannot see them by window’s File Explorer.


That’s because the thumbnail generator that creates icons for displaying within the WD My Cloud app doesn’t apply to Windows File Explorer. You need to either change the “View” in Windows File Explorer to “Icons”, either small, medium, or large icons. For certain media files one can also edited the file metadata to add “album art” so DLNA clients will display a different image. Or one can create an image file called “folder.jpg” and all files within a folder will have the same image file displayed when using a DLNA client.