Windows 10 Photos App

Has anybody figured out how to get the Microsoft Photos app in Windows 10 to access the shared photos in WD MyCloud? It works fine for Music and Videos but I can’t get it to display the photos. Yes, I’ve mapped the drive and added the folder to the photos library.

Not sure what you are asking, is this on a phone, tablet, or computer? See image below captured on my desktop computer with pictures open. Click, tap or activate image to enlarge it.


Thanks. That’s File Explorer. In Windows 10 there is a app that comes with the OS called “Microsoft Photos”. It’s a nice interface for viewing photos. It basically searches folder locations that you specify and the photos populate in the app. It does not provide the ability to drill down on folders like File Explorer. The issue I have is that even with the WD My Cloud shared pictures folder specified as a location, it does not populate the photos from that folder. When I load that folder in “library” there is a statement that not all features are supported due to indexing.

Regarding the device, Windows 10 is the same on tablet or computer. I have both and neither work for this function.

It appears to me that network drives (DLNA) and other devices that are not directly connected to the computer are not scanned by this app. See this screen shot when I attempted to do what you were trying.


■■■■, I hate that. No sooner had I replied above that it didn’t work - the Photo App popped up the pictures I have in the Public/Photo area!

So, disregard what I said above (I hate that). :joy:


PS: If you have a lot of images (like, > 10,000) then it could take weeks for this product to index them all. I’m watching it scan a modest part of my collection (about 10,000 images) and it has been churning for about an hour now. Speedy it’s not.

Thanks. Mine doesn’t seem to be getting them. It must be a configuration issue. I wonder what’s different?

Update: I’ve done two things and now it seems to be working. (1) I made sure the Workgroup in WD My Cloud matched the Workgroup setting on the computer. (2) I set up a Homegroup and made sure the computers were in it. I’m not sure if (2) had anything to do with it but it’s now loading the pictures (it does take a long time).

I also rebooted the WD My Cloud, so that also may be related.

Good news! It will take time though.