How I fixed some common problems on EX4


I have not been able to fully resolve all issues but number of occurences of each issue

has been lessened in frequency in which they occur.

After having purchased My Cloud EX4 I have experienced many if not all of what many of you also have experienced. And I have also found some resolutions.

1 - Network disconnects randomly after few min to few hours of use.

Fix: Set static IP address on the router so whenever device turns on it will receive a static IP automatically. (does not always work but helped make the issue occur less often) Also try changing Network speed from “Auto” to 1000 that way it forces Gigabit rather than 10/100 in case it’s trying to use the latter.

2 - Media service db rescan that resets to 0 and also uses up CPU.

Fix: Option 1, goto settings and disable Media server service, Option 2, goto your EX4’s Twonky server page ( http://yourserver:9000) and customize the media db by disabling search for photos and search for videos only as videos tend to be fewer and will generally finish quickly running the scan. Also make sure you uncheck in Twonky server settings rescan on IP change option.

3 - RAID rebuilds constantly and won’t finish or will freeze after

Fix: Try moving files out of the nas and let the scan finish in shorter time before it freezes, because if scan takes too long it ends up freezing the EX4.

4 - EX4 won’t shut down

5 - EX4 locks up and can’t browse the network share or access much of the web admin portal

Fix for 4 & 5, goto settings and under “Energy Saver” disable turn OFF the “Drive Sleep” option.

6 - EX4 does not see the external USB drive

Fix: try plugging the usb drive to your computer and changing permission on the drive to allow “Everyone” RW (read/write) access to it then replug it back into the EX4 and configure the share permissions Having experienced all these problems really were getting on my nerves and I was at the brink of returning this device to the store, except the store doesn’t take 30 day warranty on NAS products.

1 Like

additional note: turning off the “DRIVE SLEEP” seems to have fixed “Error 500” also.

Thanks for these helpful tips of how to resolve the issues plaging the MyCloud product’s. Sad that we have had to resort as community members to trying to find ways around the issues instead of seeing firmware upgrades to resolve the problem


I found that when plugging in the USB device cable (not being able to see the rear of the EX4) you could get the Connector upside down and it would feel that it was connected i.e. all the way home. However the USB Device did not show activity nor was it listed in the Web Interface. After managing to get a better view of the rear of the EX4 i located the USB in the correct Orientation and all sprung into life.

The first effort noted I was sure that the plug was in correctly and located all the way in.

Hope that helps someone

I was about to post regarding WD Quick View unable to wake the EX4 when it goes to sleep mode

I guess by not putting into a Sleep Mode… but there is no Energy save!

Anyway, I must phyiscally hit the power on button on the EX4 to wake it.


If you have to turn off sleep, what is the point of having this device?

I have spent countless hours trying to debug these common problems, and I am so sorry I bought this EX4.

I had to abandon any raid other than 1 for the thing to work proplerly for any extended amount of time.

I have to unplug my USB drives to boot up.

It won’t shut down, and I always have to unplug the thing to restart. Yes latest firmware.

I am very unhappy, and may just pull the hard drives out of this thing and by something more mature.

1 Like

The comments on this thread are quite concerning that there are this many issues with an EX4.  This device isn’t cheap by any means so would expect less bugs and higher quality from WD.

I have had my EX4 for around 12 months with 2x3TB WDRed drives in a RAID 1 configuration, worked mostly fine without any issue.

Only issue I had was browsing directly from my SONOS devices to access the iTunes media folder directly, no matter what I tried couldn’t get it to work so gave up in the end.

Last week I added 2 more 3TB drives and migrated my config and data to a RAID 5 configuration.  All seemed to complete OK, however since migrating I have the following issues

 1.) All 4 drive lights tend to be blinking constantly indicating the device is still doing something with the drives rather than them sitting idle.  The GUI is not reporting any maintenance operations and all drives reporting back as Good. 

 2.) The device simply won’t shut down unless I pull the power from the back of device.  I suspect it is related to Problem 1 but cannot be certain.

I read a different thread before this one that suggested performing a drive scan which is running now, so will see if thats fixes it.

Any thoughts or suggestions on root cause or potential fix greatly appreciated.

After being relatively happy for the last 12 months with it, starting to lean towards solliex’s view unless I can get these issues resolved soon.


As you probably appreciatte, the Internet is an Echo chamber, whcih is often not a good thing.

Disk lights flashing constantly is not normal operating procedure.  Combined with your issue about power-down, it would suggest that the unit has max’ed it’s CPU.  If you can access your GUI, check the CPU load - although the better way is to SSH to the device and run a “top” command.  See what is taking up the CPU, and also note the mix between “sys” and “usr” mode.  The more “user” mode CPU you have, the more responsive the unit will be.

With your symptoms, I’d expect to see low “usr” mode and high “sys” mode. If this is the case, I’d check the following

  1. Unplug any external USB drive and re-boot

  2. If no external USB drive, check your twonky scan interval.  Ensure you have marked only the directories that you want twonky to serve, also that you have “scan on NIC changes” set to OFF. Finally set your recan intervall to a nice long time - every day or so (mine is 960 minutes).  I have found that if this setting is set to “auto” (-1), then twonky can never stop scanning dircetories.

There are some bugs with the unit (reported on this forum) where the Apache server daemon seems to need a wooden stake.  There has been no fix posted for that.

1 Like

I purchased my WD EX4 on 06/18/15 and have had trouble ever since. 

  1. The RAID status says “Wait to resize” and always said this since i bought the unit.  It has never changed. Although my   Disk status is healthy and nothing wrong with the disk.

  2. cannot change to a different raid or format the disk or do a quick/system/full restore.  It keeps saying: 

    "Error.  System shut down, restore, and restart, as well as a firmware update, are prohibited when the following

     operations are in progress: disk formatting, disk resizing, disk migration, and firmware upload."

  1. Until recently I was unable to do a firmware upgrade until i shut down (manually), and waited for a couple of days (cause i was pissed-off at the issues), then plugged in the power supply again and it updated the firmware on its own.  

Thinking about re-selling this piece of **bleep** with hard drives and all and going with another vendor.

Assuming that you have no data on the drives (as youare building the RID set), then remove power from the device, do a reset and re-initialise all your drives.  The configure the RAID set through the GUI.

After the last firmware update I am also having all that issues to you listed. I bought my EX4 2 years ago and installed 4 red 4 TB WD HDD Raid 5 also on. Until last update I never experienced any issue. Thank you for your suggestions I will try them and keep update you people. Thanks again!

I had a solid connection with this after numerous issues before but after a brief power cut I am back to the same issues as you @xderka - I have since reopened my ticket.

I have tried to resolve this by:

  • Numerous system restores
  • reinstalled the recent firmware
  • restarted my router numerous times
  • I had set the router to assign a static IP to the EX4 and I removed this and then set the EX4 to assign this a static IP

None of this worked and am at the end of my tether.


I have a question mycloud ex4 system rebooting continue and restart problem
It is constantly re- start condition

After making disk raid occurred geld renewal .

help me.