EX4100 becomes unresponsive, loses network


#1

I’ve had my EX4100 for a couple months now and I’ve had a persistent issue where it disappears from my network after a few days, does not respond to ping, AND ignores a sustained press to the power button.

A hard reset ( removing the power cord and plugging it back in ) reboots it, and after initialization, everything is fine again for a few days.

I have replaced both patch cables and my switch as a troubleshooting measure, but logically speaking doubt that a faulty cable would ALSO cause the sustained 4 second press to the power button not to work. If I didn’t know better I’d say something software related is locking up.

I have the latest firmware, I have assigned a static IP and turned drive sleep OFF, but the problem persists. Any ideas?


EX4100 Keeps disconnecting from the network - ANNOYING!
Add "netpoll" and "netconsole to kernel on EX4100
#2

Hi there, try to connect the device directly to the computer. The device will still get network connection, although you won’t be able to access the shares. But you will be able to verify if the issue is with the device itself or not.


#4

i am having the exact same problem, i thought it was AVG internet security firewall issues at first but have removed this and gone back to default windows 10 security and it seems to be happening. I have the same issue with my back up EX2. now, i just noticed today that i could see and ping in dos both NAS drives and the router and could also see them on the list of devices in the router. hard reboot seems to be the only answer but means i have to resync my music library and re add the library and play lists in my bose soundtouch app. Could i ask jpeng why you suggest turning the mycloud access off, would this not stop all of the software working at all? I must admit i dont use it for remote access anyway just on a home network for backups and music/video library


#5

Thank you for the replies! It’s been 72 hours since the last restart, so I’m waiting now to confirm one more freeze, then I will try the above suggestions and report back.


#6

Hate to tell you, but this has been an ongoing problem with some of these units for many months. WD replaced my EX4100, but the replacement has the same problem. I’ve tried all the things you mention to no avail. The one thing that did seem to help was disconnecting it from the APC UPS that I had the EX4100 plugged into and plugging it into the wall. It went the longest yet, a little over a month. Not perfect, for sure but I’ll have to live with it. It was locking up every few days. Mine has had several firmware upgrades which made no difference. Also followed all the suggestions about static IP on the unit itself, not just in the DHCP of the router.
I set mine to power down every day, but that didn’t seem to make much difference either.
There are several other threads regarding this issue if you look around the site.
Good luck.

BTW The one thing I have not tried is to disable web access completely. For one thing, that’s the whole point of this cloud stuff, although I’m only using for local backup. But the unit is not at my house so the only way I can monitor if it’s working is via the web.

Chris


#7
https://community.wd.com/t/ex4100-stops-communicating-and-wont-power-off/

Another thread on the topic.

Just an aside, as a retired tech support guy myself, I tried to help diagnose the issue as much as I could. I enabled extended logging and sent in two sets of logs, but there is no follow-up from WD tech support, so what can you do. It’s a waste of time if there is no follow up.
Near as I can tell, logging stops when the system freezes (no surprise) so there is no error in the log file. The only “error” is the loss of power when the user pulls the plug to get the system to power off.


#8

Hi Chris, I can’t view the topic you linked, but yeah, I kinda wonder if WD is internally aware of this problem but doesn’t know the fix yet.

My EX4100 just froze again, so it lasted about 5 days this time. No response to ping, power button does nothing. The last thing I tried was replacing the switch and using two new Ethernet cables, but that didn’t matter.

In my opinion it has to be the device. There is no reason for the power button to fail if the problem is external.

The up/down arrows still cycle through status, but as far as I know that’s a separate circuit.

I’m going to try turning off cloud access. Like you I am only using this for media sharing and file backup on a home network, and for its RAID redundancy.

I’ll see you guys in 3 to 5 days LOL


#9

Hi all,

Mine is doing this as well. No rhyme or reason or pattern as to when it happens. Also no logs that are worth trying to hunt down as all there is an absence of logging. I think the only way that there might be anything useful to get would be if these had a viewable console that could be accessed when it crashes. This might reval some more info on what is going on.

For now only option is to pull the power :frowning:

Cheers,

JediNite


#10

Since the latest firmware, mine has been doing this as well.

I’m ready to revert the last firmware as I had no issues with freezing, now it occurs every couple of days.

The buttons on the unit work to change the display, but it loses network access and wont soft power-off.

I have to un-plug it risking the integrity of the drives with the soft raid. Very frustrating.

Anyone know the procedure to downgrade firmware?


#11

I have seen that everyone is power cycling the unit (Pulling the plug) for this issue. I was wondering if anyone has tried the reset button instead?

This is no fix, however it would be better than a cold shutdown.

Outside of that, does anyone have any other solutions to this problem?


#12

I turned Cloud Service OFF and I can report that my EX4100 has been running two weeks now without freezing.

We lost power once due to a storm, which forced me to shut it down gracefully and reboot it later, but otherwise it has responded and continues to be visible on the network. I am going to let it go another two weeks, and if no issues, I’ll try turning Drive Sleep back ON.

Honestly I don’t use the remote access / cloud functionality, so if that turns out to be the problem, I can probably live without that.


#13

Your description of the problem matches mine exactly. And indeed, the inability to power off from the power button confirms that it is not an external network issue of some kind but that the device has locked up. Trouble is that there are no log entries or error messages generated as a result. I keep hoping for a firmware upgrade to resolve this.
WD support does know about the problem, but their follow-up is abysmal.

Good luck and do keep the forum posted with anything you discover. Maybe we will figure this out yet.

Chris


#14

Yes, I tried the reset button. Didn’t work. To be honest, I hadn’t noticed there was a reset button until WD support suggested it. But like the power button, when the device locks up, the only thing that still functions is the status display message, which indicates that everything is just fine!
No option but to unplug the unit to power it down. Then plug back in and wait while it checks the drives and comes back up.

Chris

PS Has anyone tried 2 power supplies?


#15

I am now returning my second one back to Amazon. I’ve had two that disconnected on the first day. Only physically pulling power will get them back. Defective. Twice.

I’ve also opened a ticket with WD support two days ago, with no response.


#16

Just to update…
I now have 3 power supplies on hand which I have tried in all possible combinations. No improvement.
I then disabled all access other than over the local network. Again, no improvement.

It’s been locking up every couple of days.

I’m out of ideas.

Chris


#17

WD just replied to my review on Amazon, and they blamed my “environment.” Haha.

Hi There,

It’s unfortunate hearing about the inconveniences you have experienced and we appreciate you’re bringing this to our attention. Having multiple units exhibit the same or similar symptoms may indicate a configuration or environmental issue affecting the device’s behavior. We placed a few articles with detailed and useful information that might help:

“My Cloud does not enter Sleep or Standby Mode”: https://support.wdc.com/knowledgebase/answer.aspx?ID=15162

“Common Causes of Slow Media Streaming and Content Buffering”: https://support.wdc.com/knowledgebase/answer.aspx?ID=18096

“How to configure a My Cloud EX4100 device with a static IP”: https://support.wdc.com/knowledgebase/answer.aspx?ID=14941


#18

Just wow… it’s almost like they didn’t read the description of the problem. Most likely your response was not from a tech, engineer, or anyone capable of designing the unit and therefore debugging it.

I was able to resolve the freeze by turning Cloud Service OFF, though without technical knowledge of why the freeze is occurring I wouldn’t be able to definitively say the bug is with that. Has anyone else here tried turning cloud off?

I mean if WD is not interested in the problem there is no way I can recommend this product to anyone.


#19

Well scratch that theory. The unit is stuck in stand-by mode, invisible on the network, and unresponsive to a long press Shutdown. I’ve had Cloud Service OFF so that appears unrelated. I will go back to disabling Drive Sleep and see if that works.


#20

Hi all,

I’ve tried enabling some cron jobs on my EX4100 NAS so I can try and determine when it freezes if it is just the network that drops off or if the whole unit becomes unresponsive. My thinking is that if the NAS OS keeps functioning and just the network drops off, I can add some code into the cron job to detect for this and initiate a reboot of the NAS. This is far from ideal but less disruptive then finding a dead NAS that requires a power cord reboot.

Cheers,

JediNite


#21

Hi all,

I’ve just had the unit lock up and analysed the output from the cron job I was running and can confirm that the unit completely locks up when it hangs and it is not just a network drop out. So I guess, the next thing we can try is see if there are kernel settings that can be run to trigger a reboot of the NAS when the kernel panics and see if this triggers a reboot to occur ?

Cheers,

JediNite