EX4100 losing network connection after a while (OS5)

Hey there,

I have an EX4100 that was running smoothly on OS3. Never had any problems with it. Plugged it in and everything was fine.

Now I updated to OS5. Since then, I have daily disconnects from my network. Power LED is solid red, but power button does not respond. Display says drive one is above 95%, but this seems reasonable and there’s still 400GB of free space.
I only found some very old forum posts about this issue - none of which provided a solution.
Unplugging power is the only way to bring it back online.

I tried 4s and 40s resets.
I changed cables, power supply and router.
I manually updated to build 5.7.118.
When it’s online for a short time after the restart, there’s nothing unusual.
Cloud services are deactivaetd, so no indexing running.
RAM usage is a bit higher than it was with OS3 and CPU is around 5% when process-list isn’t shown. No additional apps are installed so far.

Anyone having the same problem or maybe a solution?
Thank you in advance!

1 Like

Here are some of the old posts I found:



Am I really the only one facing this issue now?

I am desperate and need a solution as soon as possible.

As I had no problems with WD products so far, I am not willing to give up right now.

I have a pr4100 and as soon as I load OS5 i lose my first drive and network cloud access. lan is accessible but nothing else. I shipped it back to them. They basically reloaded it with factory settings. I rebuilt and again as soon as I load oS5 from os3 bamm no more cloud(network internet access) can’t even contact the firmware server.
and drive bay one is now solid red. I’m getting no where with support

Hi,

Same issue here with my EX4100…just keeps dropping off my network, can’t power cycle from buttons must pull cord to reboot. Have had some issues with my credentials not seeming to survive PC restarts (Win 10 x64 20H2), but the fact that I can’t even ping or login via IP address suggests it’s just dropped off my network. Renders the device completely useless. Was fine on OS3, this is totally an OS5 problem.

This would appear to need some guidance or attention from WD support…are there settings such as SMB versions that might provide a workaround here short of updates or fixes to OS5?

1 Like

Well, loosing the first drive and cloud access without losing LAN is a different issue, I guess - but thank you for your feedback anyway. I am in contact with support, but it looks like they didn’t read my log files until now. I guess they have a lot to do since the release of OS5…

Further to my earlier reply, I’ve now pushed the upgrade to v5.7.118, and also tried toggling on the NT LAN manager NTLM v1 & v2 setting under Network Windows Services, as another user noted that some SONOS hardware requires using NTLMv1.

Had to power cycle again to gain access to do all this, and for the moment we’re up with Cloud Access, all seems fine.

One other observation is that throughout all of this, since upgrading to OS5 my Windows Explorer Network directory lists my EX4100 twice. All other devices on my network (including 2 other brands of NAS drives, which are working without issue btw) show only once. Not sure if this means something is still set wrong here. That double listing is still there after the above changes.

I just found out, that before the unit crashes, the whole CPU time is used by more than 200 mdev-processes. I also have an error libusb_init failed in the log.

I have no USB-Devices attached to my EX4100.

Your not the only one. Since upgrading to 5.07.118 I have had to pull the power on my unit twice. Same issue as you. Becomes unresponsive on the network and front buttons don’t seem to do anything. Would be nice to see a fix for this soon. I have 4 units and this one has been rock solid since purchase until now.

1 Like

Well as expected my changes made no difference, my unit dropped the network connection again after only a few hours and is locked up as before…so I’m still with a useless NAS.

Your note about CPU usage and errors in the log sounds useful for troubleshooting though. Do you have anyone at WD support actually engaged at this point or are they just going through the motions do you think?

Yes, I opened an issue and someone is on it.
I sent him quite a lengthy list of things I tried that had no effect :slight_smile: .
Unfortunatley, the 9h offset from my timzone to pacific time is delaying the conversation in a very inconvenient way.
And I guess techsupport has a lot to do since WD management forced the devs to release that shitty piece of software they call OS5…
Right now, I am sure mdev is causing either a kernel panic, stack or heap overflow. I’ll keep you updated on this.

As a workaround / convenient way to restart the unit remotely, I will install a Wifi power switch, so I don’t have to drive to the office every time I’m locked out.

1 Like

OK, Thanks.

Sounds like you are doing what we can here to help them to get to the bottom of this…hopefully our problems are related enough that some universal fix will work.

Will keep checking back here if there are updates to try certainly willing to give things a go. My device is all redundant data backup so no huge risks on my side. You certainly sound more advance than I am in these matters. Yes I agree the OS5 “wrecking crew” may have their hands pretty busy at the moment from it’s apparently premature release.

I like your workaround with the WiFi switch but I feel your pain on the remote location. In my case I’m living with the NAS so easy to keep pulling that cord, just my knees are getting worn out.

Not sure if it’s relevant but I do have a Netgear managed switch between my main router and the EX4100.

Thanks for your efforts in pushing WD support here, hope we don’t have to suffer this bricking for too long.

Another morning and locked up again. I updated to the latest firmware yesterday afternoon and it didn’t even last 24 hours. Guess it time to invest in a remote power switch for this NAS so i can power it off remotely and get it back up and running.

I was hoping to get a solution before the holidays start, but I am losing hope.
Level 1 support didn’t help much - except making me feel a little better. He seemed competent and was very friendly. Haven’t heard of him in while now… :frowning:
Maybe he is annoyed of the tons of log files and screenshots I sent, maybe he is still digging through those… maybe he forwarded them to the next level? I don’t know.

A fix would be nice. Mine locked twice this weekend. I have installed a remote power switch so i can power it off but i’m also thinking maybe a day scripted reboot might at least keep the thing up and running so i don’t have to babysit it.

A short update on this one:
A WD support staff member called me again. He apologised for the delay and forwarded the case to engineering. They read my log files and found the USB errors I mentioned on Dec 17.
So even though there’s no solution today, it’s not a cold case yet.

@postmanlee
Can you get the My Cloud Logs .

You may create a Support Case and attach the logs on the case

I am deeply disappointed!!

Not only that WD failed miserably with the release of OS5.
Now they also failed completely in cleaning up the mess they created.

My case was forwarded to engineering. They read the log, they see the error with usblib, they cannot reproduce the error, they promise to replace the enclosure … and then nothing happened again for two weeks.

I will try to revert to OS3 now.

1 Like

That’s most disappointing news…was waiting out your success to ride on your coattails.
Many thanks for your efforts with WD here…this issue is quite clearly not entirely hardware related with so many of us constantly dropping connectivity after OS5…my box was rock solid for a couple of years before the upgrade. It’s possible I suppose that their new firmware has rendered our boxes obsolete now…
When I find the time to battle I may need to open my own case here although it would seem to be very much an uphill battle.
Perhaps update us on the OS3 downgrade if you get there…
Cheers.

I have tried the 5.09.115 Firmware, with no fix for this issue…my unit still drops the network connection with 12-24hrs and requires a hard power reset to bring it back. Arrrrgh.