1st Week Issues - My Cloud EX4100 24 TB

Hello, I have had the My Cloud EX4100 24 TB for about a week now. These are the issues I have encountered so far.

  1. Yesterday, I began a copy of data from a portable HDD to a folder on the device. I then checked how the copy was going and I was unable to connect to the NAS over the network and couldn’t ping the device. The device was unresponsive. After a while I tried to safely power down the device via the power button, this didn’t work either, so I hesitantly pulled out the power source. It started working again and took a while to do a consistency/integrity check, but this is very concerning as I have important data on the device.

  2. I also encountered a serious issue when changing the devices name. When I changed the name, it stopped accepting my authentication credentials for the shares that were not public. I reset to factory default (System Only) and then it worked fine again. I tried a second time to change the device name and again it rejected my user credentials for the shares. I have just left it as the default name, but this isn’t ideal.

  3. I also found it difficult to locate the ‘WD My Cloud’ software that allows you to copy from a USB device to the NAS and found the online documentation and software download page lacking. It looks like it’s all focused on Cloud and network share access, which is great, but I want to copy things fast with the direct USB3 connection and it looks like the ‘WD My Cloud’ software has not been updated in a long time. I found out the info regarding the application I required via an online forum.

Please note that all the issues experienced were after I updated to the latest firmware that was available.

So I cant say I have been super excited about the device thus far and I’m concerned how reliable its going to be.

Thoughts, suggestions and solutions for the above would be appreciated.

Hi S4GB,

You should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.

Thank you, will contact them.

would be very interested in hearing what they told you

have owned this for a couple years, also have 24tb and use it primarily to house backed up media ( i just dn’t trust it)

it’s raid5

since day one it’s rnadomly hqangs while copying to the device, very rare locking up in the reverse (streaming from the device)

I have updated the FW, also removed twonky etc to no avail

while copying to the drive sometimes it doesn’t hang, but it hangs very frequently (u can almost bank on it)

i google it and it seems either most are not using it every day as i don’t see anyon e else with this issue and yet it is a tgiven with this device

to get out of a hang…you cannot use the shut down button either…it has to be unplugged

after 20 minutes it’s okay again, but what a wonky box

Hi there, unfortunately after much correspondence and troubleshooting with WD support, we haven’t manged to resolve the issues. We are at the stage of returning the device to our local supplier and getting a full refund and busy looking at a new solution. I’m not a 100% certain, but I highly suspect the issue is with the OS (or the way its configured) and not the hardware itself. The other NAS we have is the WD Sentinel DX4000 that runs Windows Storage Server 2012. The direct interaction with the OS through the Windows remote desktop GUI is perfect. For me personally, these devices that utilise a linux based OS with no way of the user directly interfacing with the OS and only having very limited user interaction through a web interface is very frustrating, especially if you need to troubleshoot a problem, look at event logs or the likes. So, we are now looking for a NAS with Windows Storage Server as the OS and WD does not have any NAS’s with a Windows OS in their current offerings, they are all linux based with a web interface.