EX 4 Firmware upgrade has made this device disappear from network

So my EX4 downloaded and installed the new firmware (2.11.133) - since then the device has disappeared from the network and reappears briefly for 10 mins or so before dropping again. The only way for this device to reappear on my network is power cycling it before it disappears again.

This is annoying as I have spent a substantial amount of money for this and it is now unusable.

Any suggestions?

After it disappeared, what is inside the Display? Any error message there?


The EX4 just disappears from my Mac (and PC as tested it there) and the error message is something like “EX4 has disconnected”.

I spent an hour or so with tech support trying to troubleshoot it.

I connected the PC and Mac direct to the EX4 and was walked through various troubleshooting methods.

Ultimately, I ejected the USB drives and then turned the drive sleep off and reinstalled this new f/w manually. This didn’t resolve anything and after another reboot (both using the reset button and then pulling the power socket thing out and in) the system has been up for an hour and am currently streaming a movie. So, currently, it seems to be ok, but this has proved a complete nightmare. I have now switched off the auto f/w update and will pop the USB drives back in later to see if that mucked things up.

I have the same problem with my EX2 since the new firmware (RJ45 with Mac).

In a way I am glad it is not just me - on the EX4 d/l page it said something about removing the power plug for 5 seconds and then popping it back in and leaving the EX4 to restart etc. Not too sure if that is the same for the EX2.

So the problem has happened again - the issue is obviously related to a buggy firmware - WD please fix this as at the moment the EX4 is not fit for purpose.

So an update. After numerous reboots via the pin next to the USB ports and numerous pulling the plug out and then in - I managed to keep it online long enough to plug the ethernet into my Mac and perform a system restore via the GUI. This seems to have, touch wood, kept it on my network for the past 3/4 hours. I’ll update this thread as and when it remains as it is or drops again. Annoyingly my WD Cloud 6TB (white one) remains rock solid on the network.

In case WD staff are reading this, it has now been 24 hours (ish) and everything seems to be ok - I will update this thread in a few days if all is good or sooner if I have issues.

I am not sure why a system restore via the GUI seems to have resolved this, but this all happened after the recent f/w update.

f/w updates on my other wd my clouds (specifically the 6TB) has never caused anything like the problems I have had with the EX4, this is annoying as this product cost a substantial amount of money and I assumed it was of premium quality.

I had the same problem with two EX2s every time they did an automatic firmware update. Their behaviour was, to say the least, a bit flaky until a minimal factory restore had been done. Then of course I had to set up all the users etc again - a royal pain.

In my case, I think it’s happen when “WD sync” software running on my Mac.

This has been incredibly frustrating.

So it has been a week since I figured out that doing a system restore via the GUI (by connecting the EX4 via ethernet to the Mac) cured this problem.

I spent a fortune on this 16TB device and, although WD support on the phone were lovely, I wish I had chosen a different brand.

After the last firmware update I am also having all that issues to you listed. I bought my EX4 2 years ago and installed 4 red 4 TB WD HDD Raid 5 also on. Until last update I never experienced any issue. I found these suggestions (under my post) and did all of them. Now Ex4 working really fast and smooth even better then before.

Thanks LifeInBinary!

I have not been able to fully resolve all issues but number of occurences of each issue

has been lessened in frequency in which they occur.

After having purchased My Cloud EX4 I have experienced many if not all of what many of you also have experienced. And I have also found some resolutions.

1 - Network disconnects randomly after few min to few hours of use.

Fix: Set static IP address on the router so whenever device turns on it will receive a static IP automatically. (does not always work but helped make the issue occur less often) Also try changing Network speed from “Auto” to 1000 that way it forces Gigabit rather than 10/100 in case it’s trying to use the latter.

2 - Media service db rescan that resets to 0 and also uses up CPU.

Fix: Option 1, goto settings and disable Media server service, Option 2, goto your EX4’s Twonky server page ( http://yourserver:900016) and customize the media db by disabling search for photos and search for videos only as videos tend to be fewer and will generally finish quickly running the scan. Also make sure you uncheck in Twonky server settings rescan on IP change option.

3 - RAID rebuilds constantly and won’t finish or will freeze after

Fix: Try moving files out of the nas and let the scan finish in shorter time before it freezes, because if scan takes too long it ends up freezing the EX4.

4 - EX4 won’t shut down

5 - EX4 locks up and can’t browse the network share or access much of the web admin portal

Fix for 4 & 5, goto settings and under “Energy Saver” disable turn OFF the “Drive Sleep” option.

6 - EX4 does not see the external USB drive

Fix: try plugging the usb drive to your computer and changing permission on the drive to allow “Everyone” RW (read/write) access to it then replug it back into the EX4 and configure the share permissions Having experienced all these problems really were getting on my nerves and I was at the brink of returning this device to the store, except the store doesn’t take 30 day warranty on NAS products.

So I had a minor power cut and now the EX4 is behaving as it was AFTER the firmware update. I am at the end of my tether at trying to resolve this and have tried the following NUMEROUS times:

  • System restore
  • Router restart (and it is up to date in terms of its f.w) - a Netgear D7000
  • Assigning static IP on router and then on EX4 (and tried both and one and the other)
  • All the resolutions suggested by @LifeInBinary via @xderka
  • All resolutions suggested by my first 2hr phone call to WD support
  • Tried 10 ethernet cables
  • Reinstalled the firmware (which started all these problems)

The unit does NOT respond to the reset button on the back and the only way to reboot (other than via the GUI which disappears when the unit drops from the network) is to switch the unit off then on via the wall socket. If it does remain online via the network it stays up for between 2/3 mins to an hour before it disappears again. I have a Mac and a PC (laptops).

This is an expensive piece of kit which is now not fit for purpose. My mate has an EX 4 and yesterday I took this round to his and tried it on his network - it dropped almost immediately. After safely switching this off I took the drives out and popped them in his EX4 and all works - thus it suggests that it is the enclosure which is faulty. My EX4 even shows up that it is still connected to the network when you scroll through the menu on the unit itself (it says the IP Address even though the ethernet cable is not connected to the router!).

I created an RMA online and will call WD Support on Monday - am hoping that they can just send me an enclosure out and do a swap - do people think this is possible and is it a matter of just popping the drives into the new enclosure and all will be good, or is there more I need to do?


So I have just spoken to Maplin where I purchased this from and they are going to pick this up and provide a replacement and (hopefully) swap the drives over - will keep you posted.

Maplin have just delivered the new EX4 and they managed to swap the drives over so all my data has been saved. This UK company has exemplary customer services and reassured me throughout this exchange. They picked it up and dropped it off at their own expense with a very reliable courier service. All is good so far and I have not updated to the new firmware.

Western Digital could not guarantee swapping the drives over and if I wanted to have a new one delivered so I could so the data transfer myself, they could do this but with a hold on my credit card to cover the new EX4 until the faulty one was returned and tested etc.

So, I can confirm that the original EX4 was faulty but this only developed after the new f/w update - so am still unsure whether it was the f/w update which bricked and ultimately broke the device or whether it was inherently faulty.

Either way, I am happy I have a new device and so far so good.

My NAS did an automatic update and now only displays “Welcome to WD Cycloid EX4” and does not cycle through the startup process, attempting the “Power On reset” has no effect and power cycling onlr returns to the welcome screen.
I am concerned that pulling the plug too often may damage the 12Tb of data stored on the drives, even tho thy do not even seem to spin up.
This all occurred AFTER the latest automatic update.
Can anyone advise me on how to get this device un-bricked?

I feel your pain - my replacement is on the initial stock f/w and I haven’t installed the latest f/w after my previous issues. Have you tried another browser? Have you tried popping the ethernet cable direct into your laptop and logging in?