How can I disable the thumbnail building and scanning?

I use my MyCloud 6TB ONLY for:
Data Backup
access to videos (no Full HD) via WLAN on other devie

No DLNA or other functions are relevant for me.

So I WANT to disable:
Thumbnail building
scanning media files

becauss it takes so long time and decrease the performance drastically.

Is there a solution (without all the SSH tipps, I’m a newbie). THANKS

If one does a search they’ll find numerous threads where this is discussed. Here is one such thread:

The thread above goes into much more detail including how to stop the scanning at device bootup, but basically one uses SSH to access the My Cloud and issue the following commands to stop the two services that do the scanning until one restarts/reboots the My Cloud.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

Also see the following thread which has much more info on the media server within the My Cloud.

If you don’t plan on using the media server feature of the My Cloud then access the My Cloud Dashboard and disable Media Streaming and iTunes Server. Both settings are found on the Dashboard > Settings > Network page.


Hi Bennor,

yes I’ve read this hint with SSH - but don’t know how to to this :frowning: Would you assist me?

Media Streaming, DLNA and iTunes Server are already disabled.

Here are the basic/general steps if using Windows:

Note: Use these steps at your own risk!!! Issuing the wrong command (like apt-get) via SSH can brick the My Cloud rendering it unusable!!!

Note: The screen captures used in this post are only a general generic representation. You may see slightly different screens/texts/responses.

Access the WD My Cloud using SSH

Log into the WD My Cloud Dashboard and enable SSH. Navigate to Dashboard > Settings > Network > Network Services > SSH = On.

Download PuTTY from the following link and extract the file contents to your hard drive.

Using Windows File Explorer locate the folder where PuTTY was extracted and launch the file: PUTTY.EXE

In the PuTTY Host Name (or IP address) field input the name or IP address of your My Cloud. Leave the Port at 22. Note: You can save the settings to make it easier to access the My Cloud at a later time by hitting the Save button. Hit the Open button to start the SSH session. If you see a screen indicating a security certificate go ahead and click OK or Accept. You should then be presented with the SSH login screen.

The initial login is:
Login as: root
Password: welc0me

Note: That is a zero not an “O” in the password.

Upon first time login you may be asked to change the password. Do so, remember to write down/remember the new password as it is the password you will use for subsequent SSH login’s.

Once logged in one can then issue the two commands to turn off the scanning.

First type in the following command and hit the Enter/Return key:

cd ..

Next enter the following two commands, one at a time, hitting the Enter/Return key after each command.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

Note: One can copy the commands from this post and paste it into PuTTY by copying the command, then using a Mouse + Right click within the PuTTY command line interface to paste the command.

When finished entering commands one can type the command: Exit to kill the PuTTY session and exit the PuTTY program.

The two services will remain stopped until the My Cloud is rebooted or restarted. At which time those two commands will have to be run again.

There are numerous threads that discuss how to edit the startup file(s) to stop those services from running at startup or to disable those two services entirely. Here are two such threads that details how to stop those services from starting up.

1 Like

Hi Bennor,

thanks - but I got a Apple Mac running on El Capitan …

The general steps outlined above are similar when using a different SSH client program on a different OS like the Macintosh. You can do an internet search for how to use SSH on the Mac. Here is one such article:

On the Mac you would typically type in ssh in the terminal to initiate the SSH session with the My cloud. So for example you might type in something like: ssh root@wdmycloud or ssh root@, replacing the My Cloud name or IP address with your My Cloud name or IP address.


I will try this …

Using Putty as described. Never allowed me to type the password then logged me out.

Which single bay My Cloud version do you have? It appears the login name for he second gen v2.x firmware My Cloud units is sshd and not root with the latest v2.x firmware.