My Cloud - How to disable the content scan easily

I just want to use MyCloud as a simple network storage. The fact that it constantly scan for media files really annoy me. A previous post talk about this issue, but it is not for simple user like I am.

Is there a way to disable the content scan via any WD MyCloud SW?

There are two distinctly different scans that are performed; the first is the native scan of the data on the device, the the second is the scan of the Public directories by Twonky to load the DLNA services.

You can turn off Twonky thereby eliminating that 2nd scan but I doubt that there is a way to kill the first - and if your could you would have no data available! Remember, this is a server not a passive network drive.


To further my understanding, what does rebuilding mean?


It is scanning the drive to build the necessary indexes to support the services. If you stop it (reboot, for example) it will just start all over again when it powers up.

My advice in these cases is to WAIT until you see that the device is clear of any scanning activity, then do whatever tasks you like. Anything done before scanning is finished is slower (obviously) and may not be 100% complete/accurate.


Got it. I did a factory restore earlier due to admin password problem (separate issue, not related to the scan/rebuild). The restore (also cause reboot) caused the rebuild operation.

There are two services other than twonky that scan data. S85wdmcserverd and S86wdphotodbmergerd If you stop these two processes you should not have the scanning of the media.


Hmm, this is more information than I expect. But I am interested in understanding this.

Is there any document to describe how to stop this services? I guess I will have to connect to the NAS OS running in the My Cloud box. Or can someone describe the steps how to connect to the box?

You would have to SSH into the My Cloud. cd to /etc/rc2.d directory then sh S85wdmcserverd stop
The same for the other one.



you should disable the cloud access, this will also disable the media scanning.
Disableing twonky has already been mentioned.

Kind regards

I am using Mac. Upon started a terminal:
I enter the ssh MyCloud.local
I got the message said ssh: connect to host MyCloud.local port 22: Connection refused

Try using your mycloud’s IP address.

For details of how to stop the indexing:

The Twonky scan is pretty quick by comparison.

Don’t you think you should provide a little more information than that? Like how do we stop those services. I know we can do a lot more research but christ we are already putting up with this nonsense rebuild and now we just want to get on with using the device.

This is how you stop a service. Replace the S85wdmcserverd with any service name you want to stop.


Don’t you think you should read the rest of the thread, and the threads it links to?

We’re not WD staff. We don’t get paid to help you. We don’t have to do anything for you.

Be grateful that people are prepared to volunteer their time to try to help you, and be prepared to do some work yourself, and don’t expect to be completely spoon fed.

So a man just drowns, and you pull him from the water, I guess your job is done. Some people like doing half gassed work.

Of course you’re not WD Staff, they should have eliminated this problem so it doesn’t get asked. And of course the whole point of forums is so the company doesn’t have to pay to provide support.

  1. Log into your cloud.
  2. Turn on SSH in your cloud settings.
  3. Get an application like Putty to access your cloud though SSH.
  4. Open a Putty terminal and execute this/these command(s).

Ya, real hard to provide good help.


If you want to make the change described by @rac8006 permanent, then just rename the following startup script so that they won’t start anymore at boot time:

mv /etc/rc2.d/S86wdphotodbmergerd /etc/rc2.d/K86wdphotodbmergerd
mv /etc/rc2.d/S85wdmcserverd /etc/rc2.d/K85wdmcserverd

You can do the same for the twonky server should you not need it:
mv /etc/rc2.d/S85twonky /etc/rc2.d/K85twonky