MyCloud active but not accessible (indexing?). Is it safe to unplug it?

Hi all.
I have correctly set up MyCloud 3TB, have uploaded 250 GB on it on different shares. I was able to access it from different computers on the same lan, to access the web gui.
Then, as i connected to the MyCloud an external hd via usb, it stopped responding, as the web gui and the network resource are not accessible.
The mycloud is active, as on the front the blue led is on, and on the back side the bottom green led is on and upper one is blinking. I hear that the MyCloud is continuously writing/reading data.
I have read on the forum that it can be the indexing of files, but it appears strange, as it is going on since 2 days. If it helps, I had not disabled the option related to media content (even though i do not need it, as i won’t stream files like music or movies).
I’d like to know how can i access again the mycloud in a short time (as it contains work related data that need to be accessbile), within the limits of warranty (not SSH).
The 4 sec reset is not working. I’d like to do the 40sec restore and then disable the media content option, to prevent the indexing to run again. In order to doing so, i need to unplug the mycloud: is if safe to unplug the unit while it is writing/reading?
Thank in advance.

Power cycling the My Cloud while it is writing data has the potential to cause data corruption and or data lost. However, sometimes one has no choice. As long as one isn’t copying files to the My Cloud, or the WD Sync isn’t syncing files to the My Cloud, or Smartware isn’t backing up to the My Cloud, or the My Cloud isn’t performing a Safepoint/Backup one should be OK with power cycling the My Cloud and shouldn’t loose any data or have data corruption.

Ok, thanks.
I have unplugged the esternal usb hd and then i have unplugged/replugged power, without doing a restart or system restore. Now mycloud is accessible.
Before replugging the external hd, what can i do to prevent the mycloud to begin again to index files and subsequently freeze indefinitely? All the multimedia streaming/dlna option are already disabled.

There are several ways to turn off the scanning services within the My Cloud, but it generally has to be done via SSH. One can enable SSH through the Dashboard > Settings > Network page. Often people disable the following two services that deal with scanning/indexing media because they interfere with allowing the My Cloud to sleep when not in use. Issue the following two commands through SSH.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

There are ways to add those two lines so they run at startup every time the My Cloud is started/rebooted or do disable them entirely. Those methods are discussed in the following threads:

Ok, thanks.
Just another question: i’d prefer not to use SSH, as i do not want to risk voiding the warranty.
If I empty completely the HD and then I connect it to MyCloud via usb, without disabling the two services, should the MyCloud work or it is going to freeze anyway?

When connecting a external USB hard drive to the My Cloud USB port the My Cloud may try to scan the drive for file and folders. When a external USB hard drive is attached to the My Cloud it shows up as a single Share with the name of the USB device/drive. The My Cloud typically shouldn’t freeze or hang up when connecting an empty external USB hard drive.

There is more information on connecting a USB external hard drive to the My Cloud in Chapter 12 Connecting a USB Hard Drive in the My Cloud User Manual (

Thanks, the informations provided are very useful.
I’m going to disable permanently the two services, in order to guarantee the reliability and stability of the system.
By the way, i’d like to know if there’s a way to reverse the changes made, in case I will need to send the drive to assistance in the period of validity of the warranty.
For example: would the 40 sec-restore reset the services settings?


It would all depend on how you stopped or disabled the services. For example if one issued the following two commands from the SSH command line:
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

Both of those services would restart upon reboot or power cycle. If one adds those lines to their user-start file (/etc/rc2.d/S98user-start) then it would run at every reboot/power cycle. In which case if you are worried about sending the drive back in the stock state you can simply remove the entries in the user-start file. Apparently that user-start file is not affected by a firmware upgrade or possibly a system restore.

Ok. Unfortunately i’m not familiar with linux commands, so i’d need a walkthrough guide on how to add/remove files from user-start- file.
Btw, after reading the posts, I’m going to disable the services with the following commands:
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable
Could you confirm that:

  1. it is not possible to restore the automatic startup with a “physical” restore (e.g. 40 sec-system restore);
  2. it is possible to do so with:
    update-rc.d wdphotodbmergerd enable
    update-rc.d wdmcserverd enable

Hoping, in the case i’ll need to send the drive to WD tech support, that i’ll be able to access it via SSH (or, conversely, to have to send it because of a hardware fault, so that the modifications made become not relevant) in order to be convered by the warranty.

It appears based on prior reports that when people send a defective or malfunctioning My Cloud to WD, WD is simply replacing the unit. People have reported sending in an older v4.x version My Cloud and getting back a newer v2.x My Cloud.

There is no official “guide” on how to use SSH or issue Linux commands on this site. There are numerous threads that discuss how to disable wdmcserverd and wdphotodbmergerd. One can search the internet for more information and directions on how to issue Linux commands.

Basically one enables SSH within the My Cloud Dashboard > Network section. Then using an SSH program like Putty ( or WinSCP ( one can connect to the My Cloud using SSH to either issue the /etc/init.d/wdmcserverd stop and /etc/init.d/wdphotodbmergerd stop from the SSH terminal window. Or one can edit, again do an internet search to learn how to edit a file using SSH or a program like WinSCP, the /etc/rc2.d/S98user-start file to add those lines. If one is issuing the “stop” command to the wdmcserverd and wdphotodbmerged services through the S98user-start file there may not be a need to subsequently issue the update-rc.d wdphotodbmergerd disable and update-rc.d wdmcserverd disable commands.

I tried to do as suggested, but it didn’t work.
I entered the SSH commands and had some errors. Then, i did plug in the usb external drive (with data in it) and the mycloud hung up as before. I had to do a power cycle to have the mycloud working again.
I have the 2.11.140 firmware. Any suggestion?

Here is the SSH log:
root@WDMyCloud root # /etc/init.d/wdmcserverd stop
Stopping wdmcserver
root@WDMyCloud root # /etc/init.d/wdphotodbmergerd stop
Stopping wdphotodbmerger
sh: you need to specify whom to kill
root@WDMyCloud root # update-rc.d wdphotodbmergerd disable
-sh: update-rc.d: not found
root@WDMyCloud root # update-rc.d wdmcserverd disable
-sh: update-rc.d: not found


Ah; a ‘Gen 2’ device. Not sure if those commands are present, as it’s a different platform…

Ah you didn’t indicate your version of My Cloud previously. The SSH commands above are for v4.x My Cloud versions. Version 2.x My Cloud’s have a different Linux OS and files may be in different locations. You may have to root through your My Cloud via SSH to see if similar services are there and where they are located so you can issue the stop command.

Have you tested another USB drive to see if it too hangs up the My Cloud? One that has no data on it? Could be just that one drive is causing a problem due to the data on it.

Ok, i stopped wdmcserver, almost emptied the external drive, plug it in and the mycloud recognized it without freezing.
Now i can move on doing the backups, in a different post :wink: