Hidden .wdmc directories created by mcserver and photodbmerger and the deletion of them


#1

Although I have been very very happy with my WD Cloud device, I am extremely disappointed in the amount of tweaking that I had to do in order to smooth out my purchase.

Since I am a professional photographer, I have well over a million photos on the 4TB MyCloud along with a large collection of mp3’s, movies, ebooks and much more. When I owned a WD Live, the device was constantly indexing and now that my photos are also on the same device, I would get no response from the device because of WD converting of my photos into thumbnails. This thrashing causes the two common problems, 1. WD disconnecting from the network and 2. no response when plugging in a USB drive. In both instances, the device starts thrashing due to the scan.

Even though I have stopped the two services, scattered across my cloud device are thousands of .wdmc directories and I had to find a way to search and delete all the hidden directories. Since my PC uses Samba to connect to the device, I knew that Samba was hiding this directory from Windows and I had to unhide this.

So here are the steps to help you stop the scans (don’t do this if you are using twonky or DLNA) and delete all the .wdmc hidden folders using windows explorer. Sorry I don’t have a method for the Mac.

SSH to the device and lets stop the two services:

1. 

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

to keep it from restarting after a reboot 

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable

  1. head over to /etc/samba and

mkdir no

mv  smb-global_veto.conf no

Basically this hides the veto file from Samba, allowing the following hidden files to show up in Windows Explorer (.nflc_data, .wdmc and .twonky) 

  1. service samba restart

  2. head over to your PC and remap your WDCloud drives, then bring up explorer to explore the root directory and use search for all .wdmc folders.  Highlight them all using ctrl-a and press delete.

In the short amount of time that I allowed the services to operate, I had over 20,000 hidden folders. Of course this was before I realize how badly the services were thrashing my device.

The MyCloud app on my iPhone/iPad still works but I’m guessing that it is missing the small photo, however all I need to log into my MyCloud once in awhile to grab a ebook, music or stream a movie. 

Hope this helps… 


How can I disable the thumbnail building and scanning?
My Cloud - How to disable the content scan easily
My cloud 3TB with Twonky Media server
What is a .wdmc file
How do I improve my upload speed
Folders and thumbnails from private folder showing in all users
How to Delete .wdmc files and prevent creation
I have problem with subtitle Please help me
MyCloud active but not accessible (indexing?). Is it safe to unplug it?
WDMyCloudMirror cartelle .wdmc\transcoded_files
Missing 1TB of my 4TB dive all of the sudden
Blue LED, no connection to MyCloud
Where to put pdf,doc,txt or any other data question
WD My Cloud crashes in few minutes after having attached USB HDD (My Book or Seagate)
My Cloud Firmware 4.01.04.42​2 Feedback
Having issues copying files to my new 4T MyCloud
Idiot's guide to making WDMyCloud work - needed!
Issues about speed, index and USB.. any hope anybody?
MyCloud: Please DO NOT CREATE FILES and directories that I cannot control or delete
"Capacity Available" will not display in the Dashboad
WD - Frequently asked questions
New Release - WD My Cloud Firmware Release 4.01.03-421 (2/23/15)
WDmycloud not working after installing new firmware v04-01.02-417
Crash as soon as usb drive connected
No Cloud Functionality
ALL OF MY Cloud Problems Solved!
Easy method to downgrade to previous version of the firmware
Easy method to downgrade to previous version of the firmware
WD MyCloud and Boxee Box problems
File transfer performance and reliability on firmware v04.00.00-607
File transfer performance and reliability on firmware v04.00.00-607
Stop Thumbnail Creation for Audio, Video and Photos
Dashboard problem - No info in Capacity usage
WD MyCloud 3TB and Logitech's Squeezebox Radio
CrashPlan and My Cloud Drive
Moving itunes playlists & cover art
WD - Frequently asked questions
Stop My Cloud from crashing / freezing with an external USB hard drive
Oh no after a day of figuring out what to do, there is nothing at the link provided!
Can I connect My Cloud Personal 3TB NAS to a .local domain?
Please don't create .WDMC .TWONKY folders
EX4 Woes
High CPU issue
Firmware 1.05.21 - File copy fails due to long .wdmc paths
Stop creating .wdmc folders
Drive constantly working
General Feedback - WD My Cloud OS 3 Operating Software
MyCloud 2TB does not show capacity?
#2

Hello,

Thanks for sharing this.


#3

Are you sure it is

# update-rc.d wdphotodbmergerd disable

# update-rc.d wdmcserverd disable

And not

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable


#4

Of course it’s without the #s


#5

what andreaspf8585 said :stuck_out_tongue:

fixed… problem of copying and pasting across multiple windows… :stuck_out_tongue:


#6

Thanks for the info! :smileyvery-happy:

A couple minor suggestions to save time:

To stop the services restarting, just remove their execution permissions. You can do this by SSHing in and executing the following commands:

chmod 644 /etc/init.d/wdmcserverd

chmod 644 /etc/init.d/wdphotodbmergerd

Instead of telling samba to display the index directories, just wipe them out through the command line. SSH in, cd to the root of the share you want to clean, and enter:

find . -name .nflc_data -exec rm -rf {} ;

find . -name .wdmc -exec rm -rf {} ;

find . -name .twonky -exec rm -rf {} ;

These commands will delete all files and directories in the current share named .nflc_data, .wdmc, and .twonky, respectively. Before you do this, you may also want to run the following to view the files and make sure there’s nothing that you want to keep:

find . -name .nflc_data

find . -name .wdmc

find . -name .twonky


Please don't create .WDMC .TWONKY folders
#7

@Chyre, Thank you


How to stop from constantly building thumbnail previews?
#8

This has got to be the most valuable thread throughout these My Cloud forums. Thank you, Ralphael and Chyre, for these tips. I just bought a My Cloud and spent several days of my life trying to figure out why, after transferring a modest iTunes library (~40,000 music tracks, plus a handful of movie files), the drive was constantly grinding away, as if it were trying to mill peppercorns. All of the album artwork images buried in with the song track files were being indexed…My first transfer attempt slowed to a tiny trickle data long before it was even close to finishing. I started over again, this time making sure that all media serving was switched off before starting any transfers. Doesn’t looked liked that stopped any of the indexing/thumbnail making. So now I’m on round three, having wiped the drive yet again, but fortunately I found these tips before starting the transfer again.

I have a Mac and feel comfortable using Terminal’s command line interface for small things when I need to. But I don’t really know how to work with Linux, and in general I avoid following command line advice I find on forums unless I know as clearly as I possibly can what those commands are going to do. I’ll figure out how to SSH into the My Cloud’s brains with my Mac, but help me understand this. Once I’m there (any particular directory?), if I enter:

chmod 644 /etc/init.d/wdmcserverd

 followed by:

chmod 644 /etc/init.d/wdphotodbmergerd

then that will stop (for good) all this nonsense with the thumbnails and the .wdmc directories. I can enter those and then get the h3ll out. Is that correct? (I don’t give a d@mn about the built-in iTunes and DLNA servers.)

find . -name .nflc_data
find . -name .wdmc
find . -name .twonky

and

find . -name .nflc_data -exec rm -rf {} \;
find . -name .wdmc -exec rm -rf {} \;
find . -name .twonky -exec rm -rf {} \;

are for searching for and deleting, respectively, previously created cr@p files (not globally, but within whatever directory I’m currently in). Right?

Since I’m starting over with a fresh transfer after erasing the My Cloud, I probably don’t have to worry about any housekeeping, and the previously mentioned chmod commands will prevent me from needing to housekeep in the future.

Not sure if this thread is still watched, but before I mess around with SSH and possibly void my warranty, I’d be grateful if you could help me make sure I understand what I’m doing.

Thank you!!!


#9

Hello!

I’ve read all the forementioned tricks but i still need to ask:

is there a way to stop only the thumbnail creation/extraction (which pollutes the drive with useless hiddenfolders, since i don’t  browse photos via media client) while mamtaining access to my movies through dlna capable TV??

Thank you


#10

I need to disable these services when I try the commands below I get “-sh: update-rc.d: not found”.
update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable

I also tried the following commands, I used ls -l to check the permissions however after reboot the services are back running and the permissions have execute again.
chmod 644 /etc/init.d/wdmcserverd

chmod 644 /etc/init.d/wdphotodbmergerd

Am I missing something or is there no longer a way to disable these?

I’m on 1.03.41

Thanks


#11

Disabling wdmcserverd and wdphotomergerd got my CPU load down from an average of 7-10 to an average value of 3.

I would consider this step to be a top priority. The disk is much quieter too and the remaining processes/stuff visibly much more responsive.


#12

Can someone clarify what the wdmcserverd actually serves? It’s obvious what wdphotomergerd is about, but given the available demons on the units, it’s less clear what wd.mcserverd is about (at least to me). DLNA? SMB/Samba? Something different entirely? Some or all of the previous?


#13

DarrenHill wrote:

Can someone clarify what the wdmcserverd actually serves? It’s obvious what wdphotomergerd is about, but given the available demons on the units, it’s less clear what wd.mcserverd is about (at least to me). DLNA? SMB/Samba? Something different entirely? Some or all of the previous?

I’m curious about this as well. I know very little about Linux–actually I know pretty much close to nothing about it–but enough to to log in, stop wdmcserverd and wdphotmergerd, disable them so they don’t start up again on a reboot, and get the heck out. All I know is when they run, poop happens, and when they don’t, there’s no poop.

The moment I did that, the My Cloud worked exactly as I had hoped–quiet, reliable, fast, quick to work with attached USB drives, sleepy when there’s no activity, etc., etc. I have no clue what I gave up by disabling those demons. I stream the media I want using Home Sharing in iTunes, so I’ve always had the DLNA and iTunes servers disabled. But your post made me wonder what each of these things actually does. Stumbling on this thread turned my 2TB My Cloud into the fine, reliable NAS I had hoped for, instead of a furiously grunting, completely dysfunctional box that threatened to shorten my life by several years because of the frustration and even anger that it induced. My ill-advised update to v4 firmware when it was released made the nightmare start all over again, spawning many thousands of new hidden .wdmc folders all over the place. Ignorant of Linux as I am, I was really lucky to have enabled SSH so I could roll back to v3, verify the demons were still disabled, and remove the junk folders. Now I’m back in My Cloud nirvana.

If you don’t mind my asking (since it wasn’t clear to me), what was it that wdphotomergerd was doing?


#14

WDphotomerged as far as I can see is the demon which is for automatically downloading pics from cameras that are connected directly to the unit, and then indexing and categorising them.

I actually have a MyCloud Mirror, which usually sits at 80-100% CPU usage but doesn’t make much noise or get excessively hot and is responsive enough (it reads-out as healthy for temperature). It is connected to 2-3 computers which run Smartware continuous back-ups, and looking into what the processor is actually doing it has 2-3 corresponding SMB demons which I presume are the ones talking to the computers for the backing up. Those are taking 33-50% of the CPU each depending on how many are running, so it seems reasonable.

But of course I have no desire to have demons running for services I’m not using (I have DLNA and iTunes disabled also as I don’t need them, just SMB and occasionally serving over the net via the WD apps). Hence my question, as I don’t want to go disabling demons and then find I’ve removed items that I do actually need/use. I’m also not sure that what I need to be doing on my Mirror unit is quite the same as listed at the start of this thread, as the firmware is obviously different (I had a quick look, and some of the files/folders mentioned seem to be different or not there at all).

Hence I’m just a bit wary of going in via SSH and doing brain surgery as fundamentally the device is working fine (there are the hidden folders around from when I have tried the DLNA feature, but it’s off now although I haven’t gone and tidied up - it’s a 2x2TB device so I’m not short of space). But on the other hand I would of course like it as optimised and fast as possible…


#15

Has anybody noticed if the new firmware corrects this issue, version 1.04.04?

Also, I was never able to prevent those services from restarting after a reboot, if anybody knows how to do this, please let me know.


#16

The firmware seems to help my issue with wdmcserverd consuming the cpu, I’m no tsure if it is still creating the hidden folders.


#17

Well, due to the sound of the disks grinding away when they should be idle I’m going to venture the hidden file issue is not resolved, but I haven’t created a folder with files and checked.

If somebody knows how to disable wdmcserverd through a reboot, I would love to know how.


#18

Hi

Found this thread searching for cleaning up .wdmc files. I have a load of files with spaces in the paths so I looked further and found a superuser thread:

http://superuser.com/questions/792448/os-x-find-and-rm-recursively-through-folders-with-spaces-in-the-names

Basically if you have spaces in the path you can use the following command to clear out the .wdmc folders with spaces in path:

find . -type d -name ‘.wdmc’ -print0 | xargs -0t rm -rf

Hope this is of use to someone but all credit to go to the contributors to the above thread. 


#19

jovaitt wrote:

<…snip…>

 

If somebody knows how to disable wdmcserverd through a reboot, I would love to know how.

Probably not possible. The system ‘disk’ you are editing is a ram disk (/dev/ram0) and is reconstructed on reboot so no changes we can make will last through the reboot.

Have to log in and disable the wdmcserverd after every reboot, unfortunately. Fortunately you shouldn’t need to reboot very often.

The only way to make it permanent is through WD making it a configurable option through the web interface.

Matt


#20

Matt the post you replied to is from July. you can disable it, at least till the next FW update. With the later FW versions this seems to be handled much better and I am not sure there is any reason to disable anymore

the 1st 2 lines stop running processes, the next to prevent it from starting. just change stop to start and disable to enable to restore.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable