Hidden .wdmc directories created by mcserver and photodbmerger and the deletion of them


#21

I’m very new to using ssh and coud really use some patience and help. 

I entered the 1st command

/etc/init.d/wdmcserverd stop      -----     and got this result  Stopping wdmcserver

Awesome, it works, then i enter the 2nd command 

/etc/init.d/wdphotodbmergerd stop    ------    and got this result  Stopping wdmcserver
                                                                                                               sh: you need to specify whom to kill

  1. Ok? what did I do wrong?

So i procceed to enter the 3rd command

update-rc.d wdphotodbmergerd disable   ------ and get this result  -sh: update-rc.d: not found

Again, i procced to enter the 4th command

update-rc.d wdmcserverd disable  ----- and get the same result  -sh: update-rc.d: not found

Please help. I know that I’m a newb so please be kind. 

I used Putty to SSH into my WDMYCLOUDEX4

Thank you.


#22

sega

it looks like you are on the EX4 device if so you are in the wrong forum, this is for the basic mycloud only. there are a lot of differences


#23

ok, thank you very much. i was hoping they’d be more similar.


#24

I can’t be sure how different as I only have the basic but I believe it is even based on a different Linux distribution

I have seen a few other users post that the update-rc.d was not found, At lease I think I know why now.


#25

sega:

you got it, finally??

…happens to me the same… I have a WD my cloud, I access with ssh (BusyBox v1.20.2)

I entered

/etc/init.d/wdmcserverd stop — and OK

when entered
/etc/init.d/wdphotodbmergerd stop — show: sh: you need to specify whom to kill

and when I procceed to enter:
update-rc.d wdmcserverd disable — the result is -sh: update-rc.d: not found

please, help!!! 

Thanks! :slight_smile:


#26

Good day,

I succeed to stop the two services using the following commands:

/etc/init.d/wdmcserverd stop"

/etc/init.d/wdphotodbmergerd stop

Then, I tried the command:

“update-rc.d wdphotodbmergerd disable”

but I receive the following reply

-sh: update-rc.d: not found

Is there something wrong ?


#27

I’ve followed this before using PuTTY but now mycloud won’t let me in. Access denied after entering the user name…  I don’t have a password on it, didn’t have one before.  I put a password on and still can’t get in!!!  Any help would be great…


#28

Robalian, Are you sure you are on the basic mycloud? not the mirror, EX_ etc

they are not the same devices and this won’t work on the others

If you are on the basic single drive mycloud then somthing is wrong and I suggest a system only restore which will leave data and shares in place and everything else reset like new


#29

bishop0369 wrote:

I’ve followed this before using PuTTY but now mycloud won’t let me in. Access denied after entering the user name…  I don’t have a password on it, didn’t have one before.  I put a password on and still can’t get in!!!  Any help would be great…

Unless you modified the SSH configurations, what you’re describing is not really possible  (SSH’ing in as a user with no password is not allowed in SSH unless you’re doing Key-based authentication, which the My Cloud’s don’t do by default.)

I think you’re confusing the SSH credentials with the user/admin credentials, and they are not the same.


#30

You are right, I did get that part figured out. I was able to stop it again but I am unable delete those wdmc files???  Two of the drives I can remove and put in a dock to delete but the other two are raid’ed’; don’t think I can remove them and still access the files.  Don’t want to lose “my” files.  Dang WD anyway!  Can you give me a clue…


#31

I decided to follow numanoid’s advice on how to delete all the .wdmc droppings on my system, since I don’t need them, and they’re taking up about 100MB of space:

find . -type d -name ‘.wdmc’ -print0 | xargs -0t rm -rf

Login in via SSH.

Before I did anything else, I went to the top level of the user file system:

cd /DataVolume/shares

At least if anything went wrong with the deletion, it should only delete my user data, and I have that all backed up…

I also stopped and disabled the wdmcserverd and wdphotodbmergerd sevices.

Just to check what this command was going to do (I had a pretty good idea already), I ran the find command on its own.

find . -type d -name ‘.wdmc’ -print > wcjunk.txt

Note the change from ‘print0’ to ‘print’.  print0 uses a null character /0 to separate output lines, which is a bit unwieldy in a text file.  print uses a normal line feed.

Result: yes, it’s found lots of .wdmc leaf directories, and only .wdmc leaf directories.

Now to look at the deletion part, as that ‘rm -rf’ is a bit scary…

I checked the xargs bit with Wiki

http://en.wikipedia.org/wiki/Xargs

It’s being used to allow the output of find to be sent to the rm command, and seems to be a nice safe way of avoiding the pitfalls of spaces and commas in piped text streams.

rm -rf deletes the directory and any files and subdirectories.  As I said, a bit scary, so I wanted to make sure if was going to be sent a correct list of directories.

All looked good, so I entered the command, checked and re-checked I’d typed it correctly, added a background task ‘&’ to the end, and hit return

find . -type d -name ‘.wdmc’ -print0 | xargs -0t rm -rf &

This allowed me to keep doing ‘ls’ as it ran, to make sure it wasn’t trashing the entire disk structure.

Some time later, I got the command complete message:

[1]+  Done                    find . -type d -name ‘.wdmc’ -print0 | xargs -0t rm -rf

Just to check, I re-ran the earlier command to list all the .wdmc directories.  Result: none found.

So, thanks to numanoids for the deletion advice.  It worked a treat.


#32

Hi cpt_paranoia, can you describe the effect this has (if any) on the functionality of twonky and/or iTunes servers?


#33

It has had no discernible impact on Twonky. All album artwork is still visible perfectly. I don’t use iTunes, but I suspect that will be fine too. If you’re concerned, login via SSH, go to an album folder and manually delete the .wdmc folder. Then check that the artwork is still visible in iTunes. I’d probably have iTunes shutdown while you delete, so it will read the store when it starts up.

As far as I understand it, these processes are for cloud access, to provide thumbnails for the MyCloud app. I don’t currently use cloud access or the MyCloud app.


#34

Thanks, that’s good to know. Since I killed those services I was a bit reluctant to turn on the Twonky server again. Although I don’t really use it I’ll give it a try out of curiosity


#35

Have you seen my Twonky FAQ?

http://community.wd.com/t5/WD-My-Cloud/FAQ-Twonky-DLNA-Media-Server-Setup-amp-Use/m-p/860697

ps. Twonky creates its own database, and I’m sure that, given how poorly Twonky is integrated into MyCloud, there’s no relationship between Twonky and these services. If you look at the default ‘Ignore Directories’ list in the Twonky UI, you’ll find .wdmc in the list.


#36

It looks like enabling SSH will kill my warranty.  Really?  That’s just great. 


#37

What choice do you have? We are all in the same situation, so either we live with the My Cloud “as is” or try to make it useful. I seriously doubt WD will change these useless files from being created nor give a script file to be initiated that will delete the files without losing your warranty. WD has enough issues with just firmware at the moment.


#38

Really, you need to:

  1. Login via SSH as root (havign first enabled SSHD access via the web interface).

  2. Then use the three commands in this format to get rid of all the **bleep** directories:-

              find /DataVolume -name .wdmc -exec rm -rf {} ;

IOW: You want to start at the top of the data volume and work downwards until they’re all gone.

Starting the find command at ‘.’ will only do the current directory and any below it.


#39

If you followed my description, you’ll see that I changed directory to the appropriate place in my directory hierarchy:

cd /DataVolume/shares

Which puts me at the top level of the user data space.  There’s nothing above this point that has been indexed, or that I want to delete.

And, when using ‘rm -rf’, it’s wise to start in the right level of hierarchy, just in case you make an error with the find command.

It’s unix; there are a million and one ways to skin a cat. Will that ‘exec’ command cope with spaces in the paths?


#40

I can’t find a thread like this for the MyPassport.

On this drive the init.d there is no photoshare daemon but I did find these:

S85wdmcserverd

S92twonkyserver

S92wdnotifierd

I can’t stop the S92wdnotifierd

The update-rc.d commands don’t work.

Also there isn’t a specific veto file for samba, so I just made a back up of smb.conf and edited the veto line to remove the .* files.