Firmware 2.21.119 (9/20/2016) Discussion

New user here, updated my My Cloud 3T to 2.21.119 and no, there’s still no Shutdown option! Other than that it appears just the same. Windows 10 and Andriod.

Thanks for reporting that. Just as I guessed above. It’s been several firmware versions now and that issue for v2.x users still hasn’t been fixed. Which is stupid since it is such an easy quite literally a 5 second CSS code fix.

The current workaround for v2.x users is to use the WD Access program or use SSH to issue the shutdown command.

You mean the WD Quick View I assume? First thing I downloaded from here. I can’t bring myself to just switch the thing off!!! Does seem a bit ‘sloppy’ not to have a proper safe power down.

No I mean WD Access.
http://mycloud.com/learn/?id=mycloud#mc_download

The Quick View program hasn’t been updated since 2/26/2015 while the WD Access program has been updated as recently as 6/21/2016.

As I could check, WD Access doesn’t show any shutdown for My Cloud Gen2. Have you checked yourself or are you aware of any user providing this information?

Does the WD Access program show the My Cloud? If so but not showing a shut down button then for what ever reason WD hasn’t programmed it to shut down a v2.x My Cloud. Example with a v4.x My Cloud that indicates the option to shut down the My Cloud:

Could have sworn I read a post here by one of the WD staff that they were depreciating the WD Quick View program in favor of the WD Access program, but I could be wrong. Not finding that discussion in a search.

I just downloaded and installed the WD Access ( V1.4.5949.29996) - which caused the cloud to reboot btw - and the menu goes straight from properties to WD Learning Centre - No Shut down option.

Windows File Explorer. Seems like the login/credentials changed or something like that. I can browse all my shares but they require login’s and that seems not to be working anymore.

The same when using SMB:// on my video box that also access the storage. I can browse the shares but i can’t login on the shares anymore

Also the device isn’t browsable in Windows anymore on it’s name, only on its ip.

Hello,

yvonne_Arnoldus, iCra5h,

We have passed this along to support.

I’d opened help desk tickets about that, and they finally talked me through how to install WdQuickView, which comes up as a toolbar icon. Right-click it, hover over the WDMyCloud item, and then you have the shutdown command. Also, there are user guide items that talk to using PuTTY to remote SSH login and then issue commands.

Since installing the WD Access on my Windows 10 machine, every time I switch on the PC I’m informed that my WD Cloud is downloading new firmware, it goes through an installation phase and re-boots - I first thought “Great, they’ve sorted the powerdown problem and updated the firmware” But no, it’s still the same (2.21.119). Weird?!?
So I’ve uninstalled WD Access and the problems gone.

@Bill_S

Still no official notification thread.

And there are still two sticky thread notifications of previous versions of v2. Isn’t it time these were unstuck, and replaced with a new notification…?

Oh, and you may as well take down the data centre migration notice, as that’s (hopefully) done and dusted with no unfortunate aftermath…

I can´t access My Cloud through Windows file explorer anymore after the firmware update 2.21.119,
I can access it though the IP, and form my phone.

Try disconnect and remap.

RAC

I just bought an installed My Cloud 4TB, single bay with FW 2.12.xxx. It started fine with shutdown option. I’m running Windows 10. I mapped the new folders on it to specific drives and I can still see them on my windows Explorer.
I couldn’t see any shutdown option on the control panel and I was already using WD Smartware (old software cos the new software wouldn’t eject My Passport properly) which came with QuickView. It had the shutdown option so I managed to use it to shutdown once. The next time I started up the drive and pc, the shutdown option and the driveitself disappeared from Quickview. I can still see the mapped folders and access them fine but I can’t shut down still.
I tried updating Smartware but still no shutdown option and now My Passport is not ejected properly either. I tried updating the FW to 2.21.119 and still no shut down option. I tried installing WD Access, still no shutdown option.
The other problem I had was when I tried rebooting MyCloud on the user control page, it is permanently stuck on rebooting even after the light on the device goes back to non-blinking blue light. I have to restart my pc before I can access the user control page again. Now I have to shut down pc and then pull the plug to turn the drive off.

Is there actually a solution to actually shutting the NAS drive down from PC itself?

If one uses the forum search feature, magnifying glass icon upper right, they’ll see the issue of the missing shutdown button with the v2.x firmware single bay My Cloud units has been discussed at length with several options to shutdown the My Cloud.

The easiest is to install the WD QuickView program (http://support.wdc.com/downloads.aspx?lang=en) which has the option to shutdown the v2.x My Cloud.

Here is some past discussion (there is more) on the lack of a shutdown option within the Dashboard on v2.x single bay My Clouds:

https://community.wd.com/t/safe-shutdown/147307

https://community.wd.com/t/how-to-safely-shutdown-mycloud/155265

https://community.wd.com/t/missing-shutdown-button-and-no-hibernate-option/169745

https://community.wd.com/t/what-happened-to-the-shutdown-option-on-the-dashboard/173677

https://community.wd.com/t/where-is-my-shutdown-button-in-admin-panel/175229

Ya, I did a lot of searches and reading of the multiple threads. The problem is My QuickView doesn’t even see the drive and so I still don’t have the shutdown option even with the updated Quickview. :frowning:

Try uninstalling QuickView. Then disconnect/eject the My Passport from your computer. Reboot the computer, do not reattach the My Passport at this time, reinstall the latest version of QuickView downloaded from the WD Support link (Windows): http://downloads.wdc.com/nas/WD_Quick_View_Setup_for_Windows.zip

Then check to see if QuickView can see/access the My Cloud. If not then check to see if the computer’s firewall is blocking QuickView access to the local network. If QuickView can see the My Cloud then reattach the My Passport drive and check again.

Thanks?? Partial solution? Tried the suggestion. After reinstalling the newest Quickview, MyCloud was detected and seems ok. Plugged in My Passport Essential and both showed up in Quickview. Yeah! Great! Transferred files from Passport to Cloud and then tried to shut down, Cloud disappeared from Quickview. Ok…tried ejecting Passport first and then Cloud appeared back in Quickview with shutdown option but Passport still showing in Quickview and drive still spinning but not showing up in explorer and Quickview says 0% free space in Passport now…???
…ok…shut down Cloud using Quickview, exit Quickview and used Windows safe eject for Passport. Drive ejected but lights still blinking. Spinning seems to have stopped but last time I unplugged My Passport while lights were blinking, it got corrupted and I had to get it replaced so I dare not unplug Passport.
Long-way round to shutting everything down safely but manageable. Thanks anyway.