Firmware 2.21.119 (9/20/2016) Discussion

Apparently firmware 2.21.119 has been released for the newer generation single bay My Cloud.

Release notes: http://support.wdc.com/download/notes/WD_My_Cloud_Firmware_Release_Notes_2.21.119.pdf

Firmware Version 2.21.119 (09/20/2016)
Resolved Issues:
Resolved issue where macOS-10.12 user is unable to create a new Time Machine backup.

Direct link to firmware: http://download.wdc.com/nas/My_Cloud_GLCR_2.21.119.bin

Can anyone who updates their single bay v2.x version My Cloud check to see if WD fixed the missing Shutdown option within the Dashboard? My assumption is, based on past firmware’s since this issue has been reported, hasn’t been fixed.

My device got unbootable after that firmware… Nice WD, Nice

My device isn’t browsable anymore form my Windows 10 machine. Very frustrating and no backup

Not browsable using what? Windows File Explorer? Or using WD My Cloud Dashboard or MyCloud.com?

New user here, updated my My Cloud 3T to 2.21.119 and no, there’s still no Shutdown option! Other than that it appears just the same. Windows 10 and Andriod.

Thanks for reporting that. Just as I guessed above. It’s been several firmware versions now and that issue for v2.x users still hasn’t been fixed. Which is stupid since it is such an easy quite literally a 5 second CSS code fix.

The current workaround for v2.x users is to use the WD Access program or use SSH to issue the shutdown command.

You mean the WD Quick View I assume? First thing I downloaded from here. I can’t bring myself to just switch the thing off!!! Does seem a bit ‘sloppy’ not to have a proper safe power down.

No I mean WD Access.
http://mycloud.com/learn/?id=mycloud#mc_download

The Quick View program hasn’t been updated since 2/26/2015 while the WD Access program has been updated as recently as 6/21/2016.

As I could check, WD Access doesn’t show any shutdown for My Cloud Gen2. Have you checked yourself or are you aware of any user providing this information?

Does the WD Access program show the My Cloud? If so but not showing a shut down button then for what ever reason WD hasn’t programmed it to shut down a v2.x My Cloud. Example with a v4.x My Cloud that indicates the option to shut down the My Cloud:

Could have sworn I read a post here by one of the WD staff that they were depreciating the WD Quick View program in favor of the WD Access program, but I could be wrong. Not finding that discussion in a search.

I just downloaded and installed the WD Access ( V1.4.5949.29996) - which caused the cloud to reboot btw - and the menu goes straight from properties to WD Learning Centre - No Shut down option.

Windows File Explorer. Seems like the login/credentials changed or something like that. I can browse all my shares but they require login’s and that seems not to be working anymore.

The same when using SMB:// on my video box that also access the storage. I can browse the shares but i can’t login on the shares anymore

Also the device isn’t browsable in Windows anymore on it’s name, only on its ip.

Hello,

yvonne_Arnoldus, iCra5h,

We have passed this along to support.

I’d opened help desk tickets about that, and they finally talked me through how to install WdQuickView, which comes up as a toolbar icon. Right-click it, hover over the WDMyCloud item, and then you have the shutdown command. Also, there are user guide items that talk to using PuTTY to remote SSH login and then issue commands.

Since installing the WD Access on my Windows 10 machine, every time I switch on the PC I’m informed that my WD Cloud is downloading new firmware, it goes through an installation phase and re-boots - I first thought “Great, they’ve sorted the powerdown problem and updated the firmware” But no, it’s still the same (2.21.119). Weird?!?
So I’ve uninstalled WD Access and the problems gone.

@Bill_S

Still no official notification thread.

And there are still two sticky thread notifications of previous versions of v2. Isn’t it time these were unstuck, and replaced with a new notification…?

Oh, and you may as well take down the data centre migration notice, as that’s (hopefully) done and dusted with no unfortunate aftermath…

I can´t access My Cloud through Windows file explorer anymore after the firmware update 2.21.119,
I can access it though the IP, and form my phone.

Try disconnect and remap.

RAC