2.30.172 (11/16/2017) Firmware Discussion


#1

WD has released new firmware for the second gen My Cloud units. Feel free to discuss any issues or fixes below.

Firmware Release 2.30.172 (11/16/2017) | Release Notes

Download: http://download.wdc.com/nas/My_Cloud_GLCR_2.30.172.bin

What’s new!

  • Resolved SMB server (samba) security vulnerability (CVE-2017-7494) - Malicious clients can upload and cause the SMB server to execute a shared library from a writable share.
  • Resolved critical security vulnerabilities that potentially allowed unauthorized file deletion, unauthorized command execution and authentication bypass.
  • Improved Cloud Access connectivity from the device.

#2

Yaaaay. And still no SHUTDOWN button in dashboard which I was asking on January. And I still hope I don’t have to restore my files, since I don’t know what the system did witch Czech diacritics at filesystem. Only thing I know is, that it did mess when playing movies through SMB share…


#3

Just a quick info I had searched for CVE-2017-7494, it is half a year old?!?!?


#4

People have been demanding the shutdown option be re-added to the Dashboard since the initial release of the second gen v2.x firmware when it was removed from that firmware. From the Cloud Ideas subforum…


#5

WD has been unable to add <button tag for a year and 2 months? You must be joking…

I guess I will be better with Debian or better OMV…


#6

Unfortunately its not a joke. WD has, for what ever unknown reason to we end users, decided that the single bay v2.x My Cloud doesn’t need a shutdown option within the Dashboard like the older v4.x version has. Instead one is supposed to use WD Quick Access. One can search this subforum for “shutdown” to find numerous past discussions on this particular issue. There are a few unofficial alternatives from using SSH to using a web browser hack to unhide the shutdown option in the My Cloud Dashboard.

WD has a specific Knowledgebase article on how to shut down the single bay My Cloud units.


#7

Thanks. That doesn’t make sense… I can do everything in Dashboard, but shutdown. Even though at other platforms it is used.

Other thing I have problem is, that fw 4.x is older than 2.x, but I guess I don’t have to search for logic there…

Thank you mate for your patience.


#8

We know… Quite a few things WD does don’t make sense…


#9

I am quite curious about this item in the release notes:

• Improved latency of displaying thumbnails on mobile & web app.

I have seen at least two reported instances of very sluggish behavior, including stalls on transfers, from users reporting having upgraded to this firmware. I am cautiously suspecting that the indexing daemon is more aggressive, and they did this to “resolve” this issue. The thumbnail generation software is notorious for having… “Issues”, including the “Spends hours trying to parse a single file” issue. Imagine if they gave it a higher priority in order to “resolve” the latency issue they claim to have fixed?


#10

No… it would all have been thoroughly regression tested, wouldn’t it…?

[where is that tongue-in-cheek emoji…?]


#11

Still no word on High Sierra support??? Does this firmware address this ongoing issue?


#12

Since the update I haven’t been able to log into the dashboard via Chrome, though it works in MS Edge. Anyone else having this issue?


#13

BTW, I’m glad to see WD have posted a sticky thread announcing the new firmware…

Oh, they haven’t, have they…?

Not on this forum, at least.


#14

WD did update the existing stickied thread with the new firmware…

New Release - My Cloud Firmware Versions 4.05.00-315 (4/19/17) & 2.30.172 (11/16/17)


#15

Well, it came unstuck pretty quickly, then…

After the last announcement, that stayed stuck for months afterwards, and the previous release announcement remained up even after that was taken down… Maybe it’s because they edited an old thread to add the new v2 announcement.


Is new firmware 320 out?
#16

Must be unstuck on your end. :wink:

Its tacked at the top for me (logged in), and when not logged in. Non login looks like this…

Edit to add: Logged in looks like this…


#17

They can’t even get a forum working properly…


#18

Has anyone posted a summary of what the new firmware does—in relationship to the many complaints posted here? Specifically the remote access issue(s)?

Thank you.


#19

Thanks for fixing SambaCry (which is now more than a half year old, https://www.samba.org/samba/security/CVE-2017-7494.html)

what about new fixes, like this, 2-3 days old (https://www.samba.org/samba/security/CVE-2017-14746.html - https://www.synology.com/en-global/support/security/Synology_SA_17_72_Samba)

what about the V4 devices?

this is unbelievable, please update these linux server more quickly


#20

Aha! It appears there is an ‘unpin’ button on that thread. I didn’t think I could pin or unpin a thread (only moderators could), and don’t remember doing that…