Files.mycloud login down?

I keep trying to access my cloud remotely through http://files.mycloud.com/login.php and it just loads a blank page.

I just want to be reassured that the problem is not on my end

I tried logging in on 2 different devices on 2 different networks and I still get the same blank page.

The webpage is loading for me.

Any idea what would be causing this for me?

The only thing I notice is that your link is HTTP, and not HTTPS, as it should be. Or maybe you have a blocker in your browser, which prevents you from being redirected? That files.mycloud link redirects to idp.mycloud. Try disabling any extensions you might have added (except maybe HTTPS Everywhere, if you have that). Which browser are you using, by the way?

I’m having the same issue…chrome browser and my url is HTTPS. I’ve factory reset and been on the phone w tech support and no one knows why I’m having this issue …I also can’t get the dashboard to generate any codes to activate the cloud on my android using the mycloud app

After no changes on my part, I went to the same site again today and it successfully redirected me.

I have no idea what fixed this. I am still using Chrome, still have addons enabled (one of them is AdBlock), and still am on the same device/network.

Anyways, hope it works for everyone else, thanks.

1 Like

I’m having the same issues still…I’ve factory reset my cloud device and my router and my browser and I still can’t access mycloud.com. …and the my cloud app don’t work either …but the dashboard runs great and says the cloud is ready and working lol…I can also watch all my movies from the cloud also on my samsung 50" smart tv…this is becoming very asinine and I’m not the only one having issue w. This…I’ve called customer service and still no help or any idea why this is happening…I haven’t changed anything and it worked great since I bought it in feb…I’m bout ready to just send it back. I’m still under warranty

So I took a nap after posting previously. …and now it magically works …it’s 100% safe to say it’s not the consumers fault at this point …obviously it’s a WD service problem…glad it finally got fixed

Hi. I am having the same issue, the app doesn’t work and can not log into the file.mycloud site. Are WD having problems with their servers?

Same issues here. No access to mycloud.com’s login page and no cloud access to my EX4100 or PR4100.

Hi all,

I have same issue, and I am from Hong Kong.

I don’t think this is my drive problem as I have remote access to my home computer and checked, it can access via LAN.

Also when I access to mycloud.com, and click sign in, it return a blank page, I have not signed in yet, so the issue should not be on my drive.

I also tried to access via iPhone app, but it always say my drive offline.

Tried to access mycloud.com, and click sign in from different device / browser and all the same.

So the issue is on WD unable to load the sign in page.

WD should have someone to fix it immediately!!!

Same issue in Ireland. Was working last night when I first set it up - not working today either in MyCloud android app or in 2 browsers on Linux desktop

Same here, trying to access from Croatia (MyCloud EX2). I have it for a month now, and I must say the Cloud access is more often not working than working. In fact in these 30 days it was working 3-4 times, while for the rest it was not accessible from the outside.

That should be really embarrassing for a company like WD. I went for a brand rather then for a budget product, but now I see this was a huge mistake.

P. S. No, it has NOTHING to do with my router, or the software, or the fact that “it needs a factory reset” - because occasionally (seldom, though) it does work with the same setup.

http://files.mycloud.com/login.php is responding with the same blank page it has been displaying for a week now. This needs to get fixed ASAP. Every browser, every device.

The latest post from the WD Staff is mycloud is running stable. I however am still getting the same problem and it has been almost a half hour since it was “resolved”. Are there any others getting this still getting this problem?

still drawing a blank page. they need to get ANY developer to handle these javascript exceptions. looks like someone probably commited a dev branch. oops!

I have a slightly different error. Perhaps they are working on it.

Hi @ac_crusade & @cmmiller80 - Thanks for reporting that you are still having issues. I’ll pass along the error screens to the team that was working on this issue.

EDIT: Actually, before I do that can either of you confirm you are still having issues? It’s been a few hours since your post and if this was DNS or a networking issue of some kind it sometimes takes a few hours for changes to reach everywhere.