Files.mycloud login down?

Hi @Great_Scottt, I am still getting the same error. I have tried multiple browsers and have cleared the cache as well. If I try http://files.mycloud.com/ or https://files.mycloud.com/ I can see the option to sign in but then returns to a blank screen as well.

Thanks for the additional information.

I believe the service is back in working order. I was able to login via mycloud.com this morning.

Awesome. Please let us know if the issue occurs again.

I’m afraid I still have the problem partially. I still unable to connect via desktop. I have clear the cache in both a firefox and IE to test and still end up at a blank screen. However, I took a phone that was not connected to the wifi and was able to get to sign-in and find the device is showing offline.

I have two other users that are setup to the drive and I had them try as well, but they are coming up to the blank screen as well. We are both in Idaho and have cleared our cache.

i still cant list my files from Mycloud.com
it says Nas (the nick name of my My Cloud device) is off

but i can get in to it from the android app,
please help !!

After another couple of hours, I was finally able to login and had the same problem as @WebsGhost. I was able to connect back by rebooting the drive and then turn off / on the remote cloud access. I then checked the router and had to reboot and make sure the ports were open then reboot the drive once more.

I originally tried to deal with the router first but the drive was not communicating to the router or at least I could not see it via the logs. After the steps above, I could finally see it in the logs and then on mycloud about 10 mins later.

@ac_crusade

look at my thread !! you won’t believe what I had to do for resolving the problem

I am also having this same issue.
This has been going on for about two months.
Edit. Sorry for the Necro post. Wasn’t paying attention.