My cloud website login page is Blank

Hi all, login page is blank for web acces.

The same for me, trying to access from Barcelona (Spain)

Same for me. Trying to access from Australia.

Tried to use both the HTTP and HTTPS links and both fail to a blank page.

If you hit “back” on your browser, it’ll bring up the usual log in page, but the moment you try to log in, it will send you back to no man’s land.

That is, it redirects you to https://idp.mycloud.com/idp/SSO.saml2 (plus bits at the end with session ID’s etc which I won’t include here) and when you try logging in it redirects to https://idp.mycloud.com/idp/8imn9/resumeSAML20/idp/SSO.ping then takes you back to the brand page that asks you to click to log in page (https://files.mycloud.com/index.php?error=true&brand=webfiles) then when you try logging in, blank page again. SIGH.

Would be nice if you guys had some active monitoring in place - I’ve been having this issue for hours before you eventually put an update on your status page.

Unable to register my device after I ran into issues with the latest firmware and had to do a System Restore - since then I have been unable to register it.

Starting to regret buying this NAS…

1 Like

Mycloud.com is now back online.

Have same problem. files.mycloud.com/index.php?error=true&brand=webfiles
For one week already maybe more