Sign in web page will not load: http://files.mycloud.com/login.php

I’d problem connecting remotely to the EX4, using the MyCloud app. When I tried to investigate the problem it seems like there migh be some central issue with the MyCloud services?

Anyhow, when trying to sign in via a web browser on the following url http://www.mycloud.com I’m transfered to the following url http://files.mycloud.com/login.php, a page that doesn’t load.

Do anyone know if there is a central issue right now?

I’m having the same issue, backed up all my files and did a full factory restore on my cloud . And it didn’t fix anything…

Thanks, good to know that I’m not the only one experiencing this. I guess it will be fixed on Monday, if they’re not all on vacation :slight_smile:

Still not working for me…what gives? Really need to be able to access remotely.

It isn’t working for me either. However I’ve now discovered that I can reach this log in page by using another ISP (used my mobile disconnected from my Wi-Fi). I also connected a computer directly to the fiber converter, i.e. skipping the router, and I can’t still load this sign in page.

I therefore suspect that this sign in page is using some protocol or so that’s being blocked by my ISP.

I have the same problem.

I’m having the same problem. I can use the My Cloud app on my ipad when I’m on my own network but not anywhere else. I tried logging out when I was at another location and then logging back in through the app and received an error message that either the email or password was wrong. I then tried to do a reset on the password and received a blank page. When I returned home, I was able to login with no problem using the app and the same email and password that I had previously received the error message for.

When trying to access mycloud.com via a web browser on either my laptop or ipad at either home or away I click on the 'Sign In" button either on the page or the top menu bar and it goes to a blank page.This has been going on for over a week.

Until about a week ago, all of this was working flawlessly both when at home or when I was away.

I can access the drive at home using WD Access with no problem. Seems to me the problem is at WD’s end.

Patti

We have passed along this information to WD Support.

This is still an issue for me was well, using chrome, firefox, or IE 11. Is there an update on this?

1 Like

Don’t know if this still needs a solution given this topic is almost 2 years old, but just in case: the issue of the blank page when clicking the login link in the WD website is that the link/button (Sign in to My Cloud) takes you to http://files.mycloud.com/login.php which is not the correct url. This should rather be “https” (with an “s” at the end of http) in the beginning. By typing in the correct url address (i.e. “https” rather than “http”) it solved the problem for me.

I’m having the same issue. After login I’m redirected to https://files.mycloud.com/home.php?brand=webfiles . The page never resolves. Is there a fix for this?

I’m having EXACT the same issue. After login I’m redirected to https://files.mycloud.com/home.php?brand=webfiles . The page never resolves.

Is there a fix for this?

Thanks
Al