Cannot login into mycloud.com

When I try to login into files.mycloud.com I get the following error, and the page stuck on “signin in…”, can you kindly fix it? thanks

@dontbeevil What troubleshooting steps have you taken, if any? Have you tried a different browser?

What type of device, operating system, and browser are you using to try and sign in with?

Edge Dev Version 77.0.197.1 (based on chromium)
I tried also with Edge with internet explorer emulation and I get the same error (always worked till few weeks ago, even if “in theory” is not supported I know)

I’m getting the same, can’t login to mycloud.com using Chrome, Windows 10 Home, MyCloud PR4100.

pareil!!!

("." replaced with because this forum does not allow me to include website links in my description of the problem logging into a Western Digital My Cloud website)

Same problem: files mycloud com/login.php and idp mycloud com are not responsive. This is the destination for pressing the login button for My Cloud at mycloud com and files mycloud com.

Using Chrome Browser on Windows 10 through my Xfinity internet service provider, using Safari on iOS 12.3.1 through Xfinity ISP, and using Safari on iOS 12.3.1 through Verizon cellular data plan.

Also, same result using the service at “Is It Down Right Now?” :

idp mycloud com/idp/sso.saml… URL Checked:

no response Response Time:

unknown Last Down:

DOWN

Idp mycloud com is DOWN for everyone.

It is not just you. The server is not responding…

I have the same problem. everything else is fine. just cannot login into mycloud.com website

1 Like

I’m going through the same issue. I’ve tried with different browser (Firefox, Safari, Chrome) in OS X El Capitan 10.11.6, with Explorer in win10 and with android mobile apps but it doesn’t work.

I am also having same problem, tried on Win 10 Home Pro and Chrome+Firefox+Edge with local isp, tried on mobile chrome with mobile isp, tried on 4 different locations in my country… Nothing works… Page just doesnt load and gives “[HTTP/1.1 503 Service Unavailable: Back-end server is at capacity 0ms]” error

I’m just wondering how they test they’re stuff in WD

Doesn’t look like they do. Someone at WD needs to pull their thumb out of their ass & fix this.

Dear WD Community.

We are working to resolve the issue with MyCloud.com and apologize for any inconvenience.

WDStaff

3 Likes

Dear WD Community,

The issue with MyCloud.com has been resolved.
We apologize for any inconvenience

WDStaff

2 Likes

I just tried with new Edge (chromium) normal refresh, hard refresh and empty cache and hard refresh, still same issue.

I tried in private mode and it works.

I also tried to clear all cache and cookies for files.mycloud.com but still doesnt’ work… maybe I’ll try to clear all browser data later, but I’d prefer if there would be no need

@dontbeevil I recommend using a supported browser such as IE, Firefox, Chrome or Safari.

Guys with chrome that had my same issue, can you kindly check if you have still the same issue without clear the browser data?

@dontbeevil login works fine. You may have a different issue unrelated to the login issue reported and fixed in this post.

yes as I said before, login with clean cache (in private mode) now works, I want to understand if people with chrome (because the new edge is based on chromium), have the same issue. I can’t clean the cache, yet

Still having issues. Cannot login.

yesterday it worked shortly but today same issue with this in the meanwhile ■■■■■■■ product.
I am not able to reach my data from any external computer, different browsers tried as well