Crash as soon as usb drive connected


I have a 2tb mycloud drive. Its set up on my netwrok and works fine until i try to connect my 1tb WD Mypassport drive to it.

The moment i connect the drive the Mycloud crashes and i cannot connect to it in any way. I am forced to remove the usb drive and pull the power from the mycloud drive in order for it to reset.

The USB pssport drive works fine on every other system.  Does anyone have any ideas?

Ive read a post about removing a power save mode which im going to try other than than i was wondering if the drive has to be formatted a specifice way to be compatible?

Any ideas is much appreciated.


Hi and welcome to the WD comunity.

What firmware version do you have on your My Cloud unit? I would also like to know what file system the Passport is formatted in.

Try to do a System only factory restore to see if the drive has the same issue afterwards.

here is a link that can help you with the system only restore on the unit:

Hope this can help you out

I worked for about a month to solve this, both inclusive of and independent from tech support from WD.  I had a similar issue.  I would connect a 2TB external drive with a large number of files on it, and the MyCloud would become inaccessible after about four minutes.  An SSH session revealed nothing I would consider unusual, and I could talk to the drive just fine that way.  But the browser interface was hosed and would never come back, even after a full day of it sitting there.  The drive would also never sleep in this condition.

I was under time constraints, and trying solution after solution takes a fair amount of time.  I was able to narrow the behavior down to what I believe are two possible causes:

  1. Filename paths that were too long.  This 2TB drive contained a brute force copy of a notebook hard drive, and some paths very very, very long.  I discovered this issue when working with the drive under Windows, and I presume that the same issue could be a problem with the OS in the MyCloud, as paths become even longer appended to the file system of the MyCloud as an additional share via the USB port.

  2. Invalid characters in filenames.  I found that things like the DivX package I was using did things like create filenames with characters like ® in them (really, guys?). 

By eliminating some directories (I cannot tell you which of these two were really the cause), the issue went away.

I am leaning towards #2 as the true cause of this behavior, and think more error-trapping on WD’s part may be the final solution.

1 Like

I’ve been struggling with this frustrating issue for some time now. I have two USB HDDs which I use for alternating safe point backups of all the data on my 2TB My Cloud NAS. One is an older WD 500GB My Passport Essentials. This disk never has any issue. The other is a new WD 2TB Elements. This disk has the issue every time, but ONLY when it has the safepoint data on it, and NOT when it is blank. When I first plug it in, the My Cloud crashes, and I have to hard reset it. Then once it’s reset and I plug in the 2TB Elements USB disk, it’s fine, and I can do the safepoint update. 

So I’m confused how the issue could be related to path length or characters, when one disk has no issues (both disks have the same length name). But similarly, if it’s a hardware issue, why does the disk only have an issue with the backup data on it and not while blank? 

The 2TB Elements USB disk is always fine when plugged in to my laptop. I always use the same USB cable when plugging either disk in to my My Cloud. Both disks are formatted in NTFS. 

I have the latest firmware on my My Cloud, but the issue has been present since December 2014 (when I bought the 2TB Elements USB disk), so it has probably been present across several firmware versions. 

If anyone has worked out the cause of this issue, or solution, I’d love to hear about it…!!! 

I have two 4tb MyClouds each with its own 4tb WD MyBooks attached for regular safepoint backups. The only way that I have been able to have reliable USB connections and safepoints is by downgrading the firmware to v3

If you are happy to downgrade, finish this off with a system only restore and check your USB drives for errors on your computer.

1 Like

I have the same problem here on my WD My Cloud (4TB version). Each time I attach my drive the Cloud crashes. I would appreciate a fix for this problem. No matter what the reason is (long path or funny character or many files) the Cloud should handle that.

<No matter what the reason is (long path or funny character or many files) the Cloud should handle that.>

Of, course it should but the bottom line is it doesn’t without some work from the end user. Check my post above and downgrade the firmware. Then, you can SSH into your MyCloud and stop the scanning services that cause the other problems.

Once you’ve done that you will have a device that you can actually use properly

No matter what i plug into the back of mine it crashes as soon as i try to access it throught the WD software. So I have leanrt that as soon as i plug a usb device into the MYCloud i alsways reboot it before i do anything.

It then works ok.

And the same goes when ejecting and unplugging the usb device. I reboot the MyCloud again.

I know I shouldnt have to but its the only way i dont get any crashes or freezing up…

i have same issue , but this way is not right , any other solutions ?

your solution does not work for me