WD My Cloud won't recognize USB Drive

Hi there,

I just bought a 3TB My Cloud drive and set it up two days ago. So far, it works fine (mostly…though Capacity still shows a - instead of a number).

However, when I try to add my USB 2TB WD My Passport Ultra drive to the back, it won’t recognize it at all. Now, this drive is working fine, formatted for Mac, and I know it works because it was my previous “backup” drive for my Mac.

So what do I do to get it to recognize this drive?

Thanks for any info.

Hello there,

Welcome to the WD Community. 

Have you tried resetting the drive and connecting the unit again?

Just to make sure that I get this right, when you connect the drive and you try to map the USB drive, it wont show up on the list?

tyrionbean wrote:

Now, this drive is working fine, formatted for Mac, and I know it works because it was my previous “backup” drive for my Mac. 

When you say you have it formated for Mac, does that mean you have formatted it on a Macintosh for one of the formats that the WD My Cloud supports? From the  WD My Cloud User Manual (page 111):

The WD My Cloud device supports the following formats for externally attached USB drives:
 FAT32
 NTFS (read and write capability)
 Linux Ext2, Ext3/Ext4

I had similar issues with WD My Cloud on the current firmware.

Both with my WD My Book as well with my WD Passport Ultra external USB drive the following worked:

Connect USB drive directly to the PC

Drive will not show in Windows Explorer

Open Windows Disk Management Utility

Right-click on the drive and assign the missing drive letter

Safely remove the drive from Windows

Reconnect the drive to your WD My Cloud

I had previously tried to reset My Cloud several times but only above method worked. 

Sorry I took so long to reply. Thanks for your answer. I just got back to the problem and it’s default Mac drive formate (first on the list) Mac Extended Journal, I’m pretty sure.

I was going to reformat it soon anyway so I guess that might work and I’ll post again if I have any problems. Right now, it still has a few files I will want to transfer and then make sure that everything is working and settled in correctly on the new drive. It’s not an emergency so I have time to do it all. :slight_smile:


I also have had problems with th USB recognition and I have found a very lowpractical solution to the problem.

First though I went trough all kinds of testing and formatting and so on … well, why talk about what’s not helping…

To do this you have to connect your external drive to a computer. I use ‘Total Commander’ (a free disc handling program) to perform these operations.

To recognize your (eksternal) drive, the WDTV has to have a certain DIR in the root of the drive. If it doesn’t have that, simply create a DIR called [.wd_tv] without the paranthesesis.

= ‘period’ wd ‘underscore’ tv.

  • .wd_tv *

That simple, (and without without the *.)

(Inside this DIR you may have to create a subdir named ‘thumb’ and inside that a new subDIR called ‘XXX.mkv.thumb_100x139’ or something. )

That’s an exact copy from my external HD. Maybe it’s enough with the first DIR. I just found out yesterday so I haven’t had the time to test the minimum requirements. Maybe someone else has the time to figure that out ?

I guess the problem is that sometimes the WDTV fails to create that DIR and so cannot ‘see’ the drive.

I was ready to throw my WDTV away, before I found out what was wrong. Now I’m happy again.

Regards and happy Christmas,


@Dan_Vidal, please note that this subforum is for the WD My Cloud and not the WDTV. They are two different devices. The problem with the WD My Cloud is some users, including myself and I would venture to guess the person who started this thread, are having trouble with certain USB drives not properly being mounted by the WD My Cloud Debain/Linux firmware. In my case the logs for the My Cloud shows that the firmware is seeing the drive, but for some reason the firmware treats it as read only, then fails to mount the drive. In my case this problem with certain external USB drives that I have started with the OS 3 firmware on the WD My Cloud.

1 Like

My problem is that the WD sees the USB attached drive (3T Seagate) sometimes and not others (on the control panel). Hence when not visible you cannot perform a back up. I tried loading WD Quick View but the install fails each time. Using a Mac (2011) running Sierra.



1 Like

Okay, I have just bought a MyPassport Ultra and my new PR4100 will not see it. I kind of thought that being both WD devices they should play well together. I have used two old LaCie USB drives and they work fine!

You may want to post your issue to the dedicated PR subforum where people more familar with that unit may be able to assist. This subforum (My Cloud) is primarily for the single bay My Cloud units.


Certain versions of the single bay My Cloud unit may use different firmware than the PR units.

I have a 2TB My Cloud. I managed to get all set up but having problems connecting a My Passport 1TB via USB. The My Passport is Windows NTFS. I want connect using USB to transfer video files to My Cloud directly rather than over the network. My Passport is recognised when connected to any other device. When I first set up the My Cloud the My Passport was recognised intermittently. Any ideas would be appreciated. Thank you in advance.

I was having the same problem. Reformatting, changing file systems, updating the firmware…
What worked for me finally is that I plugged in the USB drive (2TB My Passport), then rebooted the My Cloud NAS. Only then would My Cloud recognize and mount the USB-connected My Passport. Subquently, when I ejected, unplugged, then replugged the My Passport, would My Cloud consistently recognize it.

I am not sure that with all of the similar questions for this topic, why WD does not post a comprehensive support note.

If it means anything, after a reset, mine started working correctly. That was all it took.

I’m having a similar issue with a new 6TB My Book plugged into a 4TB My Cloud. I get an Unsupported File System error:

Unsupported File System
An unsupported file system has been detected on a USB device (vendor Western_Digital, model: My_Book_25EE, serial number: xxxxxxx, file system: N/A, label: N/A). Please remove the USB device.
Monday, 2017 February 20, 8:23:15

The drive is recognized properly when plugged into my Windows 10 PC. I’ve tried to restart the My Cloud with the My Book plugged in but I am still getting the same error. Thanks for any help!

1 Like

Hey Kelly, my My Cloud stopped responding to any external drive being plugged in. I raised the issue with western Digital and they have advised me to return it the retailer. Hope you find a solution. :wink:

I replaced one of the two drives connected to my NAS and then found both unrecognised.

After trying many of the solutions here (reset system, put USB drive on PC and ejected etc) what ended up working for me was rebooting the NAS without any USB drives connected - then connecting them after reboot - both now recognised - Yay!

out of the box the my book is exfat, should i reformat it to ntfs? (side note/rant, out of the box its only showing 5.45tb of free space. i understand some loss in formatting, but that over half a terabyte!)

i went ahead and formatted ntfs and all is now working as it should. this thread is a good discussion of the issue, and confirmed that exfat isnt recognized by the my cloud

1 Like

Thanks for the tip, Kelly. Performing an ntfs Quick format to My Book is an easy fix for the issue with the My Cloud usb connection. After reformatting to ntfs on a 4tb My Book, it was recognized by My Cloud and worked like a charm.

it is still happening. the software guys did not finish their progrmming classes and WD has no test engineers that they dont relaize wd dri ve cannot recognize WD drive.

1 Like