MyCloud 4TB - Cant recognize external USB3.0 HDD

Hi guys,

I have used my nasdisk MyCloud 4TB for few month, with all my stuff, and now i’m going to ensure backups using the SAFEPOINT feature.

I have bought an external 2T HDD which connects to USB3.0 ports.

http://www.netac.com/Product/81db9445-fe09-45e1-835a-d711d73d1c37.html

The HDD is properly formatted and work connected to any PC i have, BUT if i connect it to MyCloud it is NOT PROPERLY RECOGNIZED:

I spent money for it, with an huge 2TB size, JUST for keep a backup of my NAS, this has been a very bad surprise for me, that the MyCloud device do not recognize external HDD !!! Why Why ??

I have other hdd, having smaller size and USB2.0 connection, but they are not adequate for backup, and also i want to take advantage of USB3.0 speed.

The device appear to mount, but reported as ZERO storage capacity !!!

This is obviously a firmware problem. I tried to reformat it, and it has nothing wrong.
The external HDD is composed by a Sata2 drive, with an USB-TO-SATA hardware bridge, maybe the NAS is not compatible with this hardware interface ???

I have also a wifi-router (with usb3.0 port) and i can connect the device to the router without problems, also i can see it on my network share. I could use this configuration for the backup, but i do not want the backup traffic travel in my network, slowing down internet connection.

IM REALLY DISAPPOINTED

The issue of certain USB hard drives not properly mounting is well discussed here (see threads below). For some the solution is to delete the partitions on the USB drive, create one single partition and format in a My Cloud supported format (NTFS, FAT32, etc.).

https://community.wd.com/t/this-is-absolutely-unacceptable/149432/23

https://community.wd.com/t/usb-my-book-not-recognized-reporting-0k-available/96850

https://community.wd.com/t/my-cloud-cannot-not-mount-share-on-4tb-my-book/168409

Additional discussion on this issue can be found using the forum search feature, magnifying glass icon upper right.

Don’t format in FAT32 if you have files over 4 GB in size as it can’t handle it. I’d go NTFS format for added security.

Can MyCloud see exFAT? If it can, I’d go with that if you can’t do NTFS.

From a reputable manufacturer, or some generic thing off ebay, amazon, etc?

How fast is your internet that it will be slowed down by traffic over a gigabit network, which, if you have a switch, is probably rated for handling up to 16Gbps total traffic?

Amazon resell it. I do not know if it’s a reputable manifacturer or not. it WORKS, that’s all!

http://www.netac.com/Product/d87c306d-2b44-48b4-880b-088d3a0b41ea.html

I want to connect the HDD into NAS MyCloud rear port, NOT on the network.
Thie reason is also that i believe the MyCloud can do a better job for powersaving the device.
If i attach it as a nework resource, it is samba/SMB reacheable, and any time i turn on my PC the scan of the network activate it, and it start to spin.

WD should seriously update firmware (linux?) for a better USB3.0 compatibility of their device.

Of course i have formatted using NTFS, i know of FAT and EXT3 limitations.

You had better pass your concerns to WD then.

So… does anyone had a problem connecting a backup USB3.0 HDD into the rear USB port of MyCloud Nas ?

Yes, see my prior post above from October 9th with several other discussions on the inability to use certain USB hard drives with the My Cloud. As one of the discussions indicates in my case the solution was to repartition and reformat the external USB 3.0 hard drive. Since then no problems with the My Cloud (v4.x) mounting the drive and backing up to it using Safepoint. In my case my wild guess is that the factory out of the box formatting of the Toshiba USB 3.0 hard drive that I use was the problem.

In my case, the device is recognized as external HDD, but something is wrong reading the device size.
It says the HDD is of 0KB size and has 0KB free space as well! The same device attached to a PC appear normally mounted.

I’ve tried to reformat using windows (NTFS) with no improvements. Do i need a “low level” reformat maybe ? Using which tool ? I simply think WD should upgrade their USB drivers into the embedded Linux os inside MyCloud device.

Did you try repartitioning FIRST before reformatting? In my case I used Windows 7 (at the time) to remove all existing partitions on the external USB drive, then created one single partition for the maximum size I could, then formatted the new partition for NTFS.

I used the Computer Management Console > Storage > Disk Management from within Windows to remove the partition, create a new partition then format. Make sure to select the correct hard drive (USB) so you don’t erase your computer’s hard drive or some other drive you don’t intend to erase.

These are important diagnostic informations for WD linux developers about my case:

I have found that MyCloud problem mounting external HDD are specific to USB3.0 devices.

I have done the following:

Connected the external HDD to rear port before booting MyCloud NAS (firmware 4.4.xxx)

Acquired SSH root prompt on MyCloud device

Executed this command:

dmesg | grep usb

I got the following log:

[    4.241051] calling  usb_init+0x0/0x178 @ 1
[    4.241430] usbcore: registered new interface driver usbfs
[    4.241776] usbcore: registered new interface driver hub
[    4.242013] usbcore: registered new device driver usb
[    4.242042] initcall usb_init+0x0/0x178 returned 0 after 0 usecs
[    8.346294] /files/sq_kernel/linux/drivers/usb/core/inode.c: creating file 'devices'
[    8.354093] /files/sq_kernel/linux/drivers/usb/core/inode.c: creating file '001'
[    8.375139] usb usb1: default language 0x0409
[    8.379544] usb usb1: udev 1, busnum 1, minor = 0
[    8.384277] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    8.399601] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    8.406873] usb usb1: Product: xHCI Host Controller
[    8.411777] usb usb1: Manufacturer: Linux 3.2.26 xhci-hcd
[    8.417214] usb usb1: SerialNumber: xhci-hcd
[    8.421951] usb usb1: usb_probe_device
[    8.425752] usb usb1: configuration #1 chosen from 1 choice
[    8.441997] usb usb1: adding 1-0:1.0 (config #1, interface 0)
[    8.448072] hub 1-0:1.0: usb_probe_interface
[    8.452371] hub 1-0:1.0: usb_probe_interface - got id
[    8.469079] hub 1-0:1.0: no power switching (usb 1.0)
[    8.507707] /files/sq_kernel/linux/drivers/usb/core/inode.c: creating file '001'
[    8.520190] /files/sq_kernel/linux/drivers/usb/core/inode.c: creating file '002'
[    8.534807] usb usb2: skipped 1 descriptor after endpoint
[    8.540262] usb usb2: default language 0x0409
[    8.544664] usb usb2: udev 1, busnum 2, minor = 128
[    8.549582] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[    8.556419] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    8.563680] usb usb2: Product: xHCI Host Controller
[    8.568598] usb usb2: Manufacturer: Linux 3.2.26 xhci-hcd
[    8.574026] usb usb2: SerialNumber: xhci-hcd
[    8.578737] usb usb2: usb_probe_device
[    8.582516] usb usb2: configuration #1 chosen from 1 choice
[    8.618584] usb usb2: adding 2-0:1.0 (config #1, interface 0)
[    8.624757] hub 2-0:1.0: usb_probe_interface
[    8.624768] hub 2-0:1.0: usb_probe_interface - got id
[    8.624816] hub 2-0:1.0: no power switching (usb 1.0)
[    8.625238] /files/sq_kernel/linux/drivers/usb/core/inode.c: creating file '001'
[    8.625583] calling  usb_stor_init+0x0/0x44 @ 1
[    8.625900] usbcore: registered new interface driver usb-storage
[    8.625934] initcall usb_stor_init+0x0/0x44 returned 0 after 318 usecs
[    9.839098] usb 2-1: new SuperSpeed USB device number 2 using xhci-hcd
[    9.889558] usb 2-1: skipped 1 descriptor after endpoint
[    9.889571] usb 2-1: skipped 1 descriptor after endpoint
[    9.904478] usb 2-1: default language 0x0409
[    9.925339] usb 2-1: udev 2, busnum 2, minor = 129
[    9.925351] usb 2-1: New USB device found, idVendor=0dd8, idProduct=ac00
[    9.925364] usb 2-1: New USB device strings: Mfr=4, Product=5, SerialNumber=6
[    9.925374] usb 2-1: Product: USB to S-ATA
[    9.925382] usb 2-1: Manufacturer: Genesyslogic
[    9.925389] usb 2-1: SerialNumber: 0000000000009104
[   10.175866] usb 2-1: usb_probe_device
[   10.179571] usb 2-1: configuration #1 chosen from 1 choice
[   10.261053] usb 2-1: Successful Endpoint Configure command
[   10.280946] usb 2-1: adding 2-1:1.0 (config #1, interface 0)
[   10.485157] usb-storage 2-1:1.0: usb_probe_interface
[   10.485181] usb-storage 2-1:1.0: usb_probe_interface - got id
[   10.505319] scsi2 : usb-storage 2-1:1.0
[   10.506228] /files/sq_kernel/linux/drivers/usb/core/inode.c: creating file '002'
[  141.904958] usb 2-1: device not accepting address 2, error -62
[  192.032328] usb 2-1: Cannot reset HCD device state
[  242.162174] usb 2-1: Cannot reset HCD device state
[  292.293020] usb 2-1: Cannot reset HCD device state
[  292.378780] usb 2-1: USB disconnect, device number 2
[  292.383791] usb 2-1: unregistering device
[  292.387880] usb 2-1: unregistering interface 2-1:1.0
[  292.418909] usb 2-1: usb_disable_device nuking all URBs
[  342.433144] hub 2-0:1.0: couldn't allocate port 1 usb_device

[ 141.904958] usb 2-1: device not accepting address 2, error -62
This indicates there are some problem initializing USB3.0 devices properly !!!

The latest firmware is somewhat flawed and should be patched, it is highly probable
that something is wrong with xhci_hcd driver.

Hope this helps,

Paolo Marani

It should be noted that this is a use to use support forum. You may, if you haven’t done so already, may want to initiate a WD Support request either through the WD My Cloud Dashboard > Help > Support > Request Automated Customer Support or through the WD Support website (https://support.wdc.com/product.aspx?ID=904).

The error message appears to indicate the device (your USB drive) is not accepting the address assignment (#2) the My Cloud is attempting to give to it. Is this USB drive the only USB device you are connecting directly (not through a USB hub) to the My Cloud’s USB port?

One troubleshooting step is to try is to attach the external USB drive to a Linux PC or to a computer that is booted/started with a Linux boot disc like Ubuntu Live CD (https://www.ubuntu.com/download/desktop/try-ubuntu-before-you-install) and see if the drive will properly be mounted under Linux.

Another troubleshooting step is to try attaching the USB drive to a USB hub then attach the USB hub to the My Cloud.

I am now on my third MyCloud. The previous 2 were RMAed (returned) to WD at their request as the USB port did not function correctly. I am currently waiting for the third one to reinitialise itself before trying out the 4tb MyBook which should be attached to it.

I do not know whether this is a software or hardware problem, but both previous MyClouds recognised the MyBook at first, but after a reboot, or a shutdown and restart, then displayed the same symptoms that Paola describes above. Eventually the USB ports on both MyClouds failed completely…

WD support were fully involved throughout, and I supplied them with all the logs they requested. In both cases it was the USB port that had failed.

My recommendation to Paola is to contact WD Support and raise an official support request. The more people that do this, the more likely we are to getting a solution.

What devices did you try to connect to your USB port? There was a problem with
the USB devices in the past getting different mount points when remounted.
I think you also now have a gen2 My Cloud. The odds are incredible high that
you would get two My Cloud devices that have a bad USB port let alone three if this
device also fails.
I think WD’s support process contains one step. RMA.

RAC

Hi, I have only tried connecting a 4tb WD MyBook. As I have said previously, it worked perfectly as a safepoint backup device until I switched both of them off when I went away on holiday. On my return I turned them both on and the mycloud failed to correctly recognise the MyBook. After a few futile attempts ejecting it and reconnecting it, the USB port packed up completely (the same as happened on the original MyCloud)

As of today, the third MyCloud (which only arrived from WD 2 weeks ago) has also failed completely as the Ethernet port does not work. I have reverted back to the second MyCloud (which is meant to be on it’s way back to WD), as at least it’s Ethernet port works, and I can listen to my music.

rac8006, I think you are correct when you say that WD’s support process has just the one step. As an aside, I noticed that both MyClouds that have been sent to me as RMA replacements have the label ‘Recertified in Poland’ on them. As neither of them came in the original packaging (both arrived in brown cardboard boxes) I assume that they are both faulty units that have been returned to WD and then been through some process to correct whatever fault they were reported to have before being sent to me.

In my opinion, if I buy a brand new product which has to be returned because it is faulty, then it should be replaced with a similar, i.e. brand new product.

I am rapidly losing faith in WD, but, in the perhaps vain hope that they will sort this problem out, I have yet again raised this with WD Support

I agree. In the UK, this is covered by the Sale of Goods Act. My contract is with the retailer, not WD. If I buy something and it doesn’t work, it goes back to the retailer, for refund or replacement by the retailer. If it fails inside the period covered by SoGA, it goes back to the retailer, with whom I have a contract.

The WD RMA ‘replace your brand new device with a refurb unit’ isn’t good. But, given that they use RMA instead of having competent diagnostics and support, they must have a lot of RMA’d units that work perfectly once firmware has been cleaned and re-installed, rather than fixing software problems like Apache crashing and making the Dashboard unavailable…

I purchased the original MyCloud 18 months ago, so it is well outside the SoGA. The 4Tb MyBook, which I purchased to act as a Safepoint USB backup, and which then triggered all the subsequent issues with the MyClouds, is a recertified unit, and was purchased as such. It is working perfectly.

I am sure the MyCloud problems that I (and others) have been experiencing are all down to firmware issues. USB ports and Ethernet ports have been around for many years, and are proven, resilient hardware. They don’t fail just because you power off a unit in order to move it to a different room.

At last! Some light at the end of the tunnel (and I don’t think it’s the train hurtling towards me…).

I gave MyCloud No.3 the 40 second reset treatment, and Ethernet port is now working again. All data is safe and secure, and even better, the USB port is working, and my Safepoint is updating on the MyBook as I type.

The whole tedious affair highlights the flimsy nature of the firmware that the MyCloud is supplied with. Simply powering a device off, moving it to a new location and powering it back on again should NOT require a system reset.

I reformated (NTFS) my 1Tb USB drive and had no result.
Also I did reset the cloud with power down time of more than 40s
It keeps showing the disk as having size of 0 Kb !!!

Does any one have an answer?

The problem seem to be limited to ALL Usb3.0 devices.
Do you have an USB2 hub handly ?
I’m pretty sure that connected using an USB2.0 hub (with degraded
performance of course)
it can be recognized correctly. WD refuse to give support about this
weird firmware bug