USB My Book Not Recognized - reporting 0K available

 Just when I start to feel good about WD again, I hit a brick wall… seriously I was very happy about my Sleeping Cloud this morning until I plugged my WD My Book in. 

I am furious… well not “wall hitting furious” but I really want to Rant!!

This post was posted up Saturday…

After firmware update to v04.04.00-308 my external USB WD MyBook 1230 disappeared

Bill_S says on my other post "However, I’m not sure the second issue that you posted the link to above is USB drive issue.  But that will be confirmed one way or another.  "

it is now confirmed… grrrrrrrr

------------- WARNING!! ---------------

Here is my rant!!

Bill_S, I mean seriously does WD even have QA? (That’s Quality Assurance)

I mean it only takes a second at WD Headquarters to plug a USB drive in and voila… it doesn’t get recognized!!

I now have two Cloud drives to test this USB problem with… and both of them (with_ all services running _ including wdmcserverd and wdphotodbmergerd running and also tested with both scans not running (just in case the scans causes the device to be so busy that it doesn’t get recognized)…

I did not touch the other services of which I know about wdnotifierd if that isn’t running, the USB doesn’t get notified to be mounted or dismounted.

No absolutely not, I will not be contacted by tech support allowing them to download all my logs. 

Why? because I don’t want to be the Beta Tester for your company. The first and last time I got called, I waited for the call and then they had me do all the silly things that all tech support calls make you do like “rub your head and pat your tummy” and then they muted the sound at the other end so they all laugh at you (perhaps this is not true). However, I still refuse to unplug and replug, or reset or hold the pin down for 40 seconds, or even RMA the unit. 

You do not need to contact any user with a USB drive. Simply take one from your shelf and plug it into a Cloud with OS3 updated to see the results.

Would appreciate a solution

usb details.jpg


Then all was quiet. both clouds has made it to the latest firmware.

And that’s good, right…?


1 Like

cpt_paranoia wrote:


Then all was quiet. both clouds has made it to the latest firmware.


And that’s good, right…?



should have left one cloud on firmware 3.04 just so that it could access the USB. 

Almost but not Quite…

I can mount the USB drive but I don’t have permission to access it…

So I thought this was it…

The Unable to Create share photo was the solution…

Apparently in your mounting scripts with OS 3, you forgot to create the Directory for the mount under Share…

So here is the solution: and you will need to void your warranty… 

  1. the first time you try to mount your USB device, you will get the notification of Unable to Create Share. Get the share_name from the notification. It is actually the volume label of your USB drive.

  2. SSH into your cloud

  3. navigate to your shares folder and create the share name by 

cd /shares

mkdir /My_Book

  1. now plug in your USB drive again and wait for it to mount…

Yes, it actually mounts… but you cannot access anything from it…  and when dismount the USB drive, it deletes the Directory that you created.


1 Like

12 hours and counting… 

So I applied the fix_permission_v2.deb patch thinking that it might fix the overall DataVolume permissions which this USB mount problem might be related.

Nope… the Public permission has nothing to do with this problem…

Now since I was SSHed in the drive, I decided to watch my Passport being mounted…

I’ve attached a photo of my SSH progress and I’ll document what I see

  1. As you can see, doing a “ls” shows My_Passport being mounted

  2. I quickly cd into the My_Passport and “ls” again to show that all the directories are showing green!!

  3. and suddenly My_Passport gets unmounted and it disappears.

The USB icon on the dashboard shows 0KB free.


I persisted…

So I created a Share call “My_Passport” and I kept getting errors on toggling the Public Acess button on and off (I think it was Share Function Failed (400099). 

Then I plugged in “My Passport” and it managed to mount under “My_Passport” but with restricted access. After mapping it to the Mac, I had no access, but if I SSH into the device and cd /shares/My_Passport/My_Passport, I can see all my files on the USB drive.

Ejecting the USB drive deletes the My_Passport share and

any subsequent mounting continues to mount for a second (you can see it and navigate into the directory) but it gets dismounted and the mount point is deleted.

So I thought maybe it is the blank space in the drive name, tried WDPassPort, also tried creating WDPassPort as a share and the USB drive gets mounted as WDPassPort_2 and so on… 

I give up… it’s Saturday… so by the time the weekend is over… I would have worn out and probably broken my USB plug in on my Cloud; will you replace my Cloud?

Ok… just to let everyone know that I got a private message from a moderator yesterday (friday) wanting to know if he should escalate this problem.  I told him yes to escalate the problem but I do not want to be contacted about it.

I got contacted just now (Saturday 1:00PM) :slight_smile:

So I told him all the things that I tried and he thanked me for the info…

He also wanted my logs, of which I said no

and he also offered me to RMA my cloud and I told him no as I have two clouds and they exhibit the same symptoms. 

I know WD is trying and as well as working on being a good company, but as I told the support person that

“All we need is the feedback that a problem is being resolved or a problem has been resolved”

I do not want to dig around the forum looking for a solution and when there is a solution I don’t want to read 18 pages of discussions about the problem.

I just need the solution, perhaps stickied to the top of the forum of “problems and resolution”

He says “WD will take note of the suggestion” and asks if there are any other questions that I have.

I thanked him for his time and it is an extremely great gesture to call on a Saturday to help out a cloud owner. It is a +2 for WD Support.

So hopefully this will be resolved in the next firmware update…

Bumping this thread back to top as it affects NOT ONLY My Book but (for me) any USB external hard disk that I connect to the WD My Cloud. None of the three external USB hard drives I have show with the latest 4.04.00-308 firmware. Rebooting the WD My Cloud with the external hard drive attached doesn’t work (or help). The WD My Cloud does indicate a drive is attached but with 0K, and it does not mount the share or at least the share doesn’t show up as accessible.

USB external hard drives used:
1T Toshiba Canvio USB 3.0
320GB WD Passport
Generic USB 3.0 docking station with 1TB WD Green drive

If I connect a USB flash/pen drive (two Sandisk 4GB’s and a Sandisk 32GB) the WD My Cloud does properly mount and access the flash/pen drives and they are accessible to users.


This forum is very much like the WD Software, full of features that nobody wants to use, complicated with great statistics everywhere but really really annoying.

For example, I want to bump this post and I ended up replying to Bennor as he is the last post, so I click on the back page button to get out of replying to Bennor; except I do not. It keeps the reply to Bennor at the bottom of my web page and meanwhile my top browseer has backed all the way to the first WD Page.

Thus I have to navigate all the way back through my Raphael History to find this post again and this time I reply to my first post.

Seriously Annoying… perhaps I might get use to it, but the question will always remain “Why do we have to?”

The reason that I’m here is to get answers or perhaps even to help someone. I’m not here to socialize even though sometimes it may seem like that, but it somewhat akin to misery loves company type effect.

So here is the deal…

It seems that the test units at WD do work with their USB drives and they are unable to replicate the problem that only a few of us have… This is apparent with their last post on another post that had nothing to do with this problem, but they posted up my tech support call summary.

Thus without logs they are unable to replicate the problem… and I really don’t want to give them my logs simply for the reason that I’ve become the tester for WD. They will have to get the logs from someone else. However here is a pic…

It would be nice to have done a ls -l when you had the My Book connected. Also a df would help.
One would ask why did the cd … not take you back to the /share directory? Why is My_Passport a different color? If it is a symbolic link it might explain why a cd … ends up unreachable.


You make a great tech support guy Rac8006 but I wouldn’t want to be the customer that has to perform those tests, not because they are difficult but simply I would be annoyed at having to perform test like a lab monkey and give results for a product that I bought.

Anyways, I do have a solution.

I really don’t want to post up a solution because then the real problem will never be solved as another similar USB problem was never solved with the 3.04 version.

When I use to be a part of IT/software programmer, I hated users like myself because I offer helpful solutions that seems to obfuscate the problem and sometimes it impedes the solving of the problem. Take a look at my tech call on the other thread because as I tried to explain two different problems and they get interweaved into one problem; i.e. my public folders has nothing to do with my attaching a USB drive problem but yet the solution they proposed is related to the public folders.

The Story of “The Blind Men and the Elephant”

The reason that I am using that story allegorically, all of us are touching and observing different pieces of the WD software including Tech Support. I might even include the WD programmers because I am beginning to doubt that any single programmer at WD would know the whole interaction of their software.

So for the last week while keeping silent from the forums, I managed to mount my PassPort USB drive and have been using it. I thought it was a quirk but apparently it was a solution from my firmware 3.04 days (actually I had to use it more recently because I downgraded one of my clouds back to 3.04).

The method that I use with firmware 3.04 is

Normally I have these two services stopped
/etc/init.d/wddispatcherd stop
/etc/init.d/wdnotifierd stop

I would then plug in my USB drive…

Then I would start up the services
/etc/init.d/wddispatcherd start
/etc/init.d/wdnotifierd start

As soon as the USB drive is mounted as shown on the dashboard
I would then stop the services
/etc/init.d/wddispatcherd stop
/etc/init.d/wdnotifierd stop

To remove the drive, I click on the eject USB on the Dashboard… then start the services.

The reason for this elaborate starting and stopping of these services is because in 3.04 my Cloud would lock with a frenzy of activities after plugging in a USB drive. When I say locked I mean locked. There are no responses within the SSH window, the drive can be heard rattling with the drives hard at work and there is no Dashboard. I have no idea whether this problem was ever resolve by WD.

This was the reason in 3.04 that

  1. never boot up with your usb drive attached (filled with data)
  2. always wait for 5 minutes or more before attaching your USB drive.
  3. If you do boot up with the USB drive attached, SSH into the device immediately and stop the two services, otherwise the Cloud will lock.

If I left the services running for more than 5 minutes after powering up the Cloud, I can safely mount and dismount the USB drive without having to stop and start the services. It is only during the initial running of these services that seems to give us problems.

I believe you need both services to be active in order to mount a USB drive and you definitely need wdnotifierd to mount and unmount a USB 3 drive otherwise the ejecting of the USB drive would never complete.

So with OS 3… wddispatcherd has been removed but wdnotifierd is still there.

So after posting up this post last week and spending the whole day trying to resolve it, I stumbled on to the solution late at night.

After downgrading my other cloud, I decided to shut down all the services that is not needed in order for the drive to get a good night sleep.

wdnotifierd was one of the services that I shut down.

Thus that night, I decided to try my PassPort drive one more time.

Plugged in my PassPort drive
/etc/init.d/wdnotifierd start

and the PassPort drive got mounted… and I turned off the service.

The PassPort drive was mounted successfully…

I spent the whole week organizing my files without mentioning this solution on the forum in the belief that it might be, when I moved this cloud from the shelf to my desk, I had to power off the Cloud and re-power back on, the solution; I wasn’t sure.

I ended up buying another 4TB My Book and for the last two days I was busy filling it with data directly on my Computer USB 3 port.

Today I decided to try my luck with attaching the My Book to the OS 3 Cloud.

First I had to eject my PassPort…

  1. so I started up the wdnotifierd service after clicking on eject…
  2. removed passport
  3. attached My Book
  4. stopped wdnotifierd

The My Book was mounted Successfully

So just to be nice, I thought I would repeat this experiment (this is what it means to be a tester which is why I hate this job, repeating your tests).

  1. started wdnotifierd… click eject
  2. ejected and I removed the drive
  3. waited for a few seconds, like about 5 seconds and plugged it back in
  4. I am hearing a lot of clacking sounds… rumbling… like the hard drive is re-organizing itself…
  5. I am expecting the drive to be mounted… but I get this panel…

interesting eh?

  1. So I stopped the wdnotifierd services…
  2. and the drive got mounted…

so… as I’m feeling the elephant’s trunk…

If you toggle the service “wdnotifierd” stop and start while rubbing your head in a circular motion facing north… your USB 3 drive will attach…

Optionally, perhaps it is just a matter of waiting… wait for your drive to settle (lets say 5 minutes) before attaching a USB drive.

Last words… I am not doing anymore testing on this problem.

If you need to replicate this problem try filling your hard drives with 4tb of data and tell your testers that if they lose any part of the data, they will be fired, strapped to a chair and electrocuted and lastly will need to pay a $1000 fine (in no particular order).

I promised on my last post in the temp forum that I won’t be posting here anymore and I broke my promise twice because I do want this problem fixed and it is a problem.

Just for giggles tried your procedure (stopping wdnotifierd) with a 1T USB 3.0 external drive and it didn’t work. :frowning:

Obviously something is funky with the firmware. Flash/pen USB drives (4gb and 32gb) get mounted, two external USB drives (non USB 3.0) that are under 1T get mounted, yet the two external USB drives I have (both USB 3) that are 1T do not get mounted under the v04.04.01-112 firmware. Very frustrating as these two 1T drives worked prior to the recent OS 3 firmware.

Try stopping the other services that I’ve stopped.

/etc/init.d/nfs-kernel-server stop
/etc/init.d/nfs-common stop
/etc/init.d/upnp_nas stop
/etc/init.d/mDNSResponder stop
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdnotifierd stop
/etc/init.d/wdmcserverd stop
/etc/init.d/wddispatcherd stop <=== doesn’t exist :stuck_out_tongue: but was part of my script

or if you are still doing it for laughs…

stop wdnotifierd
insert USB drive
start wdnotifierd and watch dashboard until it gets mounted probably with 0k
stop wdnotifierd

and just wait for a few minutes… I believe mine kicked in a few minutes after I stopped it.

I’ll change the title back to no solution then…

Nope still not working for me on the two different 1T external drives. Perhaps others who are having problems can give your steps a try to see if it solves their USB issues. For what ever reason the My Cloud I’m using no longer properly mounts two external USB drives for some reason with the OS 3 firmware. Normally I don’t have USB drives connected but went to do a backup of the My Cloud after upgrading the firmware and found the drive wouldn’t mount that I normally use to backup the My Cloud. Have done the 4 second reset too, no effect.

I’ve even tried using a powered USB hub as well. No effect. In all cases the two separate 1T drives power up, one can hear disc activity for a few seconds then the drives appears to power down. The Dashboard throws an unable to mount alert. In the Toshiba external drive’s case the drive light indicator goes off like its no longer being powered. Makes me wonder if the drive is being put to sleep when the firmware fails to properly mount the drive or is shutting off the USB port. {shrugs} Oh well just another one of the fun quirks with the My Cloud firmware. If I get board maybe I’ll downgrade the firmware and see what happens.

1 Like

I just tried to mount a My Book to my MY Cloud. It would not mount. What I ended up doing was to mount the My Book on my PC. Verify that It was ok. Then eject it from my PC. Then put it back on the My Cloud. After a few minutes it mounted and finally showed up in the dashboard with the proper


not that I wish to deter you from your wonderful sleuthing but just wondering what effect of mounting the my_book on your PC will have on your Cloud?

is it to show your My Cloud that “See! this is how you should mount the My Book” :stuck_out_tongue:

although perhaps it is the insertion, ejection and the subsequent insertion that may have enticed the My_Cloud to finally mount the drive, or perhaps it is just the wait.

I’ve found that letting things settle plays a big role in the Cloud. Like the FW 3.04 lock that thrashes the drive if you attempt to mount the drive immediately after bootup.

However, if you wait 5 minutes until everything seems to settle (the cloud goes quiet) and then plugging in the drive, it will mount nicely.

I mounted it on the PC. Because I found an entry that said if it didn’t mount. It might be becasue it was not ejected properly. So mounting it on the PC and ejecting it would clear that condition.


fair enough,

but I think that condition flag would be on your Cloud and not something on the USB drive. Thus ejecting and re-plugging it in might clear the condition on the cloud.

I think if you have unwritten blocks due to pulling the drive out, a chkdsk will clean up the discrepancy but I cannot think of anything on the drive that will indicate a condition.

I’ll edit this to “what I think may not always be anything close to true” as the drive condition could be something fixable if you mount it in a PC.

Actually there is a flag on file systems that says that the filesystem was not shutdown properly. So
putting it on a PC and ejecting it properly resets that flag.


The system would have to have a premonition state which is only available in Quantum computers that would set a flag on a hard drive knowing that it would not be shut down properly, otherwise if the system suddenly shuts down improperly you would not have a chance to write that flag…


So having said that… I had to look this up… and lo and behold I found this…

Cannot mount volume.
Unable to mount the volume ‘Lokaal station’.

$LogFile indicates unclean shutdown (0, 0) Failed to mount ‘/dev/sda1’: Operation not supported Mount is denied because NFTS is marked to be in use.

and someone interpretation of it is…

What the error message means is that you didn’t shutdown your computer properly last time you used Windows. The best fix is booting back into windows again, then shutdown cleanly.

so what it is, is either a dirty flag indicating that the drive has been written to, or a lock flag indicating that the drive is in use?

I know it is just a matter of interpretation but a dirty flag is much more understandable than a premonition flag.