"WD My Cloud" doesn't recognize the 3TB external hard drive

Hi,

I would like to access my 3TB external hard drive (self powered in NTFS format) via WD My Cloud. I have attached my external drive to WD via USB port but it doesn’t show up in My Computer when i open up WD My cloud.

What am i missing here? I would like to avoid formatting my external hard drive as it has got a lot of data in it.

Please advise.

Thanks,

When the external USB drive is connected to the My Cloud USB port, access the My Cloud Dashboard and check the USB icon on the Dashboard:

Check the My Cloud Dashboard > Share page to see if a Share with the name of the external USB hard drive is listed.

Typically if the My Cloud recognizes the drive it will indicate the status when that icon is selected.

If the drive isn’t listed or is listed but indicates 0K check the notification icon on the My Cloud Dashboard to see if there is an notification message that may indicate the problem:

Also ensue the USB hard drive is in a format supported by the My Cloud: FAT32, NTFS (read and write capability), HFS+J, Linux Ext2, Ext3/Ext4, XFS

Unfortunately there are some external USB hard drives that are not properly recognized and or not properly mounted by the My Cloud. There are a number of other threads that mention this problem. For some (including myself) the solution was to remove all partitions on the external hard drive then reparation the drive with a single partition and then format it (in my case for NTFS).

Obviously this is not a good solution because you have existing data on your external hard drive. I had the same problem and ended up spending several hours moving the external hard drive contents to several other hard drives in order to clean it off so it could be repartitioned.

Here are some past threads, others can be found by using the magnifying glass search icon upper right:
https://community.wd.com/t/wd-my-cloud-wont-recognize-usb-drive/96017

https://community.wd.com/t/my-mycloud-doesnt-recognize-some-usb-hard-drives/152488

https://community.wd.com/t/usb-my-book-not-recognized-reporting-0k-available/96850

https://community.wd.com/t/wont-recognize-attached-usb-and-safepoint-no-longer-working/140464

Thanks a lot for your detailed response. I am so glad that someone did respond to the query.
I went through a lot of post to understand 0kb issue but i cant seem to make it work. There is only 1 single primary partition (NTFS) in my external hard drive. The USB icon is enabled in dashboard but is showing 0kb, unsure what to do next.

I have enabled SSH to fetch the logs after i connect my ext drive to WD and this is what i got. Need help in analyzing this log:

2016-07-28T19:06:15.254830+10:00 di=omtjk6Pas9 info kernel:[76973.569623] usb 2-1: new SuperSpeed USB device number 3 using xhci-hcd
2016-07-28T19:06:15.294924+10:00 di=omtjk6Pas9 info kernel:[76973.610815] usb 2-1: New USB device found, idVendor=174c, idProduct=1153
2016-07-28T19:06:15.294938+10:00 di=omtjk6Pas9 info kernel:[76973.617555] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
2016-07-28T19:06:15.307820+10:00 di=omtjk6Pas9 info kernel:[76973.624750] usb 2-1: Product: AS2115
2016-07-28T19:06:15.307854+10:00 di=omtjk6Pas9 info kernel:[76973.628349] usb 2-1: Manufacturer: ASMedia
2016-07-28T19:06:15.307867+10:00 di=omtjk6Pas9 info kernel:[76973.632480] usb 2-1: SerialNumber: 00000000000000000000
2016-07-28T19:06:15.357290+10:00 di=omtjk6Pas9 info kernel:[76973.670161] scsi3 : usb-storage 2-1:1.0
2016-07-28T19:06:16.361642+10:00 di=omtjk6Pas9 notice kernel:[76974.670426] scsi 3:0:0:0: Direct-Access ASMT 2115 0 PQ: 0 ANSI: 6
2016-07-28T19:06:16.361723+10:00 di=omtjk6Pas9 notice kernel:[76974.679273] sd 3:0:0:0: Attached scsi generic sg1 type 0
2016-07-28T19:06:16.371576+10:00 di=omtjk6Pas9 notice kernel:[76974.687221] sd 3:0:0:0: [sdb] 3907029168 512-byte logical blocks: (2.00 TB/1.81 TiB)
2016-07-28T19:06:16.385897+10:00 di=omtjk6Pas9 notice kernel:[76974.705456] sd 3:0:0:0: [sdb] Write Protect is off
2016-07-28T19:06:16.402945+10:00 di=omtjk6Pas9 notice kernel:[76974.717648] sd 3:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
2016-07-28T19:06:16.674885+10:00 di=omtjk6Pas9 info kernel:[76974.994859] sdb: sdb1
2016-07-28T19:06:16.684872+10:00 di=omtjk6Pas9 notice kernel:[76975.001239] sd 3:0:0:0: [sdb] Attached SCSI disk

Which firmware version My Cloud do you have? The newer v2.x or the older v4.x?

On the older v4.x when I had problems with one particular USB drive failing to mount properly on the My Cloud I found I had to look at two log files; kern.log and wdnas.log. See my posts with log info in the following thread where I discussed my issues as we tried to track down why my USB drive wouldn’t get properly mounted on the My Cloud. There are several other commands one can issue to try and track down exactly how the My Cloud see’s the USB drive and how it mounts.

https://community.wd.com/t/this-is-absolutely-unacceptable/149432

My Firmware

Not sure if this makes any sense ?? Nothing came up when i did cat wdnas.log so i looked at log 1 instead

cat wdnas.log.1
2016-07-28T19:06:05.002167+10:00 di=omtjk6Pas9 info logger: INFO: no more USB partition attached, increse inotify limit to: 131072
2016-07-28T19:06:05.500992+10:00 di=omtjk6Pas9 info logger: INFO: Device removed: device=2, vendor=ASMedia, model=AS2115, serial_number=00000000000000000000, revision=0.01
2016-07-28T19:06:16.228991+10:00 di=omtjk6Pas9 info logger: INFO: Device added: device=2, vendor=ASMedia, model=AS2115, serial_number=00000000000000000000, revision=0.01
2016-07-28T19:06:18.115157+10:00 di=omtjk6Pas9 info logger: INFO: Mode sense to Power condition page failed on ASMedia AS2115
2016-07-28T19:06:19.943004+10:00 di=omtjk6Pas9 warning logger: WARN: Unsupported partitions: device=2, partition=1, share_name=, label=, type=, uuid=

From the information you posted it would appear (just a guess) that the My Cloud has a problem reading the partition of the external USB hard drive as evidenced by the last line: “WARN: Unsupported partitions: device=2, partition=1”

It is possible was partitioned and formatted in such a way, even though NTFS, that the My Cloud has problems mounting it. As I found out in my case with a Toshiba external USB drive that wouldn’t mount on the My Cloud, there was some sort of weird problem with the out of the box partitioning of the external hard drive that Toshiba had done.

In my case what ultimately worked for me was to copy all the external hard drive files to a computer’s hard drive, in my case to several hard drives because it wouldn’t all fit on one single computer hard drive. Then (I used Windows 7, Computer Management, Disk Management console) I removed all the partitions on that external USB hard drive. Then re-partitioned the external hard drive with one single partition. Then formatted the external hard drive for NTFS. Then tested the external hard drive by connecting to the My Cloud where it mounted and was displayed properly. I then removed the external hard drive from the My Cloud, connected it to the computer and only then did I set about recopying all of the external drive files back to the external hard drive. Once finished copying the files back did I then reattach the external USB hard drive to the My Cloud where it now works properly.

ok will give that a go. I had checked the partition on the drive and there is only one partition.
I will try and do what you have suggested. Fingers crossed.

Good luck. The My Cloud not properly mounting an external USB drive drove me nuts for a while. There was at least one other person who had a similar problem and the repartitioning/reformatting of the external USB hard drive apparently worked for them too.

Interesting. I have used a Toshiba Canvio Basic for a few years w/o any problems. Mostly for safe point backup once a month and stored in a fireproof safe. Now it seems the drive is becoming unreliable so I am getting another Toshiba. What model did you have?

The Toshiba Canvio that I have is a 1TB HDTC610XK3B1 USB 3.0 version purchased a number of years ago (four years ago if I remember right) and is used as a monthly backup hard drive at the moment.

Does WD supports external with over 3TB capacity? Wondering if thats an issue?

In my case it was a 1TB drive. I also had trouble with a 500GB drive too before relegating that drive to another computer so I never got around to trouble shooting that drive. In both cases the drives worked just fine on other computers. Seems certain drives have problems with being properly seen and mounted by the My Cloud, basically hit or miss for some drives. Others have reported using larger capacity USB drives without issue.

Yay, it worked :slight_smile: WD can recognize the drive now but i am wondering why is it that drive has shrunk to 2 TB when it was a 4 TB drive?? and no i havent formatted in FAT32, it is in NTFS format? i am stupmed !!!

If you deleted one partition, did you resize the other to fill the free space?

As cpt_paranoia indicated if there are more than one partition on the drive, if you deleted one did you resize the other to reclaim the unused space?

But there was only one partition. I did check in the disk management and i only saw 1 partition.
Is there a way to claim it back?

Thanks for your persistent support Bennor !! Appreciate your help with this !! Its amazing what one person’s experience & knowledge can do for the rest!!

Ah, i didn’t re-read the whole thread. But…

https://technet.microsoft.com/en-gb/library/cc938432.aspx

For now, 2 terabytes should be considered the practical limit for both physical and logical volumes using NTFS