This is absolutely unacceptable!

I was hoping upon hoping that the USB issues would have been resolved in this update, but to no avail.

I purchased this drive with the hope of having a safe haven for my backups and to have a DEPENDABLE backup solution along the way.

YES, I’ve search and read the forum posts regarding this issue and have I’ve tried EVERYTHING!

Just seems a WD Drive to a WD Drive isn’t too much to ask for!!!

As soon as I connect my WD Passport 4GB drive into my 2GB MyCloud drive I lose all control, including connectivity and ability to connect via Dashboard.

COME ON…HELP US OUT HERE!

If it were still under warranty, I’d return it in an instant! SPECIFICATIONS NOT MET!!!

I think you mean 2TB MyCloud and perhaps 4TB Passport Pro, yes?

What exactly does “lose all control” mean?

I have no issues with the connectivity between my MC and 3TB Passport.

Have you opened up a support ticket with WD and sent them the logs from your My Cloud?
http://support.wdc.com/Support/case.aspx

Some of us (me included) are having trouble with certain external USB drives not working with the My Cloud USB port. In my case I have a Toshiba drive that doesn’t work yet other drive/flash drives that do work with the My Cloud.

If people don’t send their My Cloud logs to WD there isn’t much hope for them to determine why some drives don’t work properly and others do with the My Cloud USB port.

If you are interested. In the file /usr/local/sbin/wdAutoMountUdevHandler.pm at line 481-482
is the test for device is supported. One of those line has to be true otherwise the device is unsupported. 060101 is still imaging and 08 is mass storage. I’d be curious what the Toshiba value is?

RAC

@fntmstr, I know you must be frustrated. However, want to remind you this is a user forum and not an official support site. Which means it is a forum for end-user to end-user help. We are all just users like you and NOT WD employees. Once in a while you might see one in here, but hardly ever.

:grinning:

1 Like

That being said, my experience so far is that you will get a lot more assistance here than from WD support! :laughing:

1 Like

If it wasn’t for the users here in this forum we would all be a lot worse off, believe me. The My Cloud is riddled with issues … yes USB, Safepoints, Connectivity, etc., but we are about the closest thing to immediate support we got.

1 Like

Running udevadm info -q all -n /dev/sdb from the SSH command line turns up the following when the Toshiba Canvio 1T drive that doesn’t get mounted is attached.

E: ID_USB_INTERFACES=:080650:

Here is the full dump from the udevadm command:

P: /devices/platform/xhci-hcd/usb2/2-1/2-1:1.0/host2/target2:0:0/2:0:0:0/block/sdb
N: sdb
S: disk/by-id/usb-TOSHIBA_External_USB_3.0_2011111316674-0:0
S: disk/by-path/platform-xhci-hcd-usb-0:1:1.0-scsi-0:0:0:0
E: DEVLINKS=/dev/disk/by-id/usb-TOSHIBA_External_USB_3.0_2011111316674-0:0 /dev/disk/by-path/platform-xhci-hcd-usb-0:1:1.0-scsi-0:0:0:0
E: DEVNAME=/dev/sdb
E: DEVPATH=/devices/platform/xhci-hcd/usb2/2-1/2-1:1.0/host2/target2:0:0/2:0:0:0/block/sdb
E: DEVTYPE=disk
E: ID_BUS=usb
E: ID_INSTANCE=0:0
E: ID_MODEL=External_USB_3.0
E: ID_MODEL_ENC=External\x20USB\x203.0
E: ID_MODEL_ID=a006
E: ID_PART_TABLE_TYPE=dos
E: ID_PATH=platform-xhci-hcd-usb-0:1:1.0-scsi-0:0:0:0
E: ID_PATH_TAG=platform-xhci-hcd-usb-0_1_1_0-scsi-0_0_0_0
E: ID_REVISION=0001
E: ID_SERIAL=TOSHIBA_External_USB_3.0_2011111316674-0:0
E: ID_SERIAL_SHORT=2011111316674
E: ID_TYPE=disk
E: ID_USB_DRIVER=usb-storage
E: ID_USB_INTERFACES=:080650:
E: ID_USB_INTERFACE_NUM=00
E: ID_VENDOR=TOSHIBA
E: ID_VENDOR_ENC=TOSHIBA\x20
E: ID_VENDOR_ID=0480
E: MAJOR=8
E: MINOR=16
E: SUBSYSTEM=block
E: UDEV_LOG=3
E: USEC_INITIALIZED=5718810591

As usual the My Cloud indicates 0K when the drive it attached and further indicates unable to create share.

USB Device Name Toshiba External USB 3.0 
Manufacturer Toshiba 
Model External USB 3.0 
Serial Number 2011111316674 
Firmware Version 0.01 
Size 0 KB 

Unable to create share
A share could not be created on a USB device (vendor: Toshiba, model: External USB 3.0, serial number: 2011111316674, file system: ntfs, label: Toshiba1T, share name: Toshiba1T).
Friday, February 05, 2016 3:27:00 AM Code 1122

I’ve sent off several log files to WD Support but as yet they haven’t gotten back other than to say they’re looking at it.

Ok the device is supported. Now to find out why it can’t create the share.

RAC

Which is what I’ve been occasionally spending some time trying to figure out in the past months. Pre OS3 firmware that one particular USB drive mounted, post OS3 it doesn’t. Best I can tell from the logs is the system for what ever reason treats the drive as read only then fails to mount it. The kern log showing some of this.

2016-02-05T00:26:51.389524-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.117064] hub 2-0:1.0: state 7 ports 1 chg 0000 evt 0002
2016-02-05T00:26:51.389585-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.122623] hub 2-0:1.0: port 1, status 0203, change 0001, 5.0 Gb/s
2016-02-05T00:26:51.521834-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.286111] hub 2-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x203
2016-02-05T00:26:51.641813-05:00 di=NqJQ6FTJD8 info kernel:[ 5713.406162] usb 2-1: new SuperSpeed USB device number 2 using xhci-hcd
2016-02-05T00:26:51.662976-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.426495] usb 2-1: skipped 1 descriptor after endpoint
2016-02-05T00:26:51.663047-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.431843] usb 2-1: skipped 1 descriptor after endpoint
2016-02-05T00:26:51.681890-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.437633] usb 2-1: default language 0x0409
2016-02-05T00:26:51.681930-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.442284] usb 2-1: udev 2, busnum 2, minor = 129
2016-02-05T00:26:51.681948-05:00 di=NqJQ6FTJD8 info kernel:[ 5713.447135] usb 2-1: New USB device found, idVendor=0480, idProduct=a006
2016-02-05T00:26:51.681963-05:00 di=NqJQ6FTJD8 info kernel:[ 5713.453884] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
2016-02-05T00:26:51.695442-05:00 di=NqJQ6FTJD8 info kernel:[ 5713.461081] usb 2-1: Product: External USB 3.0
2016-02-05T00:26:51.695479-05:00 di=NqJQ6FTJD8 info kernel:[ 5713.465560] usb 2-1: Manufacturer: Toshiba
2016-02-05T00:26:51.695494-05:00 di=NqJQ6FTJD8 info kernel:[ 5713.469693] usb 2-1: SerialNumber: 2011111316674
2016-02-05T00:26:51.704156-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.474647] usb 2-1: usb_probe_device
2016-02-05T00:26:51.704228-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.478401] usb 2-1: configuration #1 chosen from 1 choice
2016-02-05T00:26:51.715383-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.484096] usb 2-1: Successful Endpoint Configure command
2016-02-05T00:26:51.726630-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.489918] usb 2-1: adding 2-1:1.0 (config #1, interface 0)
2016-02-05T00:26:51.726684-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.495857] usb-storage 2-1:1.0: usb_probe_interface
2016-02-05T00:26:51.732995-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.501443] usb-storage 2-1:1.0: usb_probe_interface - got id
2016-02-05T00:26:51.746704-05:00 di=NqJQ6FTJD8 info kernel:[ 5713.508096] scsi2 : usb-storage 2-1:1.0
2016-02-05T00:26:51.746760-05:00 di=NqJQ6FTJD8 debug kernel:[ 5713.512547] /files/sq_kernel/linux/drivers/usb/core/inode.c: creating file '002'
2016-02-05T00:26:57.007958-05:00 di=NqJQ6FTJD8 notice kernel:[ 5718.772506] scsi 2:0:0:0: Direct-Access     TOSHIBA  External USB 3.0 0001 PQ: 0 ANSI: 6
2016-02-05T00:26:57.008017-05:00 di=NqJQ6FTJD8 notice kernel:[ 5718.781441] sd 2:0:0:0: Attached scsi generic sg1 type 0
2016-02-05T00:26:57.041742-05:00 di=NqJQ6FTJD8 notice kernel:[ 5718.782426] sd 2:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
2016-02-05T00:26:57.041825-05:00 di=NqJQ6FTJD8 notice kernel:[ 5718.782789] sd 2:0:0:0: [sdb] Write Protect is off
2016-02-05T00:26:57.041841-05:00 di=NqJQ6FTJD8 debug kernel:[ 5718.782805] sd 2:0:0:0: [sdb] Mode Sense: 33 00 00 08
2016-02-05T00:26:57.041857-05:00 di=NqJQ6FTJD8 notice kernel:[ 5718.783145] sd 2:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
2016-02-05T00:26:57.041869-05:00 di=NqJQ6FTJD8 info kernel:[ 5718.811903]  sdb: sdb1
2016-02-05T00:26:57.051870-05:00 di=NqJQ6FTJD8 notice kernel:[ 5718.818534] sd 2:0:0:0: [sdb] Attached SCSI disk
2016-02-05T00:26:59.457978-05:00 di=NqJQ6FTJD8 crit kernel:[ 5721.221206] ufsd: "mount" (sdb1): RAW NTFS volume: Filesystem size 931.51 Gb > volume size 931.51 Gb. Mount in read-only
2016-02-05T00:26:59.471877-05:00 di=NqJQ6FTJD8 err kernel:[ 5721.234767] ufsd: unable to replay native journal on "sdb1"
2016-02-05T00:26:59.471928-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.240460] ufsd:unload kernel utf8
2016-02-05T00:26:59.471949-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.243982] ufsd:fill_super("sdb1"), 5643790: cc81c980 10000000, force,iocharset=utf8,fmask=000,dmask=000,uid=65534,gid=1000,user_xattr, verbose
2016-02-05T00:26:59.496603-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.257039] ufsd: Pages: total=e2e, free=305, buff=70, shift=16
2016-02-05T00:26:59.496649-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.263017] ufsd: Page flags: lck=1, err=2, ref=4, upt=8, drt=10, wrb=2000, priv=800
2016-02-05T00:26:59.496667-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.270837] ufsd: Buff flags: upt=1, drt=2, lck=4, map=20, new=40, del=200, aread=80, awrite=100
2016-02-05T00:26:59.512008-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.279780] ufsd: "sdb1": size = 0x74705daf*0x200 >= 0xe8e0bb*0x10000
2016-02-05T00:26:59.512064-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.286304] ufsd: "sdb1": no discard
2016-02-05T00:26:59.522818-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.290634] ufsd: 
2016-02-05T00:26:59.522859-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.292666] ufsd: ======NTFSBoot->le(0)======
2016-02-05T00:26:59.522874-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.297083] ufsd: Signature         : NTFS    
2016-02-05T00:26:59.533519-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.301558] ufsd: RWBlocks          : 0x74705daf x 0x200, sdb1, rw
2016-02-05T00:26:59.533576-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.307803] ufsd: SectorsPerVolume  : 0x74705daf x 0x200
2016-02-05T00:26:59.542933-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.313145] ufsd: SectorsPerCluster : 0x8
2016-02-05T00:26:59.542973-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.317194] ufsd: MFT               : 0xc0000
2016-02-05T00:26:59.555487-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.321576] ufsd: MFTMirr           : 0x10
2016-02-05T00:26:59.555525-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.325694] ufsd: Record size       : -10
2016-02-05T00:26:59.555539-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.329739] ufsd: Index size        : 1
2016-02-05T00:26:59.563643-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.333597] ufsd: Magic             : 0x55aa
2016-02-05T00:26:59.563680-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.337902] ufsd: ===========================
2016-02-05T00:26:59.575120-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.342287] ufsd: Boot's size of Volume is greater then allowed in RWBlock!!
2016-02-05T00:26:59.575179-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.349423] ufsd: Boot is accepted as NTFS of size 931.51 Gb
2016-02-05T00:26:59.590449-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.355121] ufsd: RAW NTFS volume: Filesystem size 931.51 Gb > volume size 931.51 Gb. Mount in read-only
2016-02-05T00:26:59.590492-05:00 di=NqJQ6FTJD8 crit kernel:[ 5721.364673] ufsd: "mount" (sdb1): RAW NTFS volume: Filesystem size 931.51 Gb > volume size 931.51 Gb. Mount in read-only
2016-02-05T00:26:59.614125-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.376165] ufsd: BdSetBlockSize 1000
2016-02-05T00:26:59.614176-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.379856] ufsd: Loading $Volume...
2016-02-05T00:26:59.614192-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.383860] ufsd: $Volume: 3.1, 0, "Toshiba1T"
2016-02-05T00:26:59.614204-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.388374] ufsd: Loading $LogFile...
2016-02-05T00:26:59.621900-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.392101] ufsd: $LogFile: 4000000 bytes
2016-02-05T00:26:59.621962-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.396184] ufsd: Loading $MFT...
2016-02-05T00:26:59.636618-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.399541] ufsd: MFT: used=33e0,total=33e0
2016-02-05T00:26:59.636666-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.405590] ufsd: End of journal read. Actions 0. empty
2016-02-05T00:26:59.636701-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.410904] ufsd: Native journal is not empty!
2016-02-05T00:26:59.646761-05:00 di=NqJQ6FTJD8 err kernel:[ 5721.415387] ufsd: unable to replay native journal on "sdb1"
2016-02-05T00:26:59.646801-05:00 di=NqJQ6FTJD8 notice kernel:[ 5721.421018] ufsd:fill_super failed to mount sdb1: "" ->-22

From the wdnas.log file:

2016-02-05T00:26:53.064567-05:00 di=NqJQ6FTJD8 info logger: INFO: Device added: device=3, vendor=Toshiba, model=External USB 3.0, serial_number=2011111316674, revision=0.01
2016-02-05T00:26:59.157253-05:00 di=NqJQ6FTJD8 info logger: INFO: attached USB partition, reduce inotify limit to: 20000
2016-02-05T00:26:59.777577-05:00 di=NqJQ6FTJD8 err logger: ERR: wdAutoMountLib: mount -t ufsd -o force,iocharset=utf8,fmask=000,dmask=000,uid=nobody,gid=share,user_xattr  /dev/sdb1 /var/media/Toshiba1T, status 8192

A few questions. Why does the Toshiba have a RAW NTFS volume? What is a RAW NTFS filesystem? Can’t find any info other than raw seems to mean formatted. Your udevadm shows the ID_PART_TABLE_TYPE=dos? What is the filesystem on the Toshiba? When you mount one of your working USB devices what kind of filesystem does it have? The only thing I can find in the source is the following statement. It tries to mount as a ufsd filesystem. This filesystem type is proprietary to Microsoft. So no source code for this driver.
$command = “mount -t ufsd -o force,iocharset=utf8,fmask=000,dmask=000,uid=nobody,gid=share,user_xattr “$partitionRecord->{devname}” “$mountDirectory””;

RAC

The drive came formatted that way. Its NTFS. What is so frustrating is the drive mounted fine under pre OS3 firmware. Windows 7 finds no errors on the drive.

I just checked my thumb drive. It also said dos. But when I tried to mount using -t ufsd I got an error. But if I just did mount /dev/sdb1 /mnt it mounted. After the device is mounted I did a “fdisk -l /dev/sdb” it shows up as W95,FAT32. But “df -T” shows up as VFAT.

Have you tried to mount the Toshiba?

RAC
PS why does the system try to mount it using ufsd filesystem?
Also if you do “hexdump -C /dev/sdb|more” What is the value of byte 1c2?

It appears the partition type is 7.

More info. Its a head scratcher.

WDMyCloud:/dev# fdisk -l /dev/sdb

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x1eaa4a81

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048  1953523118   976760535+   7  HPFS/NTFS/exFAT

WDMyCloud:~# mount -t ufsd /dev/sdb1 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

WDMyCloud:~# dmesg | tail
[52150.799848] ufsd: Loading $Volume...
[52150.803846] ufsd: $Volume: 3.1, 0, "Toshiba1T"
[52150.808366] ufsd: Loading $LogFile...
[52150.812071] ufsd: $LogFile: 4000000 bytes
[52150.816134] ufsd: Loading $MFT...
[52150.819487] ufsd: MFT: used=33e0,total=33e0
[52150.826593] ufsd: End of journal read. Actions 0. empty
[52150.831864] ufsd: Native journal is not empty!
[52150.836378] ufsd: unable to replay native journal on "sdb1"
[52150.841987] ufsd:fill_super failed to mount sdb1: "" ->-22

WDMyCloud:/dev# mount /dev/sdb1 /mnt
mount: unknown filesystem type 'ntfs'

WDMyCloud:~# hexdump -C /dev/sdb|more

000001c0  21 00 07 fe ff ff 00 08  00 00 af 5d 70 74 00 00

At some point I may just move everything off that external hard drive, reformat it, and start from scratch and see if that fixes the problem but I’d rather know why pre OS3 mounted the drive, post OS3 does not.

Filesystem type 7 is hfsp/ntfs. How did you get this type filesystem. The My Cloud tries to mount this filesystem using ufsd filesystem type. If you do a “lsmod” it shows that the ufsd
module is loaded. also jnl is loaded. It almost looks like you need to do a fsck of the partition to clear the need to replay the journal.

RAC

Forum friends,

I do not have a standard My Cloud device, I have a different one. So why am I reading this forum? Because it has a lot of “action” for one thing, and the new forum format of this past year makes it lots easier to see what is posted in all forums, so I read most any new posts that come along.

I want you to know I have a lot of empathy for all the issues you folks seem to have with the basic My Cloud product. It reminds me of the many issues people were experiencing with the WDTV product. My WDTV Live Plus works great, in part, because I learned stuff in the forum that helped, and I settled on using a firmware that was a couple of versions behind the last one of a few years ago.

I have to say, if I was having the kind of trouble many here seem to be having, I would have gotten rid of my unit, and maybe not gotten the WD My Cloud I now have. Since I did not have the basic My Cloud, I had no preconceived notions. So, a DL2100 My Cloud is what I have. It has been trouble free for me for a year, and just as important, it is trouble free for most all users by looking at the quiet forum for it as well. My NAS is in the DL Series along with the DL4100 and in the similar EX Series. there is the EX2100 and EX4100 and the EX forum is also very quiet. The basic difference between the series is processor type and speed. The DL’s have a faster processor.

So, I suggest that if someone is so fed up with their WD My Cloud they are gun shy about another WD product, don’t be. They DO make a better NAS within these two series. So, check them out; I have the basic model DL series, it comes with 2, 4TB Red drives pre-configured as RAID 1, so I only effectively have 4TB of file storage, and the second drive backs up the first.

I know these NAS cost more, but not that much more than the basic My Cloud with 4TB. Check them out at the WD main site. Hope this info is helpful.

That particular Toshiba drive mounts properly under Ubuntu 14.04. And is read/writeable.

ubuntu@ubuntu:~$ mount -l
/dev/sdf1 on /media/ubuntu/Toshiba1T type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096) [Toshiba1T]

So Ubuntu see’s the drive type as: fuseblk, while the Debian in the My Cloud sees the drive type as: ufsd. It would appear that the Debain OS of the My Cloud doesn’t use NTFS-3G properly or at all when trying to mount this particular USB drive. The Debain OS of the My Cloud is apparently using Fuse version is 2.9.2-4 per an apt-cache show fuse command.

I just ran the apt-cache show fuse on firmware 040402-105 and 040103-421. They both show the same version of fuse 2.9.2-4.

RAC

Things have taken a strange turn. Suddenly the Toshiba drive is being mounted by the My Cloud OS. Didn’t make any changes to the drive. Only ran the various commands mentioned so far in this thread. I did notice the following block in the log file however which I hadn’t see before.

2016-02-06T08:28:01.932930-05:00 di=NqJQ6FTJD8 info kernel:[ 7770.165968] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:28:01.952007-05:00 di=NqJQ6FTJD8 warning kernel:[ 7770.186218] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:28:01.952068-05:00 di=NqJQ6FTJD8 warning kernel:[ 7770.194300] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:28:01.958145-05:00 di=NqJQ6FTJD8 debug kernel:[ 7770.202922] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:28:07.944032-05:00 di=NqJQ6FTJD8 info kernel:[ 7776.166048] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:28:07.944143-05:00 di=NqJQ6FTJD8 warning kernel:[ 7776.186232] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:28:07.944163-05:00 di=NqJQ6FTJD8 warning kernel:[ 7776.194387] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:28:07.957796-05:00 di=NqJQ6FTJD8 debug kernel:[ 7776.202650] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:28:09.945375-05:00 di=NqJQ6FTJD8 info kernel:[ 7778.185868] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:28:09.972078-05:00 di=NqJQ6FTJD8 warning kernel:[ 7778.206185] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:28:09.972155-05:00 di=NqJQ6FTJD8 warning kernel:[ 7778.214339] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:28:09.977978-05:00 di=NqJQ6FTJD8 debug kernel:[ 7778.222835] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:28:14.775417-05:00 di=NqJQ6FTJD8 info kernel:[ 7783.015937] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:28:14.802071-05:00 di=NqJQ6FTJD8 warning kernel:[ 7783.036213] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:28:14.802126-05:00 di=NqJQ6FTJD8 warning kernel:[ 7783.044298] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:28:14.808169-05:00 di=NqJQ6FTJD8 debug kernel:[ 7783.052882] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:28:44.053972-05:00 di=NqJQ6FTJD8 info kernel:[ 7812.255906] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:28:44.054096-05:00 di=NqJQ6FTJD8 warning kernel:[ 7812.276169] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:28:44.054116-05:00 di=NqJQ6FTJD8 warning kernel:[ 7812.284313] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:28:44.054130-05:00 di=NqJQ6FTJD8 debug kernel:[ 7812.292464] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:28:47.765519-05:00 di=NqJQ6FTJD8 info kernel:[ 7816.006040] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:28:47.791971-05:00 di=NqJQ6FTJD8 warning kernel:[ 7816.026211] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:28:47.792036-05:00 di=NqJQ6FTJD8 warning kernel:[ 7816.034268] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:28:47.798244-05:00 di=NqJQ6FTJD8 debug kernel:[ 7816.043099] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:28:50.495364-05:00 di=NqJQ6FTJD8 info kernel:[ 7818.735887] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:28:50.522205-05:00 di=NqJQ6FTJD8 warning kernel:[ 7818.756279] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:28:50.522272-05:00 di=NqJQ6FTJD8 warning kernel:[ 7818.764432] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:28:50.528406-05:00 di=NqJQ6FTJD8 debug kernel:[ 7818.773137] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:28:52.975387-05:00 di=NqJQ6FTJD8 info kernel:[ 7821.215930] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:28:53.002173-05:00 di=NqJQ6FTJD8 warning kernel:[ 7821.236343] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:28:53.002272-05:00 di=NqJQ6FTJD8 warning kernel:[ 7821.244422] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:28:53.008567-05:00 di=NqJQ6FTJD8 debug kernel:[ 7821.253166] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:29:14.608416-05:00 di=NqJQ6FTJD8 info kernel:[ 7842.816346] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:29:14.608879-05:00 di=NqJQ6FTJD8 warning kernel:[ 7842.836729] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:29:14.609146-05:00 di=NqJQ6FTJD8 warning kernel:[ 7842.844994] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:29:14.609371-05:00 di=NqJQ6FTJD8 debug kernel:[ 7842.853203] usb 2-1: Successful Endpoint Configure command
2016-02-06T08:29:46.557830-05:00 di=NqJQ6FTJD8 info kernel:[ 7874.765891] usb 2-1: reset SuperSpeed USB device number 3 using xhci-hcd
2016-02-06T08:29:46.557960-05:00 di=NqJQ6FTJD8 warning kernel:[ 7874.786184] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc231900
2016-02-06T08:29:46.557980-05:00 di=NqJQ6FTJD8 warning kernel:[ 7874.794358] xhci-hcd xhci-hcd: xHCI xhci_drop_endpoint called with disabled ep cc23192c
2016-02-06T08:29:46.557993-05:00 di=NqJQ6FTJD8 debug kernel:[ 7874.802541] usb 2-1: Successful Endpoint Configure command

Wonder if there is some sort of conflict between the two USB 3.0 chipsets (the one in the external drive and the one in the My Cloud) where it causes the My Cloud OS to improperly read the drive? Then somehow the OS triggers a “reset SuperSpeed USB device” call which causes the drive, presumably after some type of reset, to become mountable. Going to spend some more time at some later point comparing yesterdays log dump to today’s to see if there is anything that stands out.

Computers sure are fun.

RAC