Can't reliably connect more than 3 external usb drives to My Cloud at the same time

When I connect more than 3 external drives to my My Cloud using this powered hub from the first 3 work reliably, but additional drives added after that keep ejecting themselves for no reason or just stop working properly while apparently staying connected.

At first, I thought it was the fourth drive, but I disconnected it from the hub, hooked it up to a Windows 7 pc, and ran “chkdsk /r” on it and it said there were no errors, apart from some free space incorrectly marked as used, if I recall correctly. I tried another, new drive as the fourth, and plugged it into a different socket in case there was something wrong with the connector, and that one started giving me problems after a few hours. I haven’t tried moving the 3 working drives to different sockets because I don’t want to take a chance on screwing them up.

The My Cloud is using firmware version v04.04.01-112. All of the drives are formatted as ntfs.

Does the same problem exist if the USB hub with the drives are attached to a computer?

Are all the USB drives the same, i.e. all USB 2.0 or all USB 3.0? Could be the hub cannot put out enough power if all devices are USB 3.0.

I haven’t tried connecting it to a computer yet. I’m pretty sure that 2 of them are usb3 and 2 are usb2. All have their own power supplies. I think I’ll look into finding another hub that can put out more power.

Does anyone have experience with a hub they can recommend, one that can handle the full 7 external drives that the My Cloud is supposed to be able to use?

You will have to experiment. Don’t think WD has an official list of supported hubs or even supported USB drives. Further I don’t think there is a set number of supported drives the My Cloud will support being connected at the same time. The My Cloud (at least with the v4.x firmware) has known issues with some USB external hard drives. In some cases the drives are seen but do not properly mount. My wild speculative guess is that the firmware has trouble with the way certain USB external hard drives are formatted and while it will see them attached will not properly mount them. I discussed my issues with one particular hard drive that was seen but not mounted starting with this post in another thread.

Using an old Belkin USB 2.0 7 port hub I have four hard drives and three flash drives connected to it… From the Dashboard USB status icon it indicates the following:

Prolific Technology Inc. USB-SATA Bridge
200 GB Free of 500 GB

Toshiba External USB 3.0
330 GB Free of 1 TB

9.3 GB Free of 40 GB

Western Digital External HDD
84 GB Free of 320 GB

SanDisk Cruzer
23 GB Free of 32 GB

SanDisk Cruzer*
0 KB Free of 0 KB

SanDisk U3 Cruzer Micro
3 GB Free of 4.1 GB

*I think the reason why that one SanDisk Cruzer reads 0k is because its formatted as a Ubuntu OS boot device.

For some reason the Share list (and when looking at the Shares with Windows File Explorer) only five of seven Shares are listed for the seven attached USB devices. One of the hard drives, the WD My Passport drive, keeps throwing the following Notification message in the Dashboard and is one of the two not shown/seen as a Share:

Unsafe device removal

A USB device (vendor: Western Digital, model: External HDD, serial number: 57442D5758485A3038363338383632) was removed without being ejected possibly affecting data on share MYPASSPORT.

Friday, April 01, 2016 4:30:59 AM Code 1123