Connection Issue (web access) - Everything was working fine... WAS


Everything was working fine until this morning.
Today I tryed to access my files using my celphone (android app, have done this before and everything was fine), but received an error message and could not access them.
Now I’m at home, and noticed that everything is ok, Cloud option is active, status is connected and redirecting ports is stablished.
IP still fixed, router configuration is ok, UPnP enabled, port forwarding configured same way My Cloud is… have no idea whats happening.

Any clue?

Already try to restart it, turn it off, disable anti-virus, deactivate Cloud, delete port forwarding and setup again (at My Cloud and at my router). Nothing works.

Hope anyone could help me out.



Has your router re-booted? You can check by looking at the router’s up-time status on its UI. If so, it may have been given a different global IP address by your ISP.

If you are operating in port forwarding mode, the MyCloud does not seem to be able to cope with router IP address changes, and cannot re-connect. It continues to report that all is well, but it cannot actually connect.

The solution in this case is to disable, and then re-enable Cloud Access. This seems to force the MyCloud to re-establish the remote connection.

Thanks for the fast answer cpt_paranoia.

Had read a lot of stuff you wrote around here! Glad you came to help!

Just tried to re-enable Cloud Access again. It appears it was disconnected. When I turn it active again, status turn into connected and it took some time with the message “trying to stablish a connection for remote access”. Needed to re-enable again. That message didn’t change for more than 20min.
When disable it, the message “accessing informations…” still on for more than 20min.
Decided to restart the device. After restart, the same message still there. When I try to active Cloud Access again, the other message appear “trying to stablish a connection for remote access”. At least, this make more sense… it’s really not connecting…

Maybe a relevant information, when I try to access the port I left open at my browsert, using my external IP and the external port I created (like: “http://287.12.761.32:7691” (not real)) but received the “ERR_CONNECTION_TIMED_OUT” message.

Read at [HOW-TO]: Troubleshooting Remote Connectivity Issues, that should appear another error.

So, I think It’s something wrong with port forwarding or something connected to it (I’ve not made this test when everything was working).

Where to go?

Thanks again,


Try these threads regarding remote access issues, with a WD Staff response today:

Did you check that your external IP address hasn’t changed?

I know you said your (internal) IP address is still fixed, but are you sure it hasn’t changed? If you have set up port forwarding rules, they may be trying to redirect to a previous IP address (although my router associated port rules with MAC address, not IP).

The other usual suggestion for weird behaviour is escalating resets (4 second, 40-second power-up: see the User Manual for details).

I have the same, or similar issue in that I’ve noticed yesterday that I could not access my files from “My Cloud”. My device shows as being inactive, but all my local computes are attached to it and actively using the device. I decided to reinstall WD Sync to see if that would fix the problem, but it just introduced a new one and/or confirmed my NAS isn’t available remotely. I have not made any changes to my network recently and for trouble-shooting, I powered off all the devices (routers, switches, and computers) and powered back on again - with the EX4100 being the fist device to be on-line after the router became active. The problem still exists! Any suggestions towards a resolution would be appreciated.



Note that this subforum is generally for the single bay My Cloud units. If your having a specific problem with the EX4100 you may want to post your question to the dedicated EX Series subforum where people more familiar with the EX4100 may be able to assist.

Sometimes when one is having a problem with remote access simply disabling Remote Access through the Dashboard > Settings waiting a few minutes (five or ten minutes) then re-enabling Remote Access through the Dashboard >Settings can solve the problem.

Also for some they’ll have better luck with remote access if they configure their My Cloud unit with a static IP address (either by assigning one through the router’s DHCP server or manually through the Dashboard > Settings > Network page) then enabling and configuring port forwarding within the My Cloud and router so the router routes the two ports (typically 80 and 443) to the My Cloud static IP address.

Have you tried my earlier suggestion?

Thanks for your suggestions. I still have the problem, but will move to the main form to look for a solution.



Thanks for the threads. One of them ask to test the port using a “port forward check”, and mine told that the ports are blocked.

In contact with my ISP he asked me the origin and destination IP. I didn’t understand, but after a few conversation, I told him that it was to configure a NAS unit connected to my home network. He asked me the IP of the NAS unit (fixed one) and told me it was ok (after he change a few configurations).

He told me that using ports with specific numbers were not blocked, but I understand that WD needs port 80 and 443 right?

I’ll tryescalating resets. Let’s see if it’ll help me out.

Let you know.


PS.: Do you think David with the same problem it’s just a coincidence?

Did you retry the port forwarding check after he’d made the changes?

Did you disable and re-enable Remote Access after he’d made the changes?

You can change the ports the MyCloud uses. See the User Manual, or use the following control in the Dashboard:

Settings/General/Cloud Access/Remote Access/Configure/Manual


Manage to open 8082 and 8443 (at least, online port checkers told me so).
Cloud Access is ok, says connected and ports are redirected manually (8082 and 8443).
When I try to configure My Cloud UI port forwarding (menu settings/network), it give me “FAIL” feedback. Didn’t understand why.
Router port forwarding is ok.
I think cause the My Cloud UI port forwarding “FAIL” thing, I’m not able to connect “wd2go” successfully.

After that I tried to configure Cloud Access “Automatic” and got success at “RELAY” access mode! Better than nothing! At least it’s working, not the way I waned, but it’s working.

Messing around, It still working without WD My Cloud UI port forwarding. I’ve tried to remove Routers port forwarding also, but then I lost connection, and I can’t connect even in “RELAY” mode.

I’m still trying to understand why I received the fail message trying to configure port forwarding at My Cloud UI. Everything was looking ok…

cpt_paranoia, every tests described above was done after ISP changes. And I need to say that 80 and 443 ports still closed.
Yes, re-enabled Remote Access after every change. Power off the unit for some minutes before turn it on again too.

Thats it.