Cloud access problem "User not authorized. (400057)"

Experiencing yet another issue with this device.  Managed to get it all setup fine yesterday so that I could access my music from my work PC via webdav.  Today when I come in the folder is apparently empty.  Log into dashboard (thankfully remembered to enable remote access to it) to see that I apparently now have 0 cloud devices (I had 6 when I left the house this morning).  Tried to send myself another code to setup computer as cloud device and getting “User not authorized. (400057)” message.  Went through all my settings and noticed that somehow the NAS has decided to turn off the cloud service by itself and again when trying (as admin) to change it back getting “User not authorized. (400057)”.  

Also underneath the switch for turning on and off cloud access I am receiving the laughable “Cannot establish remote access connection. Make sure you are connected to the internet.” despite accessing the dashboard remotely.  Tried rebooting, tried using My Cloud desktop (which works but doesn’t fix the cloud access issue for mapping webdav shares), tried the removal and readding of the admin password, still no luck.

Seen from search of the forum other folk have had this issue but can’t find anywhere any solution to the problem.  

Update - now I can’t even access my device via My Cloud desktop app.  Also seem to be unable to create or delete new users.  


See if the following link helps

Cheers for the reply.  As I said I tried the remove and restoration of the admin password to no avail.  Found out the issue was with accessing the dashboard remotely.  When I got home all my cloud devices were showing and I had user access.  Remotely accessed my work PC and login to the dashboard for it to claim 0 cloud devices and user access issues returned.  

Still experiencing issue when connecting remotely of dashboard claiming there is 0 cloud devices and being unable to edit shares / add users etc remotely.  Is there some port I have forgotten to open or something else causing this problem?

I have cloud service turned on (and can get it is still on by remotely connecting to one of my home devices and logging into the dashboard) but through any remote connection it is showing the service is off, says it cant establish remote connection, and won’t let me change it to on.  

*slams head off desk* now when I type in my WAN IP the dashboard doesn’t load AND the webDAV folders that I was previously able to mount with NetDrive are now not working either.