User Not Authorized Message 400057, nothing works


I’m getting this error as many users, I tried everything except to format and go back to factory defaults. Tried with no password, using passwords with only alphanumeric and numeric characters, restarting, tried to delete the admin user (not possible), created a new admin user (not able to provide it with access and not able to delete it after I noticed it didn’t work).

I hope this bug is fixed in a new firmware version or patch. I can access remotely via web using the public IP address and routing ports to the device, so that was my workaround, but not able to use the My Cloud app for iPhone or iPad.

Please let me know if anyone finds a real solution for this.

Thank you

Hello there, welcome to the community.

Let me see if I understand, you were trying to remotely access the WD My Cloud from outside of the network and you are receiving this errors? What port did you forward to the WD My Cloud? Have you tried a system only factory restore?

Hello, yes, I’m trying to remotely access the NAS system using the My Cloud app for iPhone. I configured and tested the system at home, it worked like a charm including the app, but then it went to its final location at the office and I lost it. Tried to modify the IP and there wasn’t an option to do that, only to connect as a user creating that code, and I’m unable to create a code for admin, it shows an error saying that there are no devices associated with the account, I try to do that and get the error, so it looks like a dead end.

Uninstalled the app and the first thing it asks for is the code that I’m unable to create. I moved the NAS IP to DMZ in the firewall and it works for web access, so I can manage it remotely that way, but I’d prefer to use the app and I can’t.

You have setup your home router properley?

Of course, but anyways the idea is to have access not only when I’m home, but on the move, that’s the whole point of having the app in my iPhone. Currently I can access via web from home and on the move, it’s just that I wanted to use the app which is more comfortable.

That’s why I asked if your had setup the home router properley.  

  1. have you setup a static IP for the EX4?
  2. have you enabled port forwarding on the router to point to the EX4?
  3. have you enabled the correct user for CLoud Access on the EX4?

Hello Skiwi,

Thank you.

The EX4 is at the office, in there I have a firewall and a static IP address. I added the EX4 to the DMZ so there’s no problem or need to forward ports.

Regarding enabling the correct user for cloud access, that’s precisely the problem, I get the error in subject when I try to provide cloud access to the user ‘admin’. I created a new user for me in order to provide it with access, same result. It works for other users but just with a limited time key, which is useless for myself. It did work when I first configured the system at home. In the same network I had no problem with the app and everything worked like a charm, but when I moved the EX4 to the office and manually changed the IP and network config instead of using DNS, that’s where the problems started. The rest of the computers in the network can access the shared folders and everything works fine, but cloud access is still a pain.

To clarify: You can access the EX4 when you are within WiFi range of your office network, but cannot when you are using the internet to connect from an external location?

I could by any means when I first configured it at home. Now in the office I just can’t. The app wasn’t able to recognize it, so uninstalled the app and reinstalled it again, and in order to add again the EX4 the app asks for the code. I can’t manage it using the app. I can only via web pointing my browser (from computer or smartphone, inside or outside the office network) to the public IP address of the office network.