User Not Authorized Message 400057

I am trying to set up cloud access for devices and other items on my EX4.  I get the user not auth message …i have previously restored the system to defaults…do i need to delete my user accounts and restart or ???  Advice appreciated.  (I also get this error with another account I set up for mysef)…

I get this message when i try to set up a new user, edit anything, etc…


Yes, you will need to delete the user accounts and start again creating the shares and the permissions.

Thanks, but I cannot delete the user accounts.  I get this message …

“This web account could not be deleted. Please make sure your device is registered and you do not have any network connectivity issues and try again.”

I’m having the same problem.  First I added a user and when I put in their email address I get the follow:

  • User not authorized. (400057)

When I try to delete the user as you mentioned I too get the following:

  • This web account could not be deleted. Please make sure your device is registered and you do not have any network connectivity issues and try again.

Did you try this with the latest firmware that was released 12/30/2013?

Firmware Release 1.02.25

Yes, I have updated to latest firmware.

if possible, tried after resetting the device to factory defaults?

That worked, thanks.

my “solution” was to reset to factory defaults and reformat the drives…i suspect there must be an easier and less destructive solution, but have not seen a reply indicating such.  Fortunately, my system was new and did not have much on it…

You don’t need to reformat your drives, only reset to factory settings.  It’s a bit of a pain, but not too bad.  I’m curious to know if you can back up your settings in the event it happens again.

I know that when I access my dashboard remotely I get this issue. I see no cloud devices, and can not add/delete a user or do the same with any cloud connected devices. I also see in the setting where cloud connection is turned off but I can still use both my iphone and mac to connect(both are connected as users and not admin account). However, when I pull up the dashboard on the home network its all there as if there’s no issue with the device.

1 Like

Still the same thing…


I have had my EX4 for about 24 hours now and ran into this same issue and found 2 causes and a solution to this issue.

After mutlitpe factory resets and reboots I’ve found these two things to cause the admin account to break.

  1. Chaning the IP from DHCP to Static

  2. Chaning the Server Name

Both of these issues will cause you to get user not authorized for almost everything you try.

The workaround to fix this issue is to:

  1. Select the Users Tab

  2. Select the Admin Account

  3. Turn the Admin Password Off

  4. Logout

  5. Log back in with no password

  6. Set the Admin password again.

This has resolved the issue for me, like I said I’ve only had this for about 24 hours and have not done a whole lot with it and these are the only known causes I’ve found so far.

I’ve Called WD Level 2 support and they remote connected to my computers and I’ve demonstrated this to them useing:

  1. OSX 10.9.2 with Chrome Version 34.0.1847.131

  2. Windows 8.1 with IE10 Version 10.0.9600.17107

The tech I spoke with at level 2 took logs from my server and stated he would get it over to the development team to look at.

So far after doing this I have not found anything else to cuase this other than chaning the IP address or Server name and so far everything else is working great.

If this works for you Please Star the post to make it easier for others to find.


Memorials, do you know if you solution helps resolve the issues from out of network when seeing the user not authorized message. I tend to get this message when I access the dashboard remotely and watnt to generate access codes or remove a device from a user account. I am not home to try your aolution so I thought I would ask and see if you knew or not !

That would be something you’d have to test, so far any time i’ve got this error I’ve removed the admin password, logged out and back in and set the password again and it has resolved the issue of not being able to Get codes or add/remove users.