Before you pack up your WD and return it, let's talk about Copying Speeds!


#1

This post has taken almost 6 hours to type up (I began about 5pm and finishing about 11pm) and my main reason for doing this isn’t thatI’m a staff of WD but I wouldn’t  hesitate to take any under the table money if offered, is that after having bought my two WD Cloud and MyBook, I really wanted to share my love for the devices by giving back to the forums.

Currently the two drives are sitting on the bookshelf with Book Covers ( yeah they look like books), probably sleeping since I haven’t access them for quite awhile, however they are quietly waiting for my next access. I will not lie to you as there were some transitional pains between my old WD Live and the new drives and I’ll cover the pains later in this post. 

I’ve read every single post on this forum looking for small nugets of information that I have been using to fix my problems with the device and I have been chuckling on the large number of posts that complains about the copying speeds. Even the Futureshop reviews, where I bought the drives, complained about about the speed of the device.

if you are having problems with copying files which seems to take forever… the problem is most likely “you” (well perhaps not you particularly but your infrastructure in your house) and it is not the device :P 

Your Car will go 200MPH, just not in local traffic  

Lets start off with the fact that your brand new WD Cloud is “NOT” slow. It has the ability to be as fast as some of the more expensive NAS devices out in the market however you have to spend a little time in finding out “why” you are having problems; and yes there are some nasty software problems that WD has (we will talk about it later), but for a new out of the box system you won’t have to worry about it till you fill up your hard drive with data. 

How fast you ask? well for large movie file of 733MB, it takes roughly 15-20 seconds to copy it over to the NAS. To read it back from the device takes less then 10 seconds; reading is about twice as fast as writing.  

This is the ultimate best scenario for your WD Cloud by being connected on a gigabit ethernet LAN (Local Area Network) and I’m reading and writing on a SSD flash drive on the Mac side.   This means you have a router that has gigabit ports so that both your PC/Mac and WD Cloud are connected to the same router and your WD Cloud is showing a green LED on the ethernet connection. If it is showing up yellow, that means you are connected on100Mbits lan.

Just a brief note on the USB 3.0 Speed via the NAS

This was the selling point for keeping the two devices as I bought the 4tb WD Cloud and the 4tb WD MyBook together in hopes of using the MyBook as a mirror or rather as a backup, perhaps using scheduled rsync within the NAS itself.

The surprise was the network speed of 40MB/s write and 70MB/s reads off the WD MyBook connected via the USB 3.0 port, which is just slightly slower then 45MB/s write and 75MB/s read from the WD Cloud. This performance  was more then acceptable!!

Going via WIFI only

So I disabled the wired connection on my Mac and enabled WIFI only to see how it would feel. To copy a 733MB file to and from the WD drive it took about 85 seconds, giving me 8.6MB/s which is pretty standard for WIFI.

What this means is regardless of whether you have a WD Cloud Drive or a very expensive data storage server on the other end and if you are transfering data via WIFI, this is about as fast you will get.

So if you got a 1TB drive on your laptop and you want to copy 1024GB to the NAS, at speeds of 8.6MB/s, it comes out to about 33 hours; probably more because smaller files takes longer.  

For a more reasonalbe 100GB drive, to time machine backup would be about 6-8 hours, but once the initial backup is done, all later backup changes should take very little time.

Small files always takes longer, just the facts of life…

Now the funny thing is that if you copy many many small files, even over the gigabit ethernet connection, the speed drops down to about 4-6 MB/s and that is because you really don’t have much memory for caching the data on the NAS and that is  to be expected. So if you are copying a lot of photos, mp3’s, ebooks, no matter what device you buy, the speed for copying small files is always terrible because even if you have a very very expensive NAS that has a large memory cache, it will eventually fill it up and you end up with 4-6MB/s.  

The good news is that once you get the data over to the NAS, it is pretty much permanent until you buy your next device and have to do this all over again.

Okay, so are we on the same page for Data Speeds? Gigabit ethernet = good and Wifi = ok for laptops for general file copying. 

The Nitty Gritty facts about your Network

Local area Network (LAN) is the interconnection of all your devices locally and they are separated from the Wide Area Network (WAN) which is the internet by your modem/router (usually the device that gets installed near your cable outlet). 

Back in the old days of modem, then a router, then a switch or hubs, it was just a little bit easier to point the finger at which device is giving us the problems. Today, the cable company has installed an all-in-one modem/router/switch of which all the devices are plugged into. This router/switch is also your Wifi N hub.

When my internet went on the blink (cable signal going in and out), my whole LAN reset every 15 seconds. Thus all my files on the WD Nas was inaccessible. Yes it is true, without my router I cannot access my data on the NAS :frowning:

Also if you have a yellow light on your WD Cloud ethernet connection, this means that you are on a 100Mb network from your router. I remember back in the old days when you had gigabit switch and if one of the devices was a 100Mb, it slowed the whole switch down, which means you cannot simply connect a gigabit switch to 100Mb router; you will need a gigabit router.

You can buy a separate gigabit Router and connect it to your existing Router thus separating the cable modem trouble from the router. You can then make the existing Modem/Router into a gateway so that its job becomes a modem only. Thus you can buy one of those fancy AC Wifi routers on the market to give you gigabit WIFI speeds. 

Luckily my internet outages was resolved after a few days with a visit from the tech guy. Meanwhile I bought a switch and gave all my devices static IPs so my NAS was isolated from the modem/router. After testing a few new $200 routers, I decided that money was better spent on a WD Cloud :stuck_out_tongue:

Now for those with laptops that don’t have a gigabit ethernet like the new Macbook Air, you have a couple of choises. Since they have the new WIFI-AC, you can get a new router like the Airport Extreme that replaces your modem/router. Although none of the other Apple devices like the iPhone or iPad supports AC at the moment, this will probably be supported in the future.

Your second choice is the USB 3.0 to Gigabit Ethernet NIC Network Adapter which allows you to connect the gigabit ethernet; these are only $50 at your local Computer store.

Lastly there are those older Laptops that probably has a 100Mb ethernet with possibly A/G Wifi and not N. Just because you have Wifi, doesn’t mean you have N. With b and g, if you turn on your microwave to heat up your coffee, you just might interrupt your network.  So if you have b and g, you are talking Mbits here and not even MBytes. It is somewhere in the neighborhood of 11Mbits/S which means about 1MB/s if you are lucky. With g you get about 54Mb/s which works out to about 4-6MB/s.

Just because you connect your 100Mb ethernet laptop to the gigabit Network doesn’t mean you will get gigabit speeds. Your old network card will still only go about 6-8MB/s even though it is rated at about 11MB/s max.

Most likely on your older laptop you have a USB 2.0 port. There is almost a solution to this other then buying a new computer and that is Belkin’s USB 2.0 to gigabit network adapter. Although your max rate of a USB 2.0 is 480Mbs and a gigabit ethernet is 1000Mbps, Belkin claims it can do gigabit. Even if it doesn’t and does 480Mbs, it is still probably better then a measley 100Mbs.

So there you have it… from end to end, which really has nothing and everything to do with the WD Cloud. Nothing meaning that it isn’t the fault of the WD Cloud and everything meaning that without a good gigabit ethernet network, you won’t enjoy the WD Cloud to its fullest.

Troubleshooting

  1. reduce the number of connected devices on your router/switch to just your pc/mac and your WD Cloud. and reboot everything.

  2. for your pc/mac make sure wifi is disable. 

note: if you have a mixture of gigabit and 100Mb devices on your router/switch, your router/switch may default to 100Mb.

Checking what speed is your Ethernet Card on your computer

So everyone claims they have a gigabit ethernet card on their PC, so how do you tell?

On a Mac

  1. click on system preferences

  2. click on network

  3. select Ethernet and it should show connected

  4. click on Advanced…

  5. select the hardware tab

  6. it should show Speed: 1000baseT if you doing gigabit

On a PC 

  1. select control panel

  2. select Change adapter settings 

  3. double click on Local Area Connection

  4. it should show local area connection status with speed: 1Gbps

Mapping the Devices as a drive

This is how I’ve been using the NAS device by mapping the device as a local drive. SMB for Mac and Samba for PC’s. After mapping the shares as a drive, with the gigabit ethernet, the shares almost feels local.

On my Mac, once your WD Cloud is powered up 

  1. in finder, click Go

  2. select connect to server

  3. click browse

  4. you should see wdmycloud, double click on this 

  5. you will see Connected as: Guest,

   a. if you have already created users with access to certain shares then you must click on ‘Connect as’ and enter your       userid and password.

  1. select the shares that you want to connect and they will show up on your desktop. 

On the PC, 

1, click on computer

  1. click on map network drive

  2. click on browse under “what network folder would you like to map”

  3. click on WDMYCLOUD and if your shares has a userid and password, it will prompt you for it at this time

  4. you will see all your shares, select the one you want, Public is the default start up share

  5. click ok and click finish

  6. you can now see the NAS as a mapped drive in your Computer (treat it just like a local drive).

Finally the problem with WD Cloud

Ok, now we can finally complain about the WD Cloud device itself.

WD, in all its wisdom, wants to sell you a Cloud device; rather then just a NAS or file server. What that means is that you get all your music, movies, files and photos via the network; this includes an iTunes server, Twonky and DLNA. In order to give you quick access to these media files, a couple of programs attempts to catalog and convert photos into tiny images, on your tiny NAS linux device with 2 CPUs that are running at about 600Mhz each. If you are lucky, after a couple of years, all your photos, music files and movies will be indexed in a hidden sub folder in every single folder that you have on the drive.

Now if you had an empty drive and you copied a couple of million photos, music or movies, your tiny little WD Cloud should be working hard at running through all your files and you should hearing clicking and clacking of the hard drive at work.

If you should decide to shut down the device at this time after copying the million media files… here is what happens when you reconnect…

The device will disconnect itself from the network

  1. the device upon booting up will have a white light. Depending on the number of media files, your device might come back with a blue light after two years :P… or in some cases, it can come back after a short while (the definition of short while can be as short as half hour to years thereafter). 

  2. a second problem will manifest itself. After the blue light comes on and you managed to map out the device, everything you do is very sluggish. Your WEB/UI will be unresponsive and trying to look at your shares will show nothing in the directories. Then all of a sudden the device disconnects leaving you bewildered and frustrated as you repeat the steps of rebooting without properly shutting down the device because you cannot access it via the WEB/UI anymore. At this time you simply pull the power plug… and after plugging in the power, the white light stays on for years…

Now, in another post I have up, I SSH into the device and killed the processes that takes up the CPU time. Remember, I knew about these indexing process from my WD Live days so I knew that I had to shut these processes down. However what I did not know was that in killing the processes, I acidentally fixed the 2 problems that had been plaguing every user.

The Device becomes unresponsive after plugging in a USB drive

I’m not sure if the media gets indexed on a USB drive that already has data, however I do see a lot of processes running on the WD Cloud when a USB device is plugged in, again because I killed the processes, this problem also went away. 

If your USB drive is empty, you will not have a problem. Also if you fill the USB drive through the WD Cloud shares, the indexing program should index your files simultaneously thus resolving any thrashing upon initial plugging in. 

The lock up and thrashing occurs only if you have media on the drive that have not been scanned when you initially plug in your USB drive. 

I had encountered this problem because I used the USB 3.0 port on my PC to fill the drive with data before plugging it into the WD Cloud which immediately caused the device to become unresponsive.

It will fix itself after the indexing is done

As the WD Staff will tell you, the process will eventually complete and your device will be fine after that. The problem occurs when you unplug and re-plug the device a few hundred times as well as throwing it out the window to fall 14 floors. At this time, after crazy gluing the pieces together, returning the device might be a good idea.

However I have read that it gets hunged up sometimes on a particular photo or media, which causes the scan to be 97% complete but never completes.

A Suggestion and Solution to WD

I do like the ability to see my thumbnail photos on my iPhone/iPad but just not all of them. As I’ve mentioned it in my other posts, I am a photographer and there are hundred of thousands junk photos that I need to keep for the client sake. However there are about 50 folders of good photos that I wish that I could have my Cloud device index and see within my iPhone/iPad photo app.

Although I don’t use DLNA, Twonky and the iTunes server, I can imagine the same that allowing the user to specify which folders are used for the media might be a good idea. 

Also allowing the user to specify a time to do the indexing rather then this willy-nilly indexing that occurs everyday, every minute. I had the WD Live and before I stopped the scanning process, I swear that the device was clicking and clacking for over two years; never sleeping.

Workarounds

I have two other posts that solves these problems (for myself). If you are uncomfortable about voiding your warranty because they do involve SSH’ing into the device and making software changes, then don’t attempt these suggestions.

My workarounds is very simple and that is to disable the two processes immediately after plugging in your device and as soon as you can ssh into the device. Otherwise the scanning will resume and your device will soon disconnect shortly after.

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable

Conclusions and final notes

I’ve been researching Raids, File Servers and NAS devices for over two decades. In fact just prior to buying the two WD devices, I had bought a Vantec Raid devices with 4x2TB drives giving me 8TB of storage. The only problem with the Vantec Raid device was that it was only usable via the USB 3.0 port; thus requiring some sort of PC server to connect the drives to the network. Long story short… the Vantec Raid device is now on Craigslist looking for a new home. 

The two WD drives are filled to the brim with photos, music, movies and ebooks. I have the WD Cloud app on my iPhone and iPad and I’ve on many occasions logged back to my drive looking for another book to read or to watch a movie. There are a few other Cloud drives out in the market, but WD Live got me first when I bought the drive from Costco thinking that after extensive testing that I would return it; that was two years ago. 

If you think of the WD Cloud as a slow storage device after being use to USB 3.0 speeds of 120-140MB/s then it will make your purchase difficult to justify.

If you think of the WD Cloud as its name implies as a Cloud storage device, it begins to make sense that after you copy your data over that it is there in the clouds whenever you need it; or in my case over there on the bookshelf :slight_smile:  

Thanks for reading…

and I noticed that this forums has kudos, so if you have some to spare, click on the kudos for this post.

Thank you.

p.s. it has been a long 6 hours and I’ve proofread this post about a dozen times, thus if it is hard to read at certain points in the post as I wane and wax and change directions about a certain topic, I’ll fix this in the morning.


Less than 5MB/s transfer rate via gigabit ethernet
How can I disable the thumbnail building and scanning?
Direct connection to Windows PC
Is there a better alternative to My Cloud hard drives?
Connected USB 3 device is very slow
Very Slow file transfer Rate
EX2 Ultra very slow to upload
Did I do this right? LAN / WAN
Slow unresponsive cloud device.. Help
Time Machine changes in new Mac OS Sierra
How can I use USB 3.0 plug?
My drive has gone into la-la-land again
"Preparing to copy" takes exceedingly long (Mac)
4 days to back up 60G of data and I gave up, Any advice on how to speed this up
4 days to back up 60G of data and I gave up, Any advice on how to speed this up
Some queries regarding My Cloud 3TB
Slow data transfer Aoole Time Machine
Cut to Cloud Hard drive (Not copy)
Using USB port on rear of MyCloud
S L O W MyCloud - with Time Machine
Transfer Speed
How to increase transfer speeds
My cloud and apple el Capitan
Big Library size Handling with My Cloud drive
Whats the fastest way to transfer from my cloud to my cloud mirror?
Appalling speed on MyCloud device, backups fail, etc
Ex2 2TB Mirror extremely slow
Newbie - Transfer from Computer To MyCloud way to slow - 880 kb per second
Can connect with LAN cable but not over WiFi on the same network
Slow when I drag files
Safepoint issue .... or not?
Wich is the max link speed between my router and macbook pro 2013 can i get, 80/100mbps?
Copy from Usb Device - > My Cloud Gen 2
Copying Files from pc to mycloud
Is a WD MyCloud right for me?
Transfer file too slow
New user question - v slow backups to my cloud 4.0 Gb - is this normal?
Backup to USB is taking hours... is this normal
Backup to MyCloud very slow, how to speed it up?
Slow Mac Direct Connection To WD My Cloud
Need Help with Remotely Uploading - Super Slow!
WD software and My Cloud
Slow connection in the same network
Using external usb enclosure to access my files
Wireless mouse/keyboard stop working when copying files to My Cloud
Having problems with a slow connection?
WD MyCloud 3TB - how to improve speed via WiFi AC1750
WD MyCloud 3TB - how to improve speed via WiFi AC1750
Using 2 WD My Cloud 4Tb?
Mycloud extremely slow
What type of drive is in the WD My Cloud?
How do I improve my upload speed
Throughput testing WD My Cloud
Uploading process slowing down
Rather happy with my My Cloud but can I increase the speed?
Is this slow? or is it just me?
Slow transfer speed since upgrading to Windows 10
Avoiding a hard reboot - Web UI not available and can't connect to WD My Cloud
WDMyCloud (2TB) slow under Windows 10 & some programs can't access files
WDMyCloud (2TB) slow under Windows 10 & some programs can't access files
Ubuntu + Android device
SSH changes vs future firmware update
Slow transfers, slow connection. Osx yosemite
Issues about speed, index and USB.. any hope anybody?
Second my cloud, still no go
"Capacity Available" will not display in the Dashboad
WdMyCloud extremely unresponsive and slow
New WD My Cloud 6TB; Slow File Transfers
Slow and Unresponsive
New user,,,with issues!
How to setup WD Mycloud?
Transfer speeds data request IOS
Buying the WD My Cloud: Worth it?
ALL OF MY Cloud Problems Solved!
Content Scan not going anywhere
My Mycloud 4 Tb FINALLY SLEEPS
WD - PLEASE! Stop my drive from Scanning! PLEASE
Easy method to downgrade to previous version of the firmware
Slow performance and file scanning applications on WD My Cloud
Is the cloud server waking up my WD Cloud every 25 minutes?
Estimate read/write speed?
More Info Needed - The WD My Cloud is Disconnecting from the Network
Dashboard problems - MyCloud 4tb
Slow file copy/move to PR4100
New WD My Cloud 6TB; Slow File Transfers
WD - Frequently asked questions
Slow wd mycloud mirror
No Internet Access?
Hello my cloud connection problems need help
MyCloud Extremely Slow
Add another disk
Slow TM backup
WD MyCloud is unbelievably unreliable!
My Cloud working very slow or not at all
Can I RIP out the HDD to use in Desktop?
Slow Usb 3.0 Transfer Speeds (one twentieth expected speed)
WD Mycloud 6TB Network extremely slow
#2

Words of wisdom, congrat for this! I love this device, fast enough and you can tweak almost everything on it,

BUT "wants to sell you a Cloud device"

 

This is not a Cloud Device , this does not meet the requirements:

  1. Reach the files wherever you are whatever you use (aka reach from basic IE or FF without anything installed)

  2. Share files/folders with strangers. You just can’t do that.

You have to have Java installed (you have to uninstall the newest, and reinstall an older one), you have to disable almost EVERY security setting in JAVA (doesn’t even have a proper certificate).

You can’t share files with a friend, I tried a 900mb file to share, but I had to install the desktop app, and I had to ask for an email address (because it just doesn’t give me the link for my file, **bleep** logic).

After 50% the download has failed, and she could not continue downloading, had to start over. It happened twice when she asked me to upload it to somewhere else. So I had to upload to google drive…and she could download easily without any issues.

So My Cloud is not a Cloud device, its a pretty good nas with good Android support, and thats all.

Thats why I want to install Owncloud , but I just can’t…


#3

@BullZeye,  

You are absolutely correct in that the ability to share certain types of files which is a part of a cloud service doesn’t work.

In fact the method that they chose to do it, seems to go through their own servers and when I tested that out this morning, their servers are down; at least my iphone safari and my mac safari was unable to download the movie that I sent as a link.  

Just in case my firewall was blocking it, I also switched that off… no go.

The ability to send ebooks via email via the iphone/ipad app does work.

However with all this said…everything evolves and the ability to send a movie file as a link (even though it doesn’t seem to work) and/or the requirements of having to install Java is a work in progress.

Someday all this will be painless and suddenly it will all just work and the next generation will have no idea what you are complaining about. 


#4

Hi,

@Ralphael

Yeah, that’s it.:smiley:

and know… let as clear all the little errors the community present…

Lucky (with MC):wink:


#5

@BullZeye,

So a little more investigation, since I’ve turned off my wdmcserverd from my solutions above, my device is unable to share movies. Unfortunately even after I re-started my WDMC server, the link still doesn’t work.

It is interesting on how they chose to share and rather a direct link back to your device, it goes to a central WD server which communicates with a program on your device  in order to pull the files. I would have prefered something like a web server on our own device that streams the movie to whomever the link was sent.


#6

@real_Lucky

thanks for joining in the discussion…


#7

added some info about wifi b/g and 100Mbs network cards on older laptop.


#8

So a little more investigation, since I’ve turned off my wdmcserverd from my solutions above, my device is unable to share movies. Unfortunately even after I re-started my WDMC server, the link still doesn’t work.

 

It is not wdmcserverd-s  fault, few weeks ago they changed something and I also couldn’t stream video with a virgin My Cloud (firmware upgrade default configs, without any SSH stuff) from a protected WIFI (only port 80 and 443 open). It was working for a long time but it stopped working at the end of January.

Edit.: Just tested, the video stream is working on local(home) WIFI with Android APP, also works well with 3G mobil internet, and just disabled wdmcserverd. :slight_smile:

So the problem is not with you, the problem is with WD. :slight_smile:


#9

So I’ve reached my max of 20,000 characters in one post.  I had typed up an extensive troubleshooting (which is now deleted) and simplified to:

  1. connect only your pc and wd cloud to the router. reboot everything

  2. turn off wifi

note: if you have a mixture of 100Mbit and gigabit devices, your router/switch may default to 100Mbit.


#10

Ralphael wrote:

[…]

You can notify us [Moderators] in such cases. We can link the posts.


#11

Thanks Trancer… no I think I have said enough :stuck_out_tongue: I’ll start up a new post if there is a need :stuck_out_tongue:


#12

hi Ralphael,

I just wanted to say thank you for sharing your experiences.

The workaround you propose in the first post (stopping wdphotodbmergerd and wdmcserverd) seems to have stabilized my MyCloud and I’m able to connect reliably, and copy many files to it without any slow downs or disconnections.

Thanks,

Sean


#13

Thank you bigstorage… appreciate your thank you… and I don’t know how people have been giving me kudos, but I have somehow been receiving them; perhaps “accept as solution”?  

Please continue to send me kudos as I’m indeed collecting them and hoping that with enough kudos I might be able to do something about these bugs :P 


#14

Very informative thread Ralphael, thank you :slight_smile:

p.


#15

you are welcome mizsio and thanks for reading… 


#16

Hi Ralphael,

I was thinking of buying the WD MyCloud box and your words of wisedom inspired me to take a risk, getting one of these for myself. It’s always a gamble buying new technology bits and hoping it will do, what you expect it to do.

First thing I did was connect the WD MyCloud to my network (entrirely 1 Gb network capable ports - including router).

I updated the firmware to the latest via the network connection, which was reasonably quick to update.

Everything worked perfectly, straight from go,  the 3 Tb of data I had on my former Seagate GoFlex (manually connected to a SATA port on my P.C) only took a few hours to completely copy across.  I tried transferring the whole

lot across via the Seagate GoFlex 100mB/s ethernet port, but that was horrendously slow.

I loved the way I could get access to this device, via the internet, (wd2go.com) to the files stored on my WD MyCloud (at home). It indeed acted as a “Cloud” device for me as I could map the connection to a network drive on my P.C and then
copy files across to my P.C (wherever I am) - Just drag and drop from explorer and it’s pretty quick to transfer across as well.

I just wanted to say this box is fanatastic and I am very happy with it. I know there have been a few critics out there

who haven’t had good things to say, but I think they need to make sure everything fits the criteria for successful results,
which this device is well capable of producing.

I had the experience of using a Seagate GoFlex device and that took a while before I got things working reasonably
well for me. It’s good to have a device that now well exceeds the capability of this former device.

Very happy with this WD MyCloud and my experiences with it.
Added Kudos for your article.

Cheers

Patrick


#17

Yay mchalep! 

Thanks for the Kudos and only 2983 more to cash in my airmiles :stuck_out_tongue:


#18

For mchalep

Just drag and drop from another network is very nice but if you try to transfer a big file like a movie it aint possible.

WD engeniering have lots of work to do.


#19

Ralphael, did you ever open up your my cloud physically to be able to ssh into it? I’ve searched around in other threads for pictures, but I haven’t seen any guides for how to take the my cloud apart. I’ve only seen pictures of it opened up. How do you access the internal parts? I don’t plan on doing this, but it’d be good to know.


#20

as Andreaspf8585 said at the end of Rebuild your my cloud. The drives are fairly similar.

http://www.youtube.com/watch?v=TGLJi66vxnY

When I had my live, I actually considered taking it apart and sticking in a 4TB drive, but I ended up buying a 4TB Cloud  cheaper then a barebone 4TB WD Red drive. In fact after selling my WD Live for $125 my upgrade turned out to be about a $100.