[APP] BubbleUPnP Server v0.9 for firmware V4+ (11/2015)

Live Counter

Note: Can’t see live counter image above? Try again later as my WDMyCloud is offline!

BubbleUPnP Server provides new services, many of them running on top of your existing UPnP/DLNA devices.

This is BubbleUPnP Server v0.9-update10 for WDMyCloud V4 Firmware successfully built with 64K page size memory patch. For setups and details, refer to http://www.bubblesoftapps.com/bubbleupnpserver/.

For those interested on how to build from the source, refer to this thread. It may help others to continue supporting the 64K page size memory for other packages. Below are my simplified instructions on how to get it installed on the V4 firmware (will not work on older firmwares).

AND I have also made an online generic 64K page size memory package installer to simplify the installations of Debian packages on WDMyCloud. This will not work on older version 3 WD firmwares and I’m not planning to support it either as I’m sticking with the V4 firmwares. Based on dynamic server-side FastCGI, perl and shell scripts, I’ll be using this method for newer guides from now onwards. Feel free to parse the script codes. All bug reports, opinions and suggestions are welcomed.

The Generic Online Installer:

1) Auto download of required debs including its dependencies if any.
 
2) Debs installation in the required order to prevent dependency issues.
 
3) Auto run custom configurations if any.

If you proceed further, you are fully aware of the usual WD’s _warranty void _clauses including disclaimer from any damages that may resulted from this guide.

  • Enable SSH on your NAS from the WD DashBoard settings if not done so. SSH to your NAS port 22 using i.e. putty root@wdmycloud.

  • To proceed with the installation, first you need to get the username and password from me. The credentials will expire hourly e.g. “1AM,2AM,3AM…” to prevent intentional abuse on my network resources. Click on the link below to get the credentials :

    https://teanazar.com/wdmycloud

  • After obtaining the credentials, just copy & paste into the SSH terminal session of your WDMyCloud:

    export NAZAR78_USER=user; export NAZAR78_PASS=pass; export NAZAR78_KEYS=keys;

  • Then run the online installer on your WDMyCloud copy & paste as below, follow the instructions and enjoy (-:

    curl teanazar.com/installer.fcgi?bubbleupnpserver_0.9-update10|sh;

For quick backup and restore when WD release newer firmware update:

  • Before updating firmware:
    cp -a /opt/bubbleupnpserver/configuration.xml /shares/Public/bubbleupnpserver.xml;

  • After updating firmware:
    cp -f /shares/Public/bubbleupnpserver.xml /opt/bubbleupnpserver/configuration.xml;

  • Run the online installer again. Your settings will be preserved and you may then remove the xml backup.

Online Installer change log:

[20151117] Added BubbleUPnP Server v0.9-update10.
1 Like

Ooh… nice.

I currently run Bubble server on a little Android box, but Android has a habit of booting it into touch without asking…

Having Bubble Server running on the MyCloud would be useful. Thanks.

1 Like
Installing required files by dependencies...

Installing (1)-> x11-common_7.7+12_all 245KBytes…OK!
Installing (2)-> openjdk-8-jre-jamvm_8u72-b05-1_armhf 480KBytes…OK!
Installing (3)-> openjdk-8-jre-headless_8u72-b05-1_armhf 24MBytes…
Error-1: Unable to install required files! ‘openjdk-8-jre-headless_8u72-b05-1_armhf’

Having an installation issue. i only have Minidlna installed on latest firmware. i have removed my Public share which could be the cause of this problem?

thanks.

I’ve fixed it, due to missing paths :slight_smile:

Ah well, looks like I’ll be waiting until you release it to the public; was hoping to be able to help check out the build.

ps. the response timeout is a bit fierce; I barely had time to read it before it timed out…

I might even buy you a coffee… :wink:

awesome! thank you! up and running = )

Now released to public :smile:

Unable to install. I am on a 50mbps internet connection and am able to access the internet / mycloud just fine

Checking available rootfs space…

    Partition : 1922.20MBytes
    Available : 1182.39MBytes
    Required  : 70.71MBytes

Estimated 1111.68MBytes left after installing. Proceed? (<[N]o/[Y]es>) Y

Temporarily switching from a probably slow ISP DNS to GoogleDNS…
DNS: 8.8.8.8/8.8.4.4

Checking your internet response…
PING: deleted my ip address -> teanazar.com = 0.601 secs

Checking resources…
Downloading -> bubbleupnpserver_0.9-update10 (74,146,378Bytes)…
Error-2: Unable to retrieve required files! Files extraction failure.

The download doesn’t seems complete. Try again?

Thanks. Worked after rebooting mycloud ( don’t know why a reboot helped )

Strange issue. It’s not starting when I reboot my wdcloud. It worked before a restart. Any pointers on how to manually set it to auto start

try to reinstall it :slight_smile:

Installed and running successfully, thanks. Will have a play when I’m away from home.

The only trouble I had was if I opened the credentials page in a new tab, rather than just clicking it; the credentials box didn’t appear.

Some cool stuffs you can do with JQuery, PHP and Perl.

You’ll not see the credentials if you access the page directly or from other sites including my domain itself, refresh the page or skip the adverts. Also the app forum page where you click needs to match what you want to download else the installer will fail.

Yeah I had to do this because I want all request to originate from this WD forum. Unfortunately some browser won’t work correctly if the link is not directly clicked. Works for IE and Chrome but not on my mobile. Hoping the image “How to get credentials?” helps :stuck_out_tongue:

Okay. The trouble is, the ‘natural’ thing for me to do is open in a new tab so I have the original thread to refer to for the rest of the instructions… I think the easiest instruction would be to say explicitly not to use ‘open in new tab’. New tab is almost second nature to me; I rarely go down the rabbit hole and then Back up. But maybe that’s just me. It’s only a minor problem, like those timeouts that don’t give me chance to read and consider what I’m accepting…

I registered the new server with BubbleUPnP player on my Hudl; all went well.

The only problem I have now is my new ISP seems to cause frequent router reboots, which change its IP each time (ISP got taken over; new ISP is a biggy, link rates have dropped to a lower cap, too…).

Thanks again; look forward to trying remote access, though I fear it may lead to changing ISP to get a decent uplink rate… Your gigabit rates are unheard of in the UK.

I unistalled bubbleupnp with command dpkg –purge , but when i try to access ip:58050 it is still running?

Any help?

Thx

I’ve replied you on my site.

Bubble server installed and running for some time now, thanks. Remote access works until my router reboots (as reported earlier). I figured out a way to get the MyCloud to find and log the new IP address in a share folder that I can access remotely, but then realised I’d still have to be able to prod the server to use the new address; may have to investigate the remote server control, but I’m not so keen on that.

Anyway, on to the reason for posting…

ffmpeg

I’ve not needed transcoding so far, but, whilst idly looking at the server status page, I notice it reports that ffmpeg is not found, so it can’t transcode audio or video.

So I thought I’d install fox_exe’s build. Only to have it tell me I already had the latest. d’oh! The ff**** utils are in /usr/local/bin (ffmpeg, ffprobe, ffserver).

Reading the server documentation, it says it will look in the install directory, and then in the PATH. My PATH includes /usr/local/bin, so it ought to be able to find it.

A server restart made no difference.

Any ideas, anyone…?

I also have this issue, did you also notice that the default MC dashboard becomes very slow?

Cheers.

No slower than usual… :wink:

The Bubble Server UI is pretty sluggish.