With the new update from MAC Catalina will not accept 32-bit

I don’t see any update fro 32 to 64-bit for Mycloud EX2

1 Like

Hi Robert8,

Thank you for reporting the issue regarding WD Discovery and macOS 10.15 Catalina.
WD Discovery version 3.4.89 does not support macOS 10.15 Catalina.

We are working to release a new version of WD Discovery that will support macOS 10.15 very soon.
Unfortunately, we cannot provide an exact date as to when the version of WD Discovery that supports macOS 10.15 Catalina will be released and available for download. We appreciate your patience, understanding and apologize for any inconvenience this issue has caused.

I cannot access my Passport drive since the Catalina update. I work solely from my Passport and now I cannot work

So you said this updated firmware would be out “very soon” on Oct 11, 2019. It’s now Feb 29, 2020. Why is there still no update? I’d like to upgrade to Catalina, but I don’t want to brick my backup. It’s been over 4 months. Do you have any more info on the time line? I may need to just get a new backup device and it WON"T be WD ever again if I have to do that.

Any update on this? Still cannot get Catalina to work with My Cloud EX2 Ultra. Need to know if we should abandon WD for a competitor that works. Thanks.

@jkarl83 can you provide a little more detail regarding your issue.
What WD Software are you referring to using with your My Cloud EX2 Ultra that does not work with macOS 10.15 Catalina?

@SBrown Here’s a little more info…

When I setup Timemachine for mac backup from Catalina 10.15.6, the first backup completes, then I get the following error on both my macbooks. “Time Machine completed a verification of your backups. To improve reliability, Time Machine must create a new backup for you.”

No matter how many times I try to do a new backup the same happens. I’ve scoured the web looking into this one with no answers other than get something else like a Drobo. I love WD and have used your solutions for decades, but this one is quite frustrating. I hope there is a fix coming soon.

Thanks for looking into this!

@jkarl83 Thanks for providing more detail.
How you collected your TimeMachine Backup logs and opened a support case with Apple?

We’ve published the following article that can help with this issue including
ensuring macOS not going in and out of sleep mode during TimeMachine Backups.

Answer ID 14734 Time Machine Must Create A New Backup For You
https://support-en.wd.com/app/answers/detail/a_id/14734

@SBrown - Thank you for this! I hadn’t seen this link before.

I followed it and the first backup was a success! But then… the next day the incremental failed with the same error, won’t work now, and needs to start a new one. This is so frustrating. (My buddy has a drobo and is making fun of me. :man_facepalming: )

Thanks for trying to help. I do appreciate it.

Update: I opened a case with Apple. No luck there yet either.

Here’s a page from Apple:

Backup disks you can use with Time Machine

In the list is an option for “Network-attached storage (NAS) device that supports Time Machine over SMB”

When I try to setup a backup using SMB from Catalina, it says the backup destination cannot be set. Is there a way to check the EX2 Ultra to see if SMB is active? Any suggestions on how to troubleshoot SMB between the EX2 and Catalina?

UPDATE: After much research, I finally got the backup to work with SMB. Will let you know if the incremental works tomorrow.

UPDATE 2: Bummer, right after I wrote about success and submitted, it then failed. It’s back to saying it needs to start a new backup. :frowning:

UPDATE 3: After several calls with Apple, they state they do not troubleshoot TM issues related to NAS storage and recommend contacting the storage vendor. (Gotta love vendor finger pointing.)

Anyone else seeing this?

I opened a support ticket with WD too.

Good link from Apple and Synology: https://discussions.apple.com/thread/250794335

FINAL UPDATE: Open an incident with WD support. They asked if I mapped the drive to my mac. In parallel I had found directions on the web for mapping the NAS and it worked. Hope this helps someone else out there!

https://support-en.wd.com/app/answers/detail/a_id/10789