Windows Media player doesn't play video (mpeg)

Why,
Why doesn’t windows media player play my videos in mpg format when I am connecting outdoor, by internet with my normal applicationWD My Cloud (You know the icon on my laptop screen). Why…
Though it does play the video when I am at home and connect straight by the file system.
And i have configured entrance and all that with the dashboard and i have configured the Twonky DLNA. It is just that when I connect by the internet windows media player tells me there has occured a fault by playing this video. Thats it. And I cannot choose another player because the WD Mycloud pane doesn’t let me choose. It starts the f… windows media player. And it’s 1 month now. and I ask you all
WHY!
Am I the only ship on the ocean???

What is your default app on your laptop for playing mpg?

cat0w
USA

[quote=“Jovank, post:1, topic:141189, full:true”]
Why,
Why doesn’t windows media player play my videos in mpg format when I am connecting outdoor, by internet with my normal applicationWD My Cloud (You know the icon on my laptop screen).[/quote]
If you are using the WD My Cloud Desktop program on your laptop to connect remotely to your WD My Cloud unit, note that the program apparently does not use DLNA to stream video. Same goes for the MyCloud.com portal. DLNA streaming is typically done only on your local network not through a remote access using the WD software, apps or portal.

Typically what happens with the My Cloud Desktop program it will attempt to pass off the media file to the computer’s default media player registered for the media file format one is attempting to play or view.

Edit to add: If Windows Media Player refuses to play the file due to an unsupported codec then try VLC or other similar media player programs.

Ok Bennor, Thank You Very Much for your reply. I don’t reallly understand all of it, but i understand that not using DLNA streaming video is the cause that the windows media player don’t understand what he gets (while he apparanrly do understand how to play .mov files…). So what I do is stopping my system in chossing the media player as yhe default player. I have tried and changed the settings in the configuration-screen - auto playing (hope this the term in english) in “always ask”. But windows does not listen to me and keep on starting the medial player. But thats another problem.
I will let you know.
Yhx

If you can figure out a way to disable Windows Media Player I’d love to hear about it. I started it up to stream to an XBOX and could never get it to go away after that. The only way it finally stopped showing up was when I bought a new PC and never clicked on it.

@ NunyaBiznas: I am afraid I still haven’t found a way to stop this WMPlayer. Believe it or not I have changed the setting in my configurationfile for this WMPlayer (I did it 5 times by now) and I have restarted. And the settings are “ASK ME FOR THE VIDEO PLAYER”. But when I click a video the windows system just start WMPlayer.
So I try to delete the WM Player, but that is impossible.
I will kill this player. And when Its done I will tell you.
But it drives me crazy and very mad…

@Jovank

It’s been long since I’ve use WMP. But I think you have several options.

  1. Install the required FFMpeg filters i.e. using my old favorite K-Lite Codec Pack (Basic, Standard or Full). Just get the basic if you don’t need encoding stuffs.

  2. Install VLC, go it its preferences (ctrl+p), in there you can set the extension association. This will override all your media association to VLC depending on which you’ve chosen.

  3. Remove WMP completely, control panel -> programs & features -> turn windows features on or off -> media features -> uncheck WMP -> ok. Then install you favorite media player that supports the codecs you wanted i.e. VLC or PotPlayer.

Hope it helps…

Folks, Windows Media Player is launching because it is configured as the default media player for MPG or MPEG files. If one installed VLC they can configure VLC to become the default media player for a whole host of media file formats, including MPG and MPEG.

There are several ways to change the file associations and or default programs. One is to open VLC, navigate to Tools > Preferences > Interface > Set File Associations. Another is to open up the Set Associations from the Control Panel in Windows 7 or by typing Set File Associations from the Start Search Programs and Files entry field. The other way is to set the Default Programs via the Control Panel, select the program, then select Choose Defaults for this Program.

OK Bennor, I work on it. I have windows 10 so finding control panel is not as easy it was with 7. I let you know

I will keep you informed. windows 10 supresses (hope its the good word for it) the Set File Associations setting of VLC. It stops the program by telling me I must go to settings (windows 10) -> system -> standard apps -> muzicplayer. Well I select VLC media player and guess what? Opening the mpg file starts THE MOVIES AND TV APP of windows 10. My god. And when I stop this app it asks me: “enjoyed this app?”

But I won’t give up.

GOT IT! Bennor, Nazar78, THANKU!! It’s indeed:

  1. settings, system and changing the standard apps to VLC
  2. deleting WMP in the control panel (I must admit that I do not precisely know what I did, but I ended up in a panel where I could uncheck WMP)
  3. Restart the system

And now it works.
I anm so happy!!
Thank you!

Well Nazar, It worked. And i thank you very much!

Nice to see you play guitar!

Van: Nazar78 [mailto:wdsupport@wdc.com]
Verzonden: zondag 6 december 2015 20:02
Aan: josvankeeken@quicknet.nl
Onderwerp: [WD Community] [Cloud Storage/My Cloud] Windows Media player doesn’t play video (mpeg)

https://sjc4.discourse-cdn.com/wd/user_avatar/community.wd.com/nazar78/45/34090_1.png

https://community.wd.com/users/nazar78 Nazar78
December 6

https://community.wd.com/users/jovank @Jovank

It’s been long since I’ve use WMP. But I think you have several options.

  1.  Install the required FFMpeg filters i.e. using my old favorite K-Lite Codec Pack (Basic, Standard or Full). Just get the basic if you don't need encoding stuffs.
    
  2.  Install VLC, go it its preferences (ctrl+p), in there you can set the extension association. This will override all your media association to VLC depending on which you've chosen.
    
  3.  Remove WMP completely, control panel -> programs & features -> turn windows features on or off -> media features -> uncheck WMP -> ok. Then install you favorite media player that supports the codecs you wanted i.e. VLC or PotPlayer.
    

Hope it helps…

To respond, reply to this email or visit https://community.wd.com/t/windows-media-player-doesnt-play-video-mpeg/141189/7 Windows Media player doesn't play video (mpeg) in your browser.

Glad it helped. Windows 10 has got some flaky ways of managing its apps. I first noticed this on Office 2016 especially Excel. Fixed it by manually editing the registries.

I will add this for those using Windows 10 and wanting to choose a default app. You can go to Settings>System>Default Apps. See image below. Click, tap or activate image to enlarge it. You can also choose default programs in the Control Panel by choosing Category>Small or Large icons>Default Programs.

cat0w
USA