Windows Credentials when trying to access MyCloud

Hi - until yesterday I could happily access MyCloud using either start button + R on my windows 8.1 keyboard or via the network in windows explorer. Then suddenly, Windows began asking me for my credentials - I have tried every combination of passwords I can remember and none have worked. I went online to find a fix and tried resetting my credentials - nothing happened there apart from the fact that I now get a dialog box teling me I have mutiple connections to the same user name (???). I can still access MyCloud using the desktop app (but not in windows explorer). Unfortunately, using the app means I can’t upload anything larger than 1GB as the upload always jams at 999MB.

The only recent major change I have made to anything was to change my windows account password - would this have an impact on MyCloud?

Can anyone help?

it sounds like you are connected to a public share and that connection was established before the private share. Windows only allows one Windows user to connect as a single user to a remote computer at a time, if public is 1st then that is what you are. if you connect private 1st then public is ok too.

you may need to manually clear credentials and reboot to full clear this

Got the same problem since upgrade… Windows ask ever login/password.

Tests with Windows Seven and Windows 8.1 gave the same result.

After a reboot, Mycloud display no share.Only USB hard drive is displayed.

No share, no “Public” share.

Administration IU works like a charm and FTP service still available with all sharing.

this dosn’t sound like the same issue. this sounds like the overall_share issue

Can you still see the shares in the desktop or momil apps?

it sounds like you need to do a system only restore, this leaves shares & data in place, everthing else like new

on other work around I played with and may work (it won’t hurt anything) is go into the UI/shares and change the premission of each share from private to public and back again, set the permissions. if a share is public make it private and back. don’t rush this and do 1 at a time. if you rush it you will probably trash the overall share file again

If you use SSH once you have this working I would create a backup of /etc/samba/overall_share

for example cp -p /etc/samba/overall_share ~username/overall_share.bak where username is your mycloud user all lowercase

1 Like

Samba logs seems to indicate that a database is recreated…

[2015/02/24 20:16:08.164957,  0] winbindd/winbindd_cache.c:3147(initialize_winbindd_cache)
  initialize_winbindd_cache: clearing cache and re-creating with version number 2
[2015/02/24 20:42:36.737949,  0] (pidfile_unlink)
  Failed to delete pidfile /var/run/smbd.pid. Error was No such file or directory
[2015/02/24 20:42:38.857311,  0] winbindd/winbindd.c:212(winbindd_sig_term_handler)
  Got sig[15] terminate (is_parent=1)

Those messages are all normal stuff.

larryg0 wrote:

it sounds like you need to do a system only restore, this leaves shares & data in place, everthing else like new

“System Restore” solves the problems. 

I needed to recreate users & permissions, cloud access and forced manual backup to enable scheduling backup.

1 Like

Thanks so much for taking the time to respond to my question - the system only restore did the trick. I’m back in using Explorer. You have saved me from ripping my hair out - much appreciated! Now…onto the Windows forum to find out what the **bleep** my Windows Credentials are :slight_smile:

in control panel / credential manager generally you don’t need to touch this but every no and then you may need to clear an old one

Hi All

I have been trying to get Windows Credentials not to open when trying to access my wd from my work computer.

I have tried all the above but cant get this Windows Credentials from coming up all the time and every time. when im looking at photos they load right away but any files and it just stops, I put the password in and it starts to load but never fully does the has only started happening.

I wish i could take this back as it does not do what is says it does IE cant access any file so in my mind not a cloud .

Thanks

found another solution that worked for me:

put a ‘’ in front of your WDMYCLOUD username and then use the password you setup. For instance if your username on the WD is ‘john’ then put ‘\john’ for username and then type in your password and see if that doesn’t let you in.

This just happened to me on my Lenovo laptop running Windows 10. Between one night and the next morning I was unable to access my WDMYCLOUD via File Explorer. I received the Windows Security error “Enter Network Credentials for WDMYCLOUDMIRROR”.

What finally resolved this was entering WDMYCLOUDMIRROR \ [username] and password for that user. I am now able to access my device and shares.

1 Like

Thanks a lot Larry -I tried EVERYTHING and after about a month later after reading this system restore worked a treat.
Much appreciated.
Nick

Hi all,

I have just run into the same problem. I don’t access my My Cloud that often so I don’t know what caused it. How do I perform a “system only restore”?

Thanks Rhane_Thomas :+1:. I have been tearing hair out of my head trying to find out where/what these credentials were. Not even WD could come up with a simply answer.

I had this problem suddenly this morning and read many threads on this site. I did the methods 2 & 3 from link below and fixed it. I reverted method 2 registry fix (regedit fix) and keeps working. So maybe just METHOD 3 (reseting network settings) is needed:

WINDOWS 10 METHOD 3 from link below
RESET NETWORK SETTINGS:

  • Hold the Windows Key and Press I (gives you windows settings)

  • Choose Network & Internet

  • Make sure Status is selected in the left pane.

  • Scroll down and choose Network Reset, and confirm by Clicking Reset Now.

  • REBOOT PC


METHOD 2 from link below:
Insecure Guest allowed (NOT IDEAL, try above method first)

  • Press Windows Logo key + R to bring up a Run

  • Type regedit into the Run dialog and press the Enter key to open the Registry Editor.

  • Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation
    in the left pane.

  • Click on the LanmanWorkstation key to display its contents in the right pane.

  • Right-click on an empty space in the right pane, hover over New and click on DWORD (32-bit) value.

  • Name the new DWORD value AllowInsecureGuestAuth.

  • Double-click on the new value and, in the dialog that opens up, change its value to 1 and then click on OK.

  • Close the Registry Editor and restart your computer, and when your computer boots up, you will be able to successfully access your WD My Cloud account without any issues.

AFTER REBOOT I DELETED THIS ENTRY AGAIN AND STILL NO PROBLEM
TRY DELETING IT AFTER PROBLEM GOES AWAY, but try method 3 first before trying method 2


Hopes it helps someone, source was (step 1 was useless):