Windows credentials blocking access


After moving house I now can’t gain full access to my MyCloud on my home network,

I was messing about with all my mapped folders and drives (due to new IP addresses etc) when problems stated. I decided to start again so I did the 4s reset button on the MyCloud and un mapped all the drives on my laptop

Now I can see the MyCloud in the ‘network’ section of file explorer but if I click on it ‘windows credentials’ pops up and I don’t know the password (I never set one)

I can’t map any share or drive as the same ‘Windows credentials’ thing pops up

In ‘This PC’ section on file explorer I can see WD MyCloud as a network location and access the public folder and I can get in to the settings on my web browser but I cant access the other folders/shares due to windows credentials

I’ve looked at a lot of other fourms and tried loads of stuff including:

The mycloud firmware is up to date

Any ideas?

Have you checked the My Cloud Dashboard to see if the Share you are trying to access is set to Private? If set to Private you need to use a username/password configured via the Dashboard that has permission to access the Private Share.

Also there is a Windows problem of accessing two or more Private Shares using different usernames and passwords.

Generally it’s a good idea to set an administrator password on the admin account in the My Cloud Dashboard and grant that admin account full access to all Private Shares. When you performed a 4 second reset you set the admin password of the My Cloud to default (blank).

@J_B Have you looked at the Control Panel>User Accounts>Credential Manager to see if something is shown there for your My Cloud or that may help you sign in? See example image below.

If something is showing for the My Cloud and the information does not help to get access then delete it and try again.

Thanks this seems to have fixed the problem!

seems stupid that windows is insisting on a password that doesn’t exist, so you have make the drive password protected so you can tell windows the password :roll_eyes:

Surely there should be some kind of option to not require a credential for a certain network location?!

Thanks again for the help, just couldn’t work this one out on my own!

Any Share configured as Public in the My Cloud Dashboard should be accessible to anyone on the local network without the need for a username/password to access it.