Access denied Enter network credentials

My device was working perfectly until Win 10 did the big update a few months ago. Since then I’m locked out of all my folders by the network credential message. I’ve spent days at various time following every link on the web about the problem. In most cases, i can’t understand the answers, but when I can, I’ve tried what they said, but still it’s the same.

I can access the dashboard without problems. It seems to be just a Windows permission thing, especially as I didn’t change any device settings. Today, I installed the latest firmware, but no change.

How do I get this thing working again? What are network credentials? Where do I get them from?

@d8veh
Since you are using Windows 10 type credential manager in the search box next to start for more information and if you find anything in network credentials/credential manager for My Cloud delete/remove it then try again.

I’ve just tried that. There were two entries. One said My Cloud and the other was one that I had tried adding as the IP address. I deleted both, rebooted, but it’s still the same, only now it asks me for a username as well as the password, while as before it was just the password.

Another thing in case it helps: When it was working, using File Exporer and clicking on Network, there would be an icon for it next to my PC (shown with a PC icon and the ID DESKTOP-7I0DN6A). It also showed it as an icon in the list below under Storage, but since the Windows update, and it stopped working, it has never shown next to the PC - only the storage one remains.

In case it helps, I can access my Public folder on the My Cloud, but I don’t have anything in it. All my data is in my private folders.

Then you almost certainly have a Windows multiple network credentials problem. Windows will not allow you to connect to different network resources using different credentials. MyCloud Shares are considered different network resources. Public will let anyone access it, so, unless you force Windows to use your MyCloud user credentials when connecting to it, it will use your Windows user credentials.

You need to remove the credentials association for Public (using the Credentials Manager).
Then reboot the PC.
Then use ‘Map Network Drive’ in Windows File Explorer, and map your shares as networks drives. Force the use of ‘other credentials’ for each share you map, and enter your MyCloud user credentials. Tick the ‘re-connect at logon’ option.
Repeat for each share you wish to use.

I don’t have any credentials to delete - not for anything!

If I make any folder on the drive public, I can map them and access them, but if I switch off public access, Windows says I don’t have permission when I click on the drive.

OK, I finally got in. I had typed every password I’ve ever used in the credentials dialogue box, and none worked. The solution was the folder’s user name and no password.

1 Like

could you explain the solution? What do you mean by folder’s user name?

I could see the folders in “my computer”. When I clicked on the folder, a Windows 10 dialogue box popped up and asked me to input credentials. The folder has a label underneath the icon. That label was the user name and there was no password.

1 Like

I posted how I fixed my problem here, not mentioned in this thread:

Possible solution? This may be apparent to everyone else, but it took me some time and thinking to come up with this solution. I have multiple users that I have added, and they responded to the email invitation (sent by the My Cloud device when you set them up) and set up a PW. It turns out that using THOSE credentials (the User name and the PW they set up) works for their logins to the My Cloud via the Internet, but does NOT give the User access to the My Cloud on our local network (to use it directly as a NAS drive over our LAN). I finally solved this credentials problem by setting up a PW on the My Cloud dashboard for the User, and it was a DIFFERENT PW from the User PW that the User had assign (in response to the email invitation sent by the MyCloud device when adding the user; I assume it could instead be the SAME PW). In other words, my local credentials LAN network access problem was solved by setting that LOCAL PW (which apparently does NOT affect the PW that the recently-invited User sets), and then using THAT LOCAL credential to access the NAS over my LAN.

Man you’re a hero, I’ve been trying to fix this problem for hours and nothing worked untill I tried your advice. Thanks!!

This worked for me!

For e.g. you have Public/ – for your other folders i.e. Phillip/ when asked for username and password just type Phillip and leave password blank. Worked for me perfectly after removing credentials showing my email address as username. Splendid!