Can't access private share from a Windows 7 PC

I accidently posted this in the wrong forum last night. Sorry about that!!

Hi all!

I’ve got a frustrating thing here. Have a MyCloud 4TB drive on our network. I can access my private share on my Mac and other Windows PCs, but not my desktop (Windows 7 Professional SP1). It used to be able to hook in but now it asks for creditials and doesn’t accept anything I do.

Here’s what I’ve done, many after reading posts on this forum, to no avail.

Tried login with the domain as it origianlly comes up with the PC-NAME.

Tried login with no domain (i.e., “\USERNAME”)

Tried login with the drivename as domain (i.e., “\DRIVENAME\USERNAME”)

Tried clearing out all creditinals in creditials manager

Used the “NET USE * /DELETE” in a Command Prompt window and cleared everything out there.

It really seems to be a Windows thing not a drive thing as I can get at stuff from other computers, but I’m wondering if anyone has any thoughts on what to try. I’m out of options from what I’ve read on here.


make sure you have discovery on and bonjour services discovery protocol is installed.

Disconnect your mappings and begin anew and map as a different user and password; enter your userid and password as set up on the MyCloud. Just the userid as spelt on the Mycloud with no pc-name, \Username etc.

1, click on computer

  1. click on map network drive

  2. click on browse under “what network folder would you like to map”

  3. click on WDMYCLOUD and if your shares has a userid and password, it will prompt you for it at this time

  4. you will see all your shares, select the one you want, Public is the default start up share

  5. click ok and click finish

  6. you can now see the NAS as a mapped drive in your Computer (treat it just like a local drive).

Thanks for the reply, maybe I wasn’t clear. Any time I try to access the private share or map the share to a drive, it rejects my username /  password, and I can’t figure out why. The steps above are what I’ve done to try to fix it, but to no avail.

I can see all your efforts, but your post indicates that you are prefixing your username with all kinds of characters including slashes, pcnames etc.

The username is just that… just the username with no prefixes or suffixes, so when you map a drive, browse for it, then select connect using different credentials, then type your username (exactly as you have it set up in Cloud) and password.

Well, that was the first place I started, and that has not worked either. As I said, it works just as it should on my Mac and other Windows PCs, just not this one that I need it to work on…

Make sure that you don’t have any software logged into the NAS, or any mounted share with another set of credentials. Windows only allows one set of credentials to a remote computer for each windows user. After you have cleared the credentials in the manager and use the NET USE command, reboot the computer.

your username should be entered \MyNas\Myuser

Were you able to fix this? I’m having exactly the same issue. My laptop is on a Windows domain, so when I try to access the private share it prompts me to login and it defaults to my current domain. The public shares I can access without issue.

I’ve tried many different combinations of username, \username \username, \email, drivename\username, \drivename\username, etc. but it says the username and password are incorrect. I’m able to see the share in

Was anybody able to fix this problem? I am having same issue for few users.

On my computer if I access the \Drive with the admin account that originally is created by WD when you unbox it, I have not problem to access any shares, but the moment I am try to set up permissions for other users, I can get to the \DriveStorage with no issues and access the main root and only the Public shares with those credentials and anything else that is private, I cannot eventhough the user has full access to the private share, it is super annoying, I spent days to figure it out and I still cant.

Tried different set of credentials, dfferent combination but still cant get through

Please drop a line if you have a solution

i have the same issue!! :frowning:

Windows 7 - cannot vouch for other versions working exactly this way

Windows retains the “credentials” you use to connect to remote file shares in the Credential manager. So even if you delete all the shares or mapped drives and reconnect them later, it remebers the credentials and tries to use those.

Windows only allows you to connect to a remote server with one set of credentials for any and all shares on that server. The set that is retained is the set that you use for the first connection you make to that server.

For those that are getting this error, here is what you ahve to do:

  1. Delete all network connections or mapped drives to your My Cloud

  2. Open the Credential Manager and delete the credential you find for your My Cloud

  3. Create a mapped drive or network connection (whichever you want) to a non-public share on the My Cloud. After that all connections will use those credentials.

WDMYCLOUD - name of My Cloud on your network

ME - my userid on MyCloud

Share1 - RWEfor ME

Share2 - Public (open to all)

First connection is to \WDMYCLOUD\Share1. Use User name = WDMYCLOUD\ME and password = {password for ME on the My Cloud}.

The next connection to \WDMYCLOUD\Share2 will not need a userid and password (it will use ME).

Now if you have a second user on the My Cloud (MYSPOUSE) and they have a share, Share3, with access MYSPOUSE=Read, Write and ME=None, you will not be able to connect to that share from your computer. If you need access to the Share3 you must either go to MYSPOUSE’s windows PC and access it from their using the MYSPOUSE credentials or change the access on that share using the share menus on My Cloud to give the user ME Read and Write access (or whatever is appropriate).

Also, make sure the “Network Workgroup” is set (Settings | Network tab on the My Cloud dashboard) to the same workgroup as all your PCs. I also have a fixed IP address for mine (not just a dedicated address provided by the DHCP controller, but have it fixed on the MyCloud). These things eliminate “loosing” the My Cloud.

This is what I do and it works for me. Note that if you rename your My Cloud, change its address, change the network configuration, etc., etc., you may have to re-do your connections from scratch.

1 Like

FYI, if you have mutiple people that share a PC just create additional users on the PC for each. each PC user can commect to the mycloud as a different user. one PC user can not connect to the mycloud as mutiple users

I just Wanted to add that this solution above worked perfect for me on all Windows 7 PC’s:

For those that are getting this error, here is what you ahve to do:

  1. Delete all network connections or mapped drives to your My Cloud

  2. Open the Credential Manager and delete the credential you find for your My Cloud

  3. Create a mapped drive or network connection (whichever you want) to a non-public share on the My Cloud. After that all connections will use those credentials.

WD should put this in their documentation for troubleshooting - thinking on all the usesr that we see having the same problem!

I had this problem and it was making me crazy. My desktop would not let me connect to any private share - even after disconnecting from all mapped drives and deleting my credentials. When I got onto another computer, I logged on as my fiancee and it let her access the pricate shares as well as the public. I switched users on her computer, logged in as me and let me into all public and private shares.

Here is the one step that GregLiverman left out:

2a. Restart your computer.

I know, right? After that, it used my windows credentials to log me onto the drive.

Something else you may need to think about, my username and password on my PC are the same as on the MyCloudMirror - as are my fiancee’s. There may be other issues if you use a different username and passoword on the Mirror than on your PC.