Home network and WD My Cloud

Hello. I am a bit lost and I need some help please. First of all, my system spec:

Windows 10 64-bit

WD My Cloud 3 TB

I have all the latest drivers and firmware installed.

The problem:

There are 2 users U1 (me - admin) and U2. Both have passwords enabled.

There are 3 shares: S1 (default public), S2 (Public Access OFF, U1 full access, U2 read only) and S3 (Public Access OFF, both U1 and U2 full access).

When I navigate to Network > WDMYCLOUD and try to access S2 I am prompted to input username and password. I am inputting the correct details and yet I am unable to access this share. 

For the username I tried:




None worked. The password is 100% correct.

Try rebooting the PC and then reaccess the private share. Sometimes Windows is the cause with login issues on recently configured private share folders on the WD My Cloud.

As to mapping the drive, see the following WD Support link for more information: How to map a My Cloud or NAS device on a Windows PC. If you haven’t already done so it is recommended that one read through the WD My Cloud User Manual as it will explain how to configure shares for private access and how to map a share to one’s computer.

I have Windows 10 installed on one PC and don’t have any problems with accessing the WD My Cloud or mapping a drive to Windows 10. However, others have reported (search this forum) a variety of issues while using Windows 10.

Thanks for your reply. I have edited my post slightly to give some more details and be more clear. I’ll try rebooting Windows now.

I rebooted both My Cloud and the PC and sadly it didn’t help. Here are some screens to show my set up and the error message:

  1. Users


  1. Logging in:

  1. No access:


What am I doing wrong? This is getting really frustrating. 

That last error tells you exactly what’s going on.

You’re trying to log into the My Cloud using two sets of credentials.  Windows won’t let you do that.  

Chances are, you’re accessing a PUBLIC share first, in which case WIndows logs you in as a guest user to the My Cloud.  Once you’ve done that, you can’t access any private share.

You need to access your private share first.

I have the same issue

Although its not working now for me, this has worked in the past. Go into control panel then credential manager and delete the one(s) for mycloud.

TonyPh12345 wrote:


You need to access your private share first.

Yep. One way to do this automatically is to map the private share so that when one boots the PC it logs into the private share before the user has a chance to access the public or other shares.

This problem is not really the fault of the My Cloud, rather its a problem with Windows and its credential manager.

Aaah, that explains everything - thanks for clarifying, makes perfect sense now!