Windows 8pro mybooklive windows cannot access\\mybooklive

Upgraded to windows 8, had my 2tb mybooklive with windows 7 working perfectly.  After upgrade windows 8 would not map itself and my network display would show mybooklive but when clicking on it, I receive “windows cannot access \mybooklive” with an error code 0x80070035 the network path was not found.  After 5 WD tech suggestions which all didn’t help, I had to map my IP address through the cmd prompt.  Now my drive is mapped but mybooklive displayed at the network still shows the same error code above.  I can see my shared folders within the mapped drive but cannot connect to any newly created share folders at all since I can’t click into mybooklive.  What is the problem with windows accessing mybooklive? 

You provably did it, but just in case verify if you have the latest firmware update installed, also if you have the my book connected to a router, try connecting it directly to the PC and check if that helps.

I have the latest firmware which I installed when I had windows 7 and now with windows 8 upgrade(, connecting to the MBL direct doesn’t help.  My computer doesn’t even see or recognize the MBL…  Reset the MBL to factory settings through the dashboard and completely reinstalled windows 8 and that still didn’t help.  Same issue windows cannot access \mybooklive \mybooklive

Try using WDlink to find it on your network.

wd  link finds it, maps it to z drive, i can see it, the public shares display, no problem until i click on the mybooklive under the network,  i could see my private shares that way, now i can’t see any private shares nor will windows find the drive for file history backups, mapped ok, windows continues with “windows cannot access \mybooklive” when i click on the mybooklive under the network in explorer

Same problem here. MBL is accessible from two windows 7 and one XP computer in network, but not from the new windows 8 laptop. I see it under network, but get the message “can’t access …” when I try to open it.

It is also accessible from my Android 4.1 phone and a WD TV Live.

Since you can access the MBL using the IP but not the name, it sounds like a name resolution issue.

Although it might be a Firewall / AntiVirus that is blocking it as well.

Do you have any third party FireWalls or Anti-Virus running on your system?

If so, could you turn it off and try accessing the MBL?

If that does not apply, can you try a couple other things?

  • open a “command prompt” and ping the MBL by typing “ping mybooklive” (without the “”).

If the “pings” completes:  we know the name resolution is working correctly and have to look elsewhere for the problem.

If the “pings” timeout: Can you record the IP address that is shown?

It should be on the line after you typed “ping mybooklive”. In this case we know that the name resolution is the problem, and can troubleshoot from there.

Can you also try accessing using the mybooklive’s IP Address and see if there is any issues - \IPADDRESS

ping mybooklive and was successfull, sent and received 4 times while showing the IP address

How?  I manually mapped to the z drive, which shows the IP address, and I can click and open the public folders just fine, its at the network level that fails.

Googling that error code reveals that lots of folks have the same issue with Windows 8 UPGRADES.

In almost every case I read, the users that re-installed Windows 8 (from scratch, instead of upgrading) had no further issues.

In short, that error code indicates that something is interfering with NetBIOS name resolution.

If you can connect via IP, that shows that the network layer is working fine.   

When you try to connect via hostname, it does a NetBIOS name lookup and will also try DNS lookup.   If both fail, that error code results.

It can be due to not having NetBIOS over TCP enabled, a firewall blocking NBNS or MDNS lookups, etc. 

I have the exact antivirus and firewall I had with this computer on windows 7 as I do now with windows 8, but I did shut them both down and tried anyway, same failed result.  How to I work on the TCP and NetBIOS suggestion?

Many of those links have suggestions to follow…

have not found how to affect the NetBIOS over TCP enabled properties, is that option available in windows 8?

I would assume so…  I’ve never used Win8, though, so I don’t know how to modify it.

The poster says that the problem was with win8 on the laptop.  If the laptop is connected via wireless to the local network, then I’m not surprised that win8 couldn’t find the path as I had the same problem with win7 on a laptop usin wifi.

Hmm… this is tough…

The you can turn NetBIOS on/off by going to your network card properties, then TCP/IPv4 properties, then Advanced. It is under the WINS tab.

So name resolution is working for the “ping” command, but not for the mapping.

Who provides your A/V?

I saw some of the threads Tony was talking about, but did not see a clean resolution in any of them. Most just failed-over to the IP address.

Gone to my device manager, network adapters, Realtek PCLe GBE Family Controler, properties, advanced, TCP checksum offload (ipv4) with options Rx and Tx enabled(current state), disabled, or one or the other enabled,   I have a Toshiba Satellite laptop, not knowing where to find exactly what your post is driving me to,  I think I am in the wrong area

To check network adapter settings in Windows 8:

  1. Go to Control Panel

  2. Open Network and Sharing Center

  3. In left column, click Change Adapter Settings

  4. Click on your network adapter

  5. In lower left, click on Properties

  6. The new window will list all the Clients, Protocols, and Services that are installed for this adapter

When I do this, I find that NetBios is not installed. Howefver, I don’t think this is the source of the problem you’re having, since I am able to see all MyBookLive shares in my network view even without NetBios. I think this is what you need to do:

  1. If you don’t have WD QuickView installed, download and install it from the WD MyBook Live downloads page. If there are other MyBookLive software components on this page that you haven’t installed, do those too.

  2. Once installed, click on WD QuickView icon in the Taskbar Notification area. (In Windows 8, you need to be in Desktop view to do this.)

  3. In the pop-up menu, select MyBookLive > Map > [sharename], where [sharename] is the MBL share that you’ve previously created.

  4. The Map Network Drive window opens. Choose a drive letter for this share, then check “Reconnect at sign-in.”

  5. Click “Finish.”

This should result in a new drive letter appearing in Windows Explorer, as well as the activation of the drive shares in your Network view. I hope this helps. If not, geez I really don’t know what you can try next!

Sorry guys, but WINS hasn’t been needed on a Windows network since Windows 2000. It’s a TCP/IP world now.