Network Access Problems

Setup:

  • Windows 8 Pro
  • WD My Book Live Duo with Firmware Version: 02.40.06-048 (latest)

Problem:

  • I cannot access the drive from the network using the assigned name of the drive. I enter the designated password to no avail. I get peretual log in screens (see below)

log in.PNG

(I get this over and over again)

What does work:

  • I can access the drive from the network if I use the IP address instead of the name (see below)

  • I can access teh dashboard with no problems
  • The DLNA server and itunes server work fine.
  • The iTunes server works fine
  • This all used to work, prior to the firmware update, although the problems did not show up until well after the update
  • I can also access it from my other Windows 7 computer, by name. So it looks like it might be windows 8 specific.
  • No other major computing or network changes

 Troubleshooting so far:

  • rebooted computer
  • rebooted the router
  • rebooted the My Book Live Duo
  • Changed the My Book Live Duo name (I can see the name in both cases but neither will allow me to log in)
  • Changed my user password
  • Did a hard reset of the My Book Live Duo (although it did not reset the name of the drive back to default, so i can’t be sure that I did that correctly. I pushed the button on the back and held it there while it was powered on to no avail. I also pushed it and held it while power cycling)
  • Updated the firmware from a file successfully 

any thoughts?

Hi,

If is working on the windows 7 computer, the issue is with the windows 8. What about the firewall on the computer or the router???

Check all the settings on the windows 8

@ragdexx I checked that. No third party firewall, just plain old vanilla windows. No changes to the router either. I’m at a complete loss and it’s quite frustrating.

Thanks for your reply!

I think I know what this is. Window 7 and Windows XP can have the same issues,  Your Windows 8 box has authenticated to the MBLD as a guest and a Windows OS can’t authenticate to the same server using different credentials.

First, try to remove all authenticated connections from the command line:

NET USE * /DELETE

When all authenticated connections are removed immediately try connect to the network share.

This this one.

@myron Oh soooo close. I thought you had it! But alas, no dice.

cmd.JPG

And I can still get to it using just the IP address. There is somthing simple and funky lurking at the bottom of this.

Your image has to be approved my a moderator.

Maybe Windows 8 re-authenicated as guest before you managed to properly authenticate?

I made a two line batch file that breaks connections and then reconnects without using the explorer.

So, I’ve had no luck getting this thing back on track. So, I decided to try and do a reset using the button on the back.

But not even that worked. I pushed and held the button and it just started at me, with it’s mocking blinking (constantly blinking btw) green eye.I’ve rebooted while holding the button, just nothing works on this thing these days.

I want to try a scheme to do a factory reset without losing my data. I have Raid 1 set-up so I have two chances not to screw this up. Is there a way to take one (or both) of the drives out and perform the reset then replace the drive to restore my data? I know it’s a long shot, but I’m at a loss here.

I would not try a reset. I’m guessing the blank partition will replace the one with data. Seen the image. It’s what I thought it was. Need to have a think…

I run into exactly the same problem, using Windows 8 as well, from a clean install…

Personally, I don’t think this is a problem with the My Book Live Duo.  The reason I write this is that with Windows 7 I have seen a similar behavour with an Iomega NAS and also a LaCie NAS. 

Windows 7 and I guess Windows 8 have a highly configurable firewall. That would be the firtst thing to check. There may be something else on the computer that might need turnin on ans setting.

Something to check is of the workgroup name set on the My Book Live Dio is the same as that of the computers on the network so it participates in work group name and resource browsing.

I’m still scratching my head on this one . . .

There is the possibility that the SAMBA serverin the NAS needs to be updated to version 4 if it not already at version 4?  I will raise the consern.

Update from OP:

I can now see my MBLD in my network after changing the workgroup and users. But, I still can’t access via UNC path.

The good news is that I get a different error now: 0x80070035 The networkpath was not found.

No promising, but I’m making progress.

I have a feeling that a number of NAS manufacturers may be getting caught out a bit with Windows 8.  More over that they use the Smaba daemon that is the file server that Windows requires and that’s got gtom one place.  Be it Iomega, Seagate Western Gigital, LaCie or any other.

I would think that Windows 8 would take a step down and use SMB v2 if that what is available to it.

I’m wishing that the next update to the MBL and the MBLD included the latest version of the Samba daemoin.

@Myron That is especially disconcerting  considering the slow frequency of firmware updates and the fact that we just got an update. Am I to beleive that they didn’t see this coming and I am to live withit until thy get their ducks in a row?

What had to be determined is if the fault lies with Windows 8.  There are loads of people out there who don’t have an issue. A completely unrelated issue, I helped someone else with a access problem that seemed to originate from the MBLD. My hunch was that the problem was the router and it turned out I was right.

Needs more investigating.  You got to admit that Windows 8 is a new operating system and Microsoft has a reputation of releasing a new operating system, let the lab rats (aka. “us”) test the operating system and find the rest of the bugs and then release the first service pack that fixes all the founts that should have not been in there from the beginning!

Has anyone noticed all Microsoft home oriented operating systems become less stable as they approach their ultimate end-of-life date?

@Myron Fair enough. I will say though that I don’t seem to have a problem accessing other shares on my network. That says to me that there is at least something unique about accessing the MBLD. Now, that said, you may be right that it may be something unique to accessing all NAS and not just this one. Either way, I know for certain that I am no alone. What remains is whether I am the exception of the rule.

I FIXED IT!!!

After scouring the internets, I ran accross this and it worked.

Here’s the link to the solution

Here’s the long version:

  1. From the Windows 8 Start screen, start typing “notepad” (without the quotes, of course) to start searching for the Notepad application. As you type, a list of matching applications will be shown. Notepad will likely be first in the search results list, but don’t open it quite yet.
  2. In the search results list, right-click Notepad to check it, and to reveal additional options at the bottom of the screen.
  3. Click on Run as administrator.
  4. User Account Control (UAC) may prompt you for permission to run with elevated privileges. Click the Yes button to proceed.
  5. When Notepad opens, go to File > Open… and navigate toC:\Windows\System32\Drivers\etc. There probably won’t be any files shown, and Windows will let you know that with a message “No items match your search.”
  6. Choose All Files (*.*) from the menu in the lower right-hand corner of the Open… dialog. You should see the list of files update.
  7. Double-click on “hosts” to open it.
  8. Scroll down to the bottom of the file, past all of the lines starting with #. These lines are all comments, and are ignored.
  9. Create a new line containing the IP address of your device, a space or tab, and the name of the device. You can add a comment at the end of the line, as well, to remind you what the entry is for. So, for the example given above, the new line would look like:
    192.168.0.100   DLINK-NAS   # Identifies NAS by device name for backup
  10. Save the file, and close Notepad.
  11. Test that your new entry worked by first going to\{device IP address}\Volume_1 in a new File Explorer window. Nothing should have changed here; you should still be able to see the contents of the Volume_1 share on your NAS.
  12. Now try going to \{device name}\Volume_1. Instead of Windows not being able to find the device, you should now see the contents of the Volume_1 share, same as if you used the IP address!

DOH!  No wonder mine works all the way. Beel following this thread and now you’re vwritten the solution I’ve realised I did the same ages ago but under LMHOSTS. I took those entries out when I discoverd the issue.

Microsoft would really like to get rid of the NetBIOS protocol, specifically NetBIOS names so everything works using DNS names.  Not sure if it is available but enablinc NetBIOS ov er TCP/IP should do the trick and also if the “Computer Browser” service is turned off to turn it on. NetBIOS names notmally get re-broadcast every 15 minutes. It is better to use a WINS server which the SAMBA Daemon used with the MBL and MBLD does have, but it turned off. I ddn’t use this feature because it keeps pinging it’s database which is not held in the Ramlog space so the NAS will not go to sleep…  Unless I figure out hot wo relocate the WINS database into ramdisc/ramlog without causeing any other additional issues.