Samba issue


I have a 4TB MyBook Live DUO, two share folders, one is public, anyone can access this folder without password, also works on Win8.

Another folder is required username and password to access, on Win 7, it works well, but Win8 PC cannot access, even if entered the correct username and password, error: Network Name Is No Longer Available

In addition, I also tried WD link on Win8 PC, still not works.

Current Firmware Version:

MyBookLiveDuo  02.41.05-034 : Core F/W

Any ideas?



Make sure that your computer has all the windows updates available.

To my understanding, there’s an update for windows that was having issues with the network shares.

Are you running any Anti-Virus software? Kasperki has had problems with errors like this before. See if this link is something similar to your problem.


New situations, would be help to find out the problem.

You know, My Book Live has an admin account, if I use this account to map the network device on Win 8, it WORKS.

But, if I use another account e.g. “share” to map network device on Win 8, I’ll face the problem.

On Win 7, both of “admin” and “share” are works well.


Is there any evidence shows that is a Win8 problem?

You said a windows update having issues with the network shares, do you have the KB#? I’d like to know which KB caused this issue.


Hi Chaos311,

Yes I am using symantec antivirus software, but I am not sure this software can cause the issue.

Because if I use “admin” account to map the network device on Win8 PC, it works. If I use any other account which created by myself, I’ll got that error on Win8.

Strange :dizzy_face:


Do you have any other shares mapped to the MBL from the Win8 computer, that are not mapped on the Win7 computer? Like Public perhaps?

There can only be one share mapped to a drive from a computer, if it is Private.