MyBookLive access problem

Hi. Ok so I have a MyBookLive at home and everything is running smoothly except for one computer that has an access issue. There’s 4 computers that all can access the files  without trouble. The fifth however  can’t seem to reach the folders and files. You can connect to the dashboard but when you click “Show files”(Or whatever it is in english, have mine in my native language) it opens “My documents” and not the drive with all the files etc.

Uhm yeah that’s about it, I might have left something out but just ask and  i’ll answer. Would be awesome with some assistance here, have googled my **bleep** off until now.


I had same issues (and then some). I posted this in another thread stating what I did to fix it. I hope it works for you.

I just installed Windows 8 pro with a clean install on my HP laptop that was previously running Windows 7 home premium. I had all of the same issues everyone else was having getting my 2tb mybooklive network storage to be recognized by windows 8 and therefore couldn’t map a network drive.

The WD dashboard had no issues seeing the device, I was able to ping it using the command prompt. I tried multiple times to map a drive letter thru wd link. The wd link software would see the drive and the ip but just wouldn’t let me map a drive letter. I would continually get the error that windows cannot access the drive.

I was also getting a windows securty login credential pop up. I attempted multiple times to login using my windows username/password and also the mybooklive user/password with no go. I finally just changed the user name in the wd dashboard from my name to “Admin” and BAM! it worked. I was able to map the drive and all is working well. 

This was absolutely driving me bonkers. I reinstalled windows 8 two more times, disabling NetBios and all the other tricks I found trying to get it to work. Just changing the username is all it took. 

Bottom line solution for me was just to change the username in the wd dashboard for the drive made it accessible in windows explorer and the wd link software. I hope this helps at least one other person because I know how much of a struggle I had with it over the last two days.