Not working after upgrade to Windows 8

My MyBook Live Duo (connected via router) worked pretty good under Windows 7, but after upgrading to Windows 8 things have changed. When I open the driveletter Z: I get an error, which roughly translates into: “There’s been an error reconnecting between Z: and \\Public . Can’t find the network path”.

The only way to connect now is via ‘Network’ and then ‘MYBOOKLIVEDUO’. That’s all fine, but this way I can’t open files from within programmes like Paintshop Pro and Word etc. anymore.

Also, under ‘Computer’ a new “drive” called MyBookLiveDuo has appeared, but this also fails to give me access to files.

I wonder what has gone wrong and how I can go about correcting these errors. Any help will be highly appreciated.

(BTW I’ve considered uninstalling everything but installing the drive in the first place was a nightmare since the software installation disc delivered with the MyBook Live Duo… didn’t work! Nice going…)

Have you tried remapping the drive?

Are you able to check on the name of the drive to see if theres any changes?

Might be because the MBL and MBLD is stil using Samba server version 3.6.5 and I think WD are working on a firmware release which uses Samba server version 4.  It might also be a fault with Windows 8 and not Samba.  In this case if and when WD release Samba v4 then WD will be trying to work round a fault within Windows 8.

Thank you so much. I never did anything like ‘remapping a drive’ but for some reason this worked right away. Wonderful! I’m out of the trouble now I think.