MyBook Live And Windows 8

Hey everyone this is my issue. I Have a 1TB MyBook Live. It is connected to my router. I am able to read/write data to the device itself. I am running Windows 8 Pro. I had set up File history to a network HDD (MyBook Live). But now it cant find the device. But i can still access the drive itself. If i go into the Device manager on my computer it shows a triangle with an exclamation point in it. This is what it says:

This device cannot start. (Code 10)
The specified request is not a valid operation for the target device.

I was wondering if anyone new what would cause this or if anyone else was having this issue.

1 Like

Try doing a power cycle, you can also try using wdlink to find the device on the network. Check the link below.

everybody has this issue with win 8 pro… i believe at WD are looking into this. in my opinion is a drive integration into the win 8 ecosystem: everything works well, but MBL is not properly integrated into win 8 “devices” (for instance it does not appear among the devices when you use charm bar)… WDTVLive has a similar issue… i strongly believe that WD will come up with a solution…

Hello All,

I’m having the same issues with my network drive in windows 8 pro RTM. Tried reboot and even did a Factory reset with the same result while being able to use the features of my device. According to windows… It can’t find and install all of the drivers for the device. Code 10 - this device cannot start. All I’ve recieved from WD is basic trobleshooting steps that have nothing to do with the problem.

I lose connection to MBL when windows 8 comes out of sleep mode. Network refresh seems to find it but this is screwing up by backup. Any ideas?

I installed windows 8 32 bit, mybooklive did not get flagged with a warning in device manager. I then formatted and installed windows 8 64 bit, now mybooklive shows a warning flag. It appears to be working OK however, I then updated mybooklive’s firmware to current version, still shows as flagged.

1 Like

Hello everyone.

So I guess it sounds like its got something to do with Win 8 x64 edition.

1 Like

according to me, but I could be wrong, there is a issue with drivers (class drivers)… this is what “Code 10” usually means…

further there is an issue of missing “contracts” of the device within the win 8 environment: using some win 8 apps, for instance, the device should appear among the devices when you swipe in the charms bar, but it doesn’t… perhaps a dedicated win 8 app (offering the proper drivers of the device) should solve the issue… but so far WD has not offered a viable app for MBL, but only for other devices… let’s hope in (and pester) WD ;o)

Yes I know what you mean, my MBL isn’t the only problem I’ve had with Windows 8. I can’t even sync my HTC witch is just despicable since 8 is basically windows phone 8.

I had the same issue.  WD needs to fix some drivers, I think.


I ran into this yesterday  issue when setting up a new Windows 8 box. Very annoying as all my data and software is located on the NAS and it is basically unaccessable from the Windows 8 machine. Is there a fix yet? 

Apparently not. Windows 8 has been out for a bit now. I can’t imagine it would take this long to get a patch together.

I’m also seeing…

This device cannot start. (Code 10)

The specified request is not a valid operation for the target device.

If i try to access the drive, I get an error from Windows 8 saying it can’t access the drive and offers to ‘diagnose the problem’. The diagnostic program runs and says it’s unable to fix the problem. From that point on, I can access the drive just fine… until I reboot. Then it’s the same scenario all over again. I’m considering creating a Media PC so I can stream movies to my TV. If Western Digital isn’t interested in fixing this problem in a timely manner, I’ll just rip the H/D out of the case and install it in my Media PC and forget about all of this hassle.

1 Like

I am using windows 8 pro 64bit.

I have problem with my book live 3T.

When using download manager of internet explorer 10 to download file to my book live i get an error couldn’t be downloaded

but if i download to my usb external hard drive i have no problem.

When using canon my image garden photo software it does not recognize my book live ,i cannot select a photo to display but i have no problem with my usb external hard drive.

Same thing with roxio creator burning software .When i select a movie from my book live to burn the program hangs or not responding,but no problem with my external hard disk.

Lastly when i copy a file from my book live to my c drive to replace the file,i get a error cannot copy file or the drive is not connected.But i have no problem with my usb external hard drive.

This shows my book live has some intergration problem with windows 8 64bit.

I have no problem with windows 7 64bit.

Keep this thread alive till they fix it.  I’m not too happy with my experience with this MyBookLive and windows 8 32 bit.  I got the smartware to work but it takes over my processor.  I try to use different software and it flat doesn’t work.  frustrated.

1 Like

I just installed Windows 8 pro with a clean install on my HP laptop that was previously running Windows 7 home premium. I had all of the same issues everyone else was having getting my 2tb mybooklive network storage to be recognized by windows 8 and therefore couldn’t map a network drive.

The WD dashboard had no issues seeing the device, I was able to ping it using the command prompt. I tried multiple times to map a drive letter thru wd link. The wd link software would see the drive and the ip but just wouldn’t let me map a drive letter. I would continually get the error that windows cannot access the drive.

I was also getting a windows securty login credential pop up. I attempted multiple times to login using my windows username/password and also the mybooklive user/password with no go. I finally just changed the user name in the wd dashboard from my name to “Admin” and BAM! it worked. I was able to map the drive and all is working well. 

This was absolutely driving me bonkers. I reinstalled windows 8 two more times, disabling NetBios and all the other tricks I found trying to get it to work. Just changing the username is all it took. 

Bottom line solution for me was just to change the username in the wd dashboard for the drive made it accessible in windows explorer and the wd link software. I hope this helps at least one other person because I know how much of a struggle I had with it over the last two days. 

1 Like


I registered myself specially at this community for a comment to you.

You are my hero!  :smiley:

I had the same problems as mentioned above.

Had no problems with Win7, but after upgrade to Win8 it was… I also tried reinstalling Win8, but didn’t worked.

Simply connect with different credentials solved my problems.

Thank you very much for your information.

Thanks for posting ths workaround until WD gets their act together and resolves the issue. I am a bit unclear on where to change the user for authentication. I already use the default admin user to access the configuration software. When I try to map a driveand choose the windows option to authicnticate using a different user I just hit the same issue. any additional information would be appreciated 

Miy user name was already set to admin so this workaround didn’t work for me. My drives map and work no problem - just have the issue with an exclamation mark in the device manager.


Are you able to connect to your MBL through Devices on the charm bar in Win8? Are you able to access yours pics using Photos app?

Sorry I meant Deutch. Apologies for the inability to type correctly.