Windows 10 network share on WDTV (solved)

      Hi everyone.

     With the upgrading to Windows 10 I had the same problem as many of here not being able to share media content from my PC onto WDTV Media Player.

     

      After playing around for a while with various settings I found a solution that is working, at least for me:

  1. On your WDTV: Setup —> Network Settings —> Clear Saved Network Share Login —> Clear All Windows Share Login —> OK

  2. On your PC: 

   

a) right click START —> Control Panel —> Network and Sharing Center —> Change advanced sharing settings —> All Networks (drop down arrow) —> Turn off password protected sharing (last one on the bottom) —> close everything.

   

b) right click START —> File Explorer —> navigate to the folder you want to share and right click on it —> Properties —> Sharing (tab) —> Share… (NOT  Advanced Sharing…) —> in the new opened window there is a large empty box with a drop down option on the right side. Click the arrow and select either Guest, Everyone or both of them —> after each selection click Add —> for Guest and/or Everyone set bellow Read/Write Permission Level (this is very important because WDTV needs to right some media library information inside your shared directory) —> Share

   In my case it’s working with just a Guest account permission.

  1. Now you should be able to find the shared directory on the WDTV.

   

   Also, I don’t know if this counts, but I did all this on a fresh/clean install of Windows 10 Home. The upgrade process left to many c.r.a.p. on my C:\ partition.

   

   I hope this helps everyone who has the sharing problem. Good luck and enjoy!

P.S. I’m from Romania so I apologize for the eventually english mistakes.

        

7 Likes

Welcome to the WD Community.

Thanks for sharing. 

Hopefully, this can help other users as well. 

Not sure if this will help find a solution but I have noticed WDTV finds shared video files stored on the internal hard drive of my windows 10 computer, doesn’t see any of the shared files on external hard drives connected to the same computer by USB.

1 Like

@smido

Same thing here. Pretty frustrating. The WDTV finds the shared files in my C: drive just fine, but any of my external drives attached by USB to the PC are lost in the wind.
I’ve created Guest accounts. Changed permission levels. Everything, with no success.

I could always attach the drives to the WDTV, but I’ve found that’s a little clunky, and inconvenient when I want to access their files on my PC.

I tried PLEX as an alternative, but it’s too slow for the amount of data I have.

I’m sorry to see the WDTV fail me here. It’s been my go-to for years.

I’ll have to save my pesos and buy a cheap PC to use as an HTPC, I guess.

1 Like

What’s especially frustrating is that it sees the external drive folders in the media server, but that’s probably the PC seeing them and funneling them out as served media.

I have Windows 10 and WDTV sees both my ‘C’ drive and my external hard drive. I’m sorry I can’t say why my experience is different than yours. I have my video files on my external hard drive and my music on my pc’s “C” drive, and all (videos and music) show in my WDTV. No help, sorry, but just so you know it ought to happen.

Hey there. Just want to reply to your solution in Post #1 and inform that indeed, your solution did work for me. All our devices in the household are Windows 10 (2 PC’s, 2 Laptops, Tablet and Phones)

Following your above steps has worked for me and I thank you. Hopefully it also works for others.

I was about half a second away from returning the device as I couldn’t figure out what to do to fix the problem. If it couldn’t connect to any of our devices, that kind of rendered the system useless for me. But later in the day I sat down and spent a bit more time online trying to find a solution and came across this thread.

Daniam’s guide is good and correct as far as it goes. But if, after following all Daniam’s steps, you get the message “there is no content” after pressing ‘enter’ on the homepage large tile/s ‘videos’ or ‘music,’ there’s another thing, something Daniam hasn’t mentioned (no criticism) that’s essential, particularly if along the way you’ve reset your WD TV to factory settings.

Enter Setup. Enter Network Settings. Enter Network Setup. This is where you tell WD TV whether you are wired or Ethernet. Select the relevant choice. At this point, in a matter of a few seconds WD TV will read your network and display the message Network Setup is completed.

I’m writing this because I went all through Daniam’s steps - and the settings on WD TV - and on my pc - over and over again, but no matter what, always got the message “there is no content!”

Check your firewall, I spent weeks figuring this out, would see the WDTV from PC sometimes, but unable to stream from PC.
Turned out when i last updated windows, Windows firewall had turned itself on, and was already running avast. FINALLY…turned off windows firewall, and YEAH…finally network share and media server works with PC!

Well i have been reading a lot posts and here is my solution and it has worked for both windows 7 and windows 10 Network share on WD media and WD live

Start >>>>in the search bar type run sysdm.cpl system properties Computer name tab go to To rename this computer or change its domain or workgroup click change Workgroup change to HOMEGROUP ok and restart your computer…Another change i did for windows was network ID this is a home computer and restarted Hope this works for you… On the WD Live>> settings >> Network Settings >>WORKGROUP …change to HOMEGROUP now you can search for your pc. anonymous as user leave the password blank put the check mark in the box below … and enjoy

The solution to this problem has been posted at the forum for quite a few years. A while ago I updated the original post of mine, and it now is a Sticky post in the WDTV forum. Glad to know it got figured out in here. So here is a link to my post in a brief and clear explanation of what is going on with the sharing access issue.

2 Likes

Hello everyone. I am trying to use a WDTV Live that I have not used for a few years and getting nowhere with it. I have tried all of the methods above and no joy. I am using the latest windows 10 insider preview. As it stands right now the computer shows up and shows all the files I have shared on my PC but it does not matter what I try to play it tells me to check the extension in the manual and I know they should work. Then I go to System/Media Library/Clear Media Library/Media Library Manager For Network Share/Add Network Share To Media Library/Windows Share/Click OK and the circular arrow just sits there and spins and nothing happens. Then if I go to one of the categories like videos and at the top right of the window click select content source/click network share and it does the same thing just sits there and spins. Then from the same menu I choose my computer that is also in the list and it populates as before but none of the files will open. I looks like for some reason it is not seeing the extensions on the files. I know this because when I look at the files the extensions do not show up and also looking at the file info box at the bottom right it shows the extension as the last word in the title of whatever piece I am trying to play. I am about ready to stomp on this thing so any help would be very greatly appreciated. Thanks in advance KerryP

I assume we’re talking about a Windows Network Share here. I’m running the same Windows and I will virtually guarantee the problem is in Windows sharing, not the fault of WDTV. That endlessly spinning arrow is the worst, it really is! I get it every time my Windows system gets its settings upset (that can happen quite legitimately for a number of reasons).

The resolutions for this, in Windows, can vary from being easy and quick to resolve, or it can be rather more stubborn. Still, I will offer some fixes but in a more pragmatic vein, any work you do now, in Windows, on this problem, will stand you in good stead because I also guarantee it will happen to you again someday.

First switch off WDTV completely with a five-second press of the remote’s off button. (A good practice anyway, because when you switch it on from that state it always reboots fully and re-reads libraries which can be helpful if they have been altered).

So now, the sharing options explained, in Windows. First (out of curiosity and to get some basic idea of what is or isn’t going on), right-click a folder you believe you are sharing, look down the list and hover your cursor over ‘share with.’ See whether it says there, to the right, ‘stop sharing’ (as it should, if sharing is in operation), or just ‘share this folder’ which indicates it is not sharing.

Now look at the ‘Sharing’ tab. You will see a button which says ‘Share.’ In any event, whether you believe the file is sharing or not, click the ‘share’ button anyway. Assuming that on its own, does not resolve anything, next select the ‘Security’ tab. This is where it can become quite complex. You do sound as it you have a fair idea of what’s what, and that’s good because it may carry you through if it does become complex. As you can see, this is where the sharing is really controlled from (along with Control Panel). You ought to click into all the options here and see whether “read AND write” is selected - which is needed. (Last time I had to do all this, for the first time I had to actually insert a new user, namely “all” - because I had previously had that there, and it had vanished!). Make sure of this “read and write” attribution, because just read alone is not sufficient.

Separate from all this, check Control Panel, both Homegroup and Network and Sharing Centre. Make sure WDTV appears in HomeGroup in the list of devices being shared to.

That’s basically it. You can alternate between Control Panel, the right-clicking of folders to be shared, and powering up WDTV, and powering it down if need be. In other words, you may need to revisit the fixes I have mentioned. But amongst these things, if you perservere, it will get the job done!

That did not work for me?
REAL SOLUTION here
Got WDTV working WIN10 you need to turn it on in “media sharing options” (Control Panel)
.
First get WDTV plugged in conneted to TV and HDMI turn it on have it connected to your WiFi

Get "Control Panel " up
Click the “Turn on media streaming” button to enable the media-streaming server.
Right click WINDOWS icon bottom left, choose SEARCH, type in control panel press enter
Click Control panel. In that search box type “media”
Click “media sharing options”
read below url you should be able to work it out

Since W10 1709 i had Problems to Connect WD with my PC .
Checked 4 times all Share Rules, User Login, everything, but nothing helped.

Solution (for me): Turn on all Option for SMBv1 in Windows Feature ( find it under Standard SW, left side Activate Windows Feature), Pop Up with many Options will appear, there you will find a bullet Point SMBv1 , in my case the last Option wasn´t set (SMB1 Server), activate + reboot.

Result: now WDTV Live react like every time before, was able to conncet to my Shared Folders under W10 1709 !

Microsoft disabled SMB V1 for unsafty reasons, but many old devices still need it. They will never update their own Firmware to SMB V2 oder V3.

Good luck to all !
Mr Peter

2 Likes

Hi Guys,

This problem caused me many hours of frustration. After trying endless ways around the windows 10 update problem when trying to see network shares on my WD Live, I just reverted back to an earlier windows 10 build. The WD now works as it should. I also stopped Windows 10 from updating itself until I hear and see on an update that repairs the WD issue.

Regards,

Dave B.

Excelently STUPID idea :frowning:

HI Mr Peter, tried your solution on my WIN10 1709 no change for me still have the dreaded orange circle and no windows shares on my WDTV

Hi Paul,

its still a tricky thing for my System.

Using WDTV Live , Netgear Router, W10 PC

The smbv1 thing have to be configurated as well
First i set up an new User at the PC, with easy remindable PW, give Access this User to Directory and Files
Second you Setup this User in WD under Network options
In my case WD finds the Name of my PC after 5—10 sec , but after using, another day, i didnt find it again, so i have to replug the Power Cable…

After that it will find it again. Its not a smart Solution, but it works…

Keep on trying…

Peter

Hi Peter,
Thanks for your reply, I will try your suggestions and see how I go and will let you know if it works for me Paul McKeown

PTF2000
January 29 |

Hi Paul,its still a tricky thing for my System.Using WDTV Live , Netgear Router, W10 PCThe smbv1 thing have to be configurated as well
First i set up an new User at the PC, with easy remindable PW, give Access this User to Directory and Files
Second you Setup this User in WD under Network options
In my case WD finds the Name of my PC after 5—10 sec , but after using, another day, i didnt find it again, so i have to replug the Power Cable…After that it will find it again. Its not a smart Solution, but it works…Keep on trying…Peter Visit Topic or reply to this email to respond.
In Reply To

Paul_McKeown
January 29 |

HI Mr Peter, tried your solution on my WIN10 1709 no change for me still have the dreaded orange circle and no windows shares on my WDTV Visit Topic or reply to this email to respond. To unsubscribe from these emails, click here.