A Guide to Fixing Network Shares (THIS WORKS)


#1

UPDATE

I’ve used this exact method to get Network Shares working on 5 different HDLIVE units all on Windows 7 and so far no problems have been reported.

// Intro //

This is a quick guide for Windows 7 users who are having trouble getting NETWORK SHARES on the HD TV Live to work. It may not work for you, but it worked perfectly for me and has kept working flawlessly. At this point the only issue I have is not being able to login to Youtube.

This method does not require you to setup another user account in Windows; you simply login with the username ‘anonymous’ with the password field left blank one time. After that you shouldn’t have to login ever again. I’m going to write this guide as simply as I can so, hopefully, it’s easy to follow.

// A Wee Bit 'O Background //

After trying every possible way to get my unit working how I wanted I gave up and just settled for viewing all my media under MEDIA SERVER. Unfortunately that method didn’t work for long and the unit stopped updating the folder with new files I added to my shared folders on my PC.

I played with Tversity and got it to see and stream all of my media, but Hulu and BBC videos didn’t play very well. After using it for a few days I decided to give getting the NETWORK SHARES to work right another try.

Like many other posters my issue involved it not letting me log in. Eventually I figured how to get it work and for the past week I haven’t had any problems. I can log in, see all my folders, add folders, and play everything that I’ve thrown at it.

//  My Setup //

  • Dell Inspiron

  • Western Digital 500GB USB2.0 External Drive X2

  • Hardwired WD HD TV Live (haven’t bothered to try wireless)

  • D-Link WBR-2310

  • Windows 7 Ultimate

On one of the WD drives I have a ‘movie’ folder and the other drive has ‘tv series’ and ‘sports’. On my PC I have a ‘BluRay’ folder, ‘Pictures’, and ‘Music’. All these folders are what I have shared so my HDTV Live can see them under the NETWORK SHARES section.

// STEP BY STEP GUIDE //

  1. SETTING UP MEDIA STREAMING

The first step is to get media streaming working. This is done in the control panel. Go to:

Start > Control Panel > Network and Internet

Once there click on HOMEGROUP or CHOOSE HOMEGROUP AND SHARING OPTIONS.

The next screen should say ‘Change homegroup settings’ at the top. This is where we can turn media streaming on if it isn’t on already.

Under SHARE LIBRARIES AND PRINTERS you should put a check in the box of the following:

-    Videos

-    Music (only if you want to share your music library with the HD Live)

-    Pictures (only if you want to share your pictures with the HD Live)

The next section is SHARE MEDIA WITH DEVICES. You need to put a check in the box for ‘Stream my pictures, music, and videos to all devices on my home network’.

After you check that box click on CHOOSE MEDIA STREAMING OPTIONS… directly below it. On the next screen it should have a field to let you name your media library. Put whatever you want.

Next to ‘SHOW DEVICES ON’ make sure the drop down box says ‘Local Network’. Underneath it should show any devices your computer sees on the network and unless you changed the settings on the WD TV Live one of those devices should be WDTVLIVE. Make sure the dropdown box to the right of WDTVLIVE says ‘Allowed’ and then click OK at the bottom of the box.

You should now be back at ‘Change homegroup settings’. At the bottom of the box click CHANGE ADVANCED SHARING SETTINGS…

A box should pop up that says ‘Change sharing options for different network profiles’ at the top. Make sure the following options have a dot next to it:

-    Turn on network discovery

-    Turn on file and printer sharing

-    Turn on sharing so anyone with network access can read and write files in public folders

-    Use 128 bit encryption

-    Turn OFF password protected sharing

-    Allow Windows to manage homegroup connections

Once those options are all selected make sure it says ‘media streaming is on’ and click SAVE CHANGES at the bottom. This should bring you back to the previous box again. Make sure that SAVE CHANGES is greyed out. If not, click it.

This next step is a bit more complicated. Go to:

Start > Control Panel > System and Security > Administrative Tools

You should get a box with a list starting with COMPONENT SERVICES. The section you want to go to is LOCAL SECURITY POLICY. Click it and a box should pop up.

In the right frame click LOCAL POLICIES. On the next page click SECURITY OPTIONS. You should now have a long list of security options. Near the top of the list locate:

ACCOUNTS: LIMIT LOCAL ACCOUNT USE OF BLANK PASSWORDS

Right click it and choose ‘properties’. Once the properties box pops up put a dot next to DISABLED and then click APPLY and then OK.

You can now close all the boxes that we have left open. Media Sharing should now be turned on and we’re ready to get some folders shared.

  1. SHARING FOLDERS

I did this in a very specific way just to keep everything nice and neat. However, if you simply want to share each and every folder individually you can do it that way.

As a mentioned earlier I have two external USB drives that I have permanently connected to my PC that I wanted to share along with a single folder on my desktop where I keep all my BluRay rips. Instead of sharing each and every one of these folders I simply added them to the Windows 7 library.

The first step is to get all the folders you want in the Windows 7 library under VIDEOS. To do this right click each folder you want the HDTV Live to see and choose:

Include in Library > Videos

This will include that folder under VIDEOS in the Windows 7 library. Once you have done this with all the folders with videos you want to stream go to:

Start > Documents

There are a number of ways to get to the libraries but this should work for everyone. In the box that pops up you should see a frame on the left that has LIBRARIES with the following listed below it:

-    Documents

-    Music

-    Pictures

-    Videos

If you click the little arrow you should see a drop down of all the folders that you “included” in the VIDEOS library. For example mine looks like this:

LIBRARIES

Documents

Music

Pictures

Videos

 - Movies

 - New

 - Sports

 - TV Series

 - BluRay

You can individually go through and set sharing permissions for each folder but I like using the library because all one we have to do is set up sharing VIDEOS and all the folders under it will be shared without having to touch any of them.

In addition, if you want to add a folder later all you have to do is right click it and select share with library > videos and it will immediately be visible on the HDTV Live.

To set up sharing for VIDEOS simply right click it then choose:

Share with > Specific People

In the box that pops up click the drop down box and choose EVERYONE and then click ADD to the right. Once you do that you should see EVERYONE appear in the list of names below.

This part is very important and until I did it the HDTV Live would tell me my folders were empty. To the right of EVERYONE in the list you will see their ‘permission level’. You want to click the arrow and choose READ/WRITE. It doesn’t make any sense to me either but the HDTV Live kept telling me my folders were empty until I changed permissions for EVERYONE from READ to READ/WRITE.

Once you have that done we need to move to the HDTV Live and change some settings.

  1. SETTING UP THE HDTV LIVE

This should be the easy and quick part. If your HDTV Live is not on turn it on. On the main screen go down to SETTINGS and then up to NETWORK SETTINGS. Under the network setting options make sure AUTO LOGIN TO NETWORK SHARES is set to ON. Then click CLEAR LOGIN INFO FOR NETWORK SHARES.

Now go back to the main menu and then go to VIDEO and down to NETWORK SHARES. Under NETWORK SHARES you should see your computer (if you don’t you have a bigger issue than this guide is meant to cover). Click right or hit enter on the remote and it should bring you to a login screen.

If everything was done right on your computer all you should need to do is use anonymous for the username and leave the password field blank. If it lets you login you should see all the folders you added to the VIDEO library on your computer as well as a “users” folder.

Once you successfully login once you will not have to login again. If it did not let you login make sure you followed all the steps. If you followed them all and it still doesn’t work I’m sorry you wasted your time reading all of this. It worked for me and hopefully it will work for you.

Just a note to anyone using Windows 7 RC. Before I updated to the retail version I had major issues with the homegroup and sharing which I couldn’t resolve. It seems like a pretty common issue with other RC users. If you upgrade to the full version all those issues go away.


#2

Has this worked for anyone yet?


#3

I’m having issues on Win7 x64 and will be using your guide to see if it helps me.  I’m down to step 3 with no real problems.  great step by step.

I can’t continue onto step 3 until m son finishes watching a mvie.  I wish there was a way to access the WD settings via PC through the network.  That would be great.

Anyway, i do have a sorta dumb question or two for you.  When you said “The first step is to get all the folders you want in the Windows 7 library under VIDEOS. To do this right click each folder you want the HDTV Live to see and choose:”  I did that for my "Movie folder I have on my external hard drive.  Am I also supposed to do similar with all of my pictures and music?  IOW Right click on the Music folder and  and choose Include In Library and then click on Music?  

Also, since I am not finished yet I don’t know what the final outcome will be but do you know if there is any way to have the WD Live only see my Movie folder when I go under videos?  What I am asking is since I am sharing through this Library, will it also show items on my C: drive ?

Thanks again for the guide.


#4

Under step 1 where I talked about SHARE LIBRARIES AND PRINTERS it has boxes you can  check for VIDEOS, DOCUMENTS, PRINTERS, MUSIC and PICTURES. The guide was intended more for videos but if you were to put a check box next to both PICTURES and MUSIC then it would automatically share the PICTURES and MUSIC folders in the Windows 7 library. If you use those folders (I do) then you don’t have to worry about setting their sharing permissions later. If you don’t use those folders just right click and set up sharing like you did the VIDEOS folder.

In regard to your second question, if you do it the way I did when you go to VIDEOS  > NETWORK SHARES and then  login the only folders you should see are the ones you added to the VIDEOS  library. Plus you will have a folder called users. Basically when I log into Network Shares on my HDTV Live my folder list looks like this:

Movies

TV Series

Sports

Kids

New

BluRay

Users

If you only added a ‘MOVIES’ folder to your Video library then yours should look like this:

Movies

Users

Hope that helps.


#5

I’m sending this to the top because I’ve used this to get four HDLIVE units working on four different Windows 7 computers.


#6

First, thank you for posting this walk-thru, based on what I’ve read, I doubt I could have managed to get my WD live working without it. I am also running Windows 7 and having issues connecting. I have been following your walk-thru step by step but have run into an issue here:

 " Start > Control Panel > System and Security > Administrative Tools

You should get a box with a list starting with COMPONENT SERVICES. The section you want to go to is LOCAL SECURITY POLICY. Click it and a box should pop up.

In the right frame click LOCAL POLICIES. On the next page click SECURITY OPTIONS. You should now have a long list of security options. Near the top of the list locate "

I do not have LOCAL SECURITY POLICY in my list. I have, as follows, in order:

Window

COMPONENT SERVICES
COMPUTER MANAGEMENT
DATA SOURCES (ODBC)
EVENT VIEWER
iSCSI INITIATOR
PERFORMANCE MONITOR
SERVICES
SYSTEM CONFIGURATION
TASK SCHEDULER
WINDOWS FIREWALL AND ADVANCED SECURITY
WINDOWS MEMORY DIAGNOSTIC
WINDOWS POWERSHELL MODULES

I know this has nothing to do with WD Live, but as a Windows 7 user, do you have any idea why this might be set-up this way. I am running Windows 7 Home Premium. Please let me know if you can help in any way.


#7

Not sure waht the answer is to your issue, yeyeah but a quick google search shows the following statemnet from another forum.

The Local Security Group Policy Editor will only be available in the Windows 7 Professional, Ultimate, and Enterpise editions. You will not have the Local Security Policy Editor available in the Windows 7 Starter and Home Premium editions.

."


#8

I checked as well and it looks like that option isn’t available in your version of Windows. This means either your computer will allow guest logon by default or it cannot be changed to accept the guest logon. In that case you may have to create another account in Windows that you can use to login to Network Shares with.


#9

I’ve tried logging in already with ‘anonymous’ and ‘no password’ and have not had success. Are you saying I would create a seperate profile in Windows just for purposes of WD Live?


#10

The reason for going into Local Policies > Secuity Policies is to basically turn off the options that limits the use of guest accounts. By default Windows limits guest logins which people aren’t able to login with anonymous and  no password even if all their other settings are correct.

The question is whether your version of Windows 7 has guest login limited by default, depsite the fact that you aren’t able to disable it.

If it is limited that is why the anonymous login isn’t going  to work. What you’ll probably have to do is setup another user on your PC just to use to login to Network Shares on the HDLIVE. You don’t have to create a password when you setup another user in Windows so you may be able to just login to Network Shares with just the username. If that doesn’t work you  can try adding a password to the new acccount. If it doesn’t work after that I’m not sure what else to do.

Hope that helps.


#11

I’m going to create a second admin account and try that now, then. We’ll see. The fact I have to even go through all of this absurd, thanks WD…I’m lucky to have everyone and this forum to help me, I guess, but how many customers who bought the unit will even go this far without returning it…


#12

Thank you for the quick response and for helping me in this matter.

So I created a user account with admin privledges, specified all the options listed in the walk-thru up to where I could no longer (because of my OS versions), and tried again…nope, won’t login. Created a password for the account…nope, won’t login. This unit cannot connect to most Windows 7 machines, where was the beta testing on this?! I should not have to upgrade to a higher version of a brand new OS for this to work…I can connect to third-party external drives no problem…?

I guess I’ll just have to wait for a firmware upgrade, maybe I’ll get lucky, I’ve already returned the unit once because parts were missing, not going to bother again. Back to playing 8GB worth of data via USB drive, woohoo…

Again, thanks again to this forum. 5/6 Windows 7 machines is still a decent stat, haha…


#13

Sorry that didn’t work. There’s actually a couple of things you can do to watch stuff over your home network despite the Network Shares not working.

Just viewing your shared files through MEDIA SERVERS doesn’t work well (I can’t even see .mkv there). However, if you have a third party media server it does the trick.

I’ve used both tversity and am now happily using Playon. Tversity did a great job of serving up the media I have on my PC to the HDLIVE. I simply went to Tversity, downloaded the pro beta, installed it and then added all my folders in the program. Tversity popped up in my MEDIA SERVER menu no problem. However, I could never get Hulu running right on it.

Currently I’m using Playon and love it. The only draw back is you have to pay for it (40 bucks) after the trial period  expires. However, I can watch Hulu, CBS, ESPN, Nick Jr., Cartoon Network, Netflix, etc… on the HDLIVE with it no problem. Playon also lets you share local media (from your PC) like Tversity does. For me just having the option to watch Hulu with no problems was worth the money. There’s no other place in the world to watch Major Dad!

I know both of these aren’t the best solutions but they work. The fact that everyone had to do stuff like this is ridiculous, but it is what it is I guess.


#14

Thanks for spending the time to put this together allyismycopilot.

A few things to clear up here:

  • Using the Windows Homegroup feature only works if all the computers are running Windows 7.

  • The WDTV Live does not use the Windows Homegroup features to operate on your network.

  • All computers on the network and the WDTV Live need to belong to the same workgroup.  WDTV Live will look for the name “WORKGROUP” first and try other options to connect if that name is not found.

  • In most cases you do not need to change the ACCOUNTS: LIMIT LOCAL ACCOUNT USE OF BLANK PASSWORDS to disabled.

  • You do not connect the WDTV Live to a computer.  You are connecting it to a network and accessing the shared folders/files on that network.

The important thing is to make sure your network is set up properly first.  You need to be able to see the WDTV Live connected to your network. After that you can set up folder sharing.

Make sure you have a folder for each media type you want access to.

Music

Video

Pictures

To share a folder in Windows 7 so WDTV can access it:

    Right click folder and  choose “Properties”.
    Click the “Sharing” tab.

    Click “Share”.

    Click the arrow and select Everyone then click the Add button.

    Click “Share” at bottom

    Click “Done”

Make sure “Everyone” has all Permissions needed.

     Click “Advanced Sharing”
   Make sure “Share this folder” is checked.
    Click “Permissions”
    Highlight “Everyone”
    Check all boxes for Allow
        Full Control
        Change
        Read

    Click “OK”

    Click “OK”

    Click “Done”


#15

did just that on my windows 7 home edition and still can’t see the network shares

I actually have two computers on my homegroup, one is connected wirelessly and one is wired.

I was able to see the network shares thorugh the wireless one, the wired one is out of luck thus far.( the WD is wired).

I can see both computers in the settings/folders menu and also in the network shares menu, but wehen it comes to logging in, the wired computer won’t allow it.

 I can see the libraries through media shares on both computer but not the network shares through the wired computer. It has to be something with the user accounts and passwords as allyismycopilot was saying. I do not have the choice of disabling the LIMIT LOCAL ACCOUNT USE OF BLANK PASSWORDS becausue of my operating system but there’s gotta be something else.


#16

Connecting to your router has nothing to do with user accounts and passwords unless you are connecting wirelessly.  In that case you need the Pre-shared Key you set up on the router to log in to the wireless connection.

If you turned off Password protected sharing then you do not need to enter a password to access the share folder.


#17

never said anything about routers, never had a problem with the router, wired or wireless,I cannot login or get access using the WD to the main computer through the network shares, yet, I can access the the wirelessly connected computer.


#18

If you turned off Password protected sharing then you do not need to enter a password to access the share folder.

I do not think this is entirely true. I am running Win7 Pro 64-bit and get the non-stop, impossible-to-remove “Invalid username or passwqord” when trying to log into my network shares (located on my desktop). I’ve tried so many tutorials and am on the 15th hour of getting this working correctly.

Anyway, my point being that I KNOW FOR A GOD DARN FACT that I have password protected sharing TURNED OFF and my WDTV Live STILL asks me to log in. WWWWHHHHYYYYY!!! WHY WHY WHY will it not just login anonymously or as guest!!! Ugh!!!

AKA, please help! :slight_smile:


#19

P.S. I have auto-login enabled on the WDTV Live but it still tell sme it’s incorrect. I’ve gone and cleared the login info every time before I go to login - still tell me invalid UN or PW.

I have yet to try the registry hack but I’m about to do it when I get home anyway, I’m sick of this ■■■■! I just wish I knew exactly what it did.


#20

If I understand this correctly, you are saying you can see both computers share folders from the WDTV Live but can only access (log in to) the shared folders on the wireless connected computer.

If you disabled password protection on shares you should not have to “log in” to a shared folder on your computer from the WDTV.  Make sure you have shared folder set to share with “Everyone” and that “Everyones” permissions are all set to allowed.