Still No Network Shares ... but should I care?

My Live player is on t he network — passes the network tests, has an IP address, etc.  It is wireless.  It recognizes Media Servers on my PC and Laptop.  Using Windows 7/64 WMP 12 on either computer, I can “play to”  the Player.  It does a fantastic job with both music and video.  Instead of using a computer to send media to the Player, I can also select “Music” or “Video” on the Players interface and access and play my media with the Player’s remote and the Player GUI.  (To achieve this, on the computers I have media streaming on). 

However, when I select “Network Shares” on the player interface, all that I see is my network name, no computers or shares.  The question is — in not having access to my network shares, what am I missing in terms of functionality and flexibility, user interface, etc.? 

Curmudgeon:   It should NOT be showing the network name.   It never does that.

I’m thinking maybe you have a computer NAMED the same as the WORKGROUP name?

The only big limitation is that you can only play what the media server allows you to play.  If it’ll stream everything you need, you can forget about network shares.  Does Win7 stream ISOs / DVD folders? 

Another limitation is that media servers generally don’t supply external subtitles when selecting a film to play.  Even if they did, it’s not in the DLNA spec and none of the WD players would use them anyway.  As long as your subtitles are embedded in the file (e.g. in an MKV), this isn’t a problem.

However, the flip-side is that network shares actually have their own limitations.  

Media server streams seem to be more efficient, so you can play higher bandwidth media.  

Media servers seem to have more neat apps available, so you could control your content via an iPhone or other mobile device if you wanted.

Network shares, on the Live/Plus units, have an annoying bug where they show image thumbnails alongside your video media.

Network shares have a worrying tendency to disappear randomly (or never appear at all) for some users.

If you don’t feel like you’re missing out on anything, you’re not.  ;)  

I was a network share devotee for a long time but recent changes in my setup have led me to use media server more often.  Streaming 1080p (via media server) on a Powerline connection that previously stuttered playing 720p (over network shares) was an eye-opener…

Hmm… I seem to always end  up with the unique problems.  My workgroup is named WORKGROUP, and my two computers have unique descriptive names.  Everybody pings everybody.  Network shares accessible from each computer. Net View without parameters yields System 53 error,  but Net View \computername  (including wdtvliveplus) returns a path and correct parameters. 

Here’s a potential problem: I configured the  WDTV Live  Plus network adapter (USB plug in by Medialink) on my PC and then plugged into the WDTV (No idea how to do it differently). 

I did a little more fooling around today; tomorrow I am going to reset the WD Player and see what happens.  Thanks for your help.

Right now, my level of sophistication starts and stops at music and music videos.  The music works great and my music videos look good enough for me.  My wife is the movie selector, and she is a devoted Blockbuster DVD afficionado (I believe we hold the record for the most movies rented at our local Blockbuster).  It’s doubtful I’ll ever need much of the flexibility and sophistication  that I read about with others…so I can probably do without network shares per your observation.

However, it’s not in my nature to just give up on something that is not operating the way it should be, so I am determined to figure this one out.  Thanks for your observations! 

I still think you have SOMETHING on your network named WORKGROUP. On your PC, try the command
Net view /domain
and
nbtstat -a workgroup
And tell me what it says

by the way, configuring your USB adapter on your PC does nothing but make it work on your PC. Nothing is stored on the adapter, so it doesn’t make it magically work on the Live…

Here’s the output — both computers and wdtlive were on, networked via “home” workgroup named WORKGROUP.  Everybody still pinging everybody.  Normal looking data if you run the nbstat command with -a (computer or device name).  IPs all assigned and displayed in Windows 7, etc.  Perhaps firewall issue?  No third party firewalls…

C:\Users\Rick>nbtstat -a workgroup

Local Area Connection:

Node IpAddress: [192.168.1.121] Scope Id: []

Host not found.

Wireless Network Connection:

Node IpAddress: [192.168.1.122] Scope Id: []

Host not found.

Wireless Network Connection 2:

Node IpAddress: [0.0.0.0] Scope Id: []

Host not found.

Microsoft Windows [Version 6.1.7600]
Copyright © 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Rick>net view /domain
System error 53 has occurred.

The network path was not found.

With regard to the setup of the wireless adapter…I found myself in a Catch-22 situation.  My HDTV is in the basement, but there is no ethernet there, only cable.  My ethernet is on the second floor, but there is no TV at all there, just a computer monitor.  The adapter came with a setup cd, but of course there is no way to put this cd in the player.  I needed a wireless connection to the player just to access the player menus, but I had no way of connecting the player via ethernet at a location where there was a TV (nor could I figure out whether it was possible to run the player menus in a window on the PC monitor).  So I got the adapter working on the PC and then plugged it into the player; I had enough connectivity to then access the player menus and run the setup routing native to the player for wireless networks.  Seems to work fine now.

Is this helpful?  This is the result of nbtstat of my network name.  It is this name that shows up when I click on “Network Shares” in the player’s xmb (or whatever that menu is called).

C:\Users\Rick>nbtstat -a peachpine

Local Area Connection:
Node IpAddress: [192.168.1.121] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name               Type         Status
    ---------------------------------------------
    PEACHPINE      <00>  UNIQUE      Registered
    PEACHPINE      <03>  UNIQUE      Registered
    PEACHPINE      <20>  UNIQUE      Registered
    …__MSBROWSE__.<01>  GROUP       Registered
    WORKGROUP      <1D>  UNIQUE      Registered
    WORKGROUP      <1E>  GROUP       Registered
    WORKGROUP      <00>  GROUP       Registered

    MAC Address = 00-00-00-00-00-00

Wireless Network Connection:
Node IpAddress: [192.168.1.122] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name               Type         Status
    ---------------------------------------------
    PEACHPINE      <00>  UNIQUE      Registered
    PEACHPINE      <03>  UNIQUE      Registered
    PEACHPINE      <20>  UNIQUE      Registered
    …__MSBROWSE__.<01>  GROUP       Registered
    WORKGROUP      <1D>  UNIQUE      Registered
    WORKGROUP      <1E>  GROUP       Registered
    WORKGROUP      <00>  GROUP       Registered

    MAC Address = 00-00-00-00-00-00

Wireless Network Connection 2:
Node IpAddress: [0.0.0.0] Scope Id: []

    Host not found.

I think you’re confusing terminology.

PEACHPINE isn’t the NETWORK NAME.   PEACHPINE is the HOSTNAME.

WORKGROUP is the NETWORK NAME.

So, which name is showing on the HUB?

And let me say again.   Configuring your WLAN adapter on your PC does NOTHING.    There is NO NEED to “configure” the thing on your PC.   All of the drivers for the WLAN adapter are already built in to the hub.

Second,

   The output of the command “nbtstat -a peachpine” indicates your PC has BOTH WIRED and WIRELESS running simultaneously.    Why?

Tony, thanks for the knowledge update on the terminology. 

I don’t know why that wireless connection on the PC existed.  I deleted it in the router admin.  I’m not sure how to answer your question on  what is connected to the HUB.  Are you referring to the router?  Need a clue.  Thanks.

Perhaps this is  part of the problem:  you say PeachPine isn’t the “network name”  but in my router page, Wireless/Basic Wireless Settings, I have “Network Name (SSID) PeachPine.”  This name  was auto assigned when the router was booted up initially.

The WLAN Network Name (or SSID) has nothing to do with your Network Shares.

So, when you go to the HUB and select NETWORK SHARES, and it says PEACHPINE, that’s referring to the COMPUTER that is named PEACHPINE, not the WLAN name.

When I go to Network Shares on the player menu, I see Peachpine.  Clicking that gives me the account sign in display.  Going back to previous guidance on another thread, I should enter the username and password for the COMPUTER named, not the router or any other set of userids/password.  I understand that Peachpine is the name of my PC, so I enter the account username and password for my PC, being careful to observe case.  I still receive back “the network share can not be accessed.”

I’ve tried the clear auto login procedure a few times.

Getting back to computer names, in my Windows 7 display, my “Computer Name” column shows RICKSLAPTOP and  RICKSOFFICE PC.   Also listed here are various devices (media libraries, the WDTV player, etc.) In every case, under “Network Location,” the name provided is Peachpine.

This remains a source of confusion for me.  I don’t see how “Peachpine” can be the name of a specific computer since I have two computers on the network and they both show the same network “location”: Peachpine and they have different Windows Workgroup names.

Anyway, I haven’t yet figured out how to access Network Shares unless there is some username and password for “Peachpine” that I am not familiar with.  Thanks for your continuing support.

Tony, I just read in your other lengthy thread that one troublespot is lack of Master Browser in Linksys E3000.  You recommend putting the router in a separate workgroup.  Is that something that is just done through 192.168.1.1?  I have that router and perhaps  it is causing my problem  accessing  network shares…

Yes, it’s done in your ROUTER.

But, since PEACHPINE (the system name) is the master browser, I doubt that will have any effect.

Curmudgeon10 wrote:

…  I don’t see how “Peachpine” can be the name of a specific computer since I have two computers on the network and they both show the same network “location”: Peachpine and they have different Windows Workgroup names.

 

Well, that’d be wrong.   They must all have the SAME workgroup name, and your Live must ALSO have the same Workgroup name.

It should look something like this:

net.png

Note the NAME Column:  All of my PC’s and Devices have UNIQUE Names.

Note the WORKGROUP Column:  All of my PC’s and Devices have the SAME WORKGROUP name.

Access this screen by clicking START / COMPUTER.  Then, on the LEFT SIDE click the NETWORK icon (which is highlighted in this example.)

Then in the MAIN MENU, select VIEW / DETAILS.

I guess I didn’t make myself clear: I have exactly the same display that you do.  Unique computer names, the same WORKGROUP.  The next column over is Network Location, and it is Peachpine for all.

Ok, try setting the WORKGROUP name on your router to something OTHER than WORKGROUP.

PROGRESS is being made with this change.  Not quite yet there, but here is the situation:

First, my WDTVLIVEPLUS showed up in Explorer/Network as a Computer (it is also shown as a Device, as before).  Discovery of the “computer” HDTVLIVEPLUS was through NetBios.

I am able to autologin to my  Network Shares; each computer is visible in the  Network Shares view as it should be.

Only problem: When I click on the Computer (i.e.,  MYLAPTOP, MYPC), the WDTVLIVEPLUS churns for about a minute and then tells me “no media in the folder” (paraphrasing).

All of my media is playable through the Media Server.

I have a snipped picture of the Explorer/Network view (.png format) if that is useful.  I just don’t know how to include it in this message.

So now — please give me a troubleshooting strategy for the Network Shares being “accessible” but whatever the Player is accessing doesn’t have any content.

Excellent.  Now, it’s most likely that you just didn’t set up a share.

Here’s how.

In the NETWORK AND SHARING CENTER, click “Change Advanced Sharing Settings.”

On THAT screen, make sure the following options are selected:

  • Turn On Network Discovery
  • Turn On File & Printer Sharing
  • Turn OFF Password Protected Sharing

Then save the changes.

Then open up a file browser, and navigate to the folder you want to share.

Right click the folder, and select 

   … Share With …

   Specific People

   If the name “Everyone” is NOT in the list, then add it by clicking the little down arrow to the left of the ADD button.

  Select EVERYONE from the list and click ADD.

That should be all that is required.