W7, Network Share, little help

hi everyone

Just got my new wd tv live today, missing a few instructions though.

My System:

W7 x86

Network, no homegroups, router managed everything.

So I have put media (mkv h.264) in my c:\public\public videos folder etc., but I don’t even see my PC under Network Share. All I see is my PC as a Media Server if I activate it in wmp12, but that **bleep** because I can’t add any mkv / hd stuff to that library somehow (doesn’t show in wmp12 either as no codecs I think, use VLC on pc) plus I see all the divx stuff from ‘my videos’ which I don’t want (and would have to remove from library to get out of the media sharing…)

All I want is _one_ folder  (doesn’t matter where) on my W7 Computer with a few mkv which I can -share- and see on my wdtv live, so I can copy the mkv i want in that folder and go upstairs and watch it on my tv. Btw I see the win xp ‘shared folder’ of my other computer on the network just fine (never put anything in it though).

(Btw I have windows live messenger 11 installed)

Thanks for advice

Make sure Network Discovery is ON.

Make sure File / Printer Sharing is ON.

Make sure Password Protected Sharing is OFF.

Then RIGHT-CLICK on the PUBLIC folder, Share With, Specific People, and make sure EVERYONE is in the list, with at least READ access.

TonyPh12345 wrote:

Make sure Network Discovery is ON.

Make sure File / Printer Sharing is ON.

Make sure Password Protected Sharing is OFF.

Then RIGHT-CLICK on the PUBLIC folder, Share With, Specific People, and make sure EVERYONE is in the list, with at least READ access.

First three is ok.

But “Then RIGHT-CLICK on the PUBLIC folder, Share With, Specific People, and make sure EVERYONE is in the list, with at least READ access.”  does not work, because if I right click ‘c:/users/public’ and go ‘share with’ the only Option is ‘Advanced sharing settings’ which brings me back to the screen to turn on network discovery etc.

Doesn’t show in WD Live atm, net view shows my pc sharing.

Ahhh, Ok, that folder is “Special.”

When you click Advanced Sharing settings, is the setting “Turn On Sharing So Anyone with Network Access can Read and Write Files in the Public Folders” clicked?

Try a different folder the way I described, just to see if THAT will show up.  

If NOTHING will show up, then you have something else going on.

unfortunately still didn’t show up. 

The thing is, I can’t even see my pc name under network shares on the wdtv, so no login etc.

I’ll give it further effort tomorrow.

On your PC, issue the command

net view

and post the results here.

Issued under the omnisearch (net view) I see my router and my own Computer, which I can click and view all files (public and not). Issued under cmd, ‘the list of servers for this workgroup is currently no available’. Mind you, the wdtv was off when tested.

… that means you have a Master Browser problem on your network.

Make sure EVERY device on you rnetwork is set to the SAME WORKGROUP NAME.

Thx, this youtube video finally solved my problem:


After that, deinstall windows live 2011 for successful login.

Thanks for your help, I have further questions (DTS not working) but I will create a new thread in the appropriate place. Thanks for helping.

Has anyone corresponded with WD about this issue?  What was the response?

The MP+ isn’t an outdated product, it seems like they almost would HAVE to fix it; I can’t imagine it being anything more than a firmware fix, because every other computer and device on my network (including my Patriot Boxoffice, which is older than the WD) can access the network and shares fine, with password-protected login.  And in fact, the WD could access my Win7 shared folder, then it couldn’t, then it could, and currently it can’t again (insists it’s the wrong password or says it can’t be accessed).

It does work with media server, and the info about workarounds is appreciated, but I’m more wondering if WD will step up and fix this, or just abandon the product and fix it in a new model.  Having to shut off password access is not acceptable, nor is having to uninstall Windows Live.  I’ve read the resoning about PW logins not being necessary, but in fact they are for many situations and applications (logging in from a remote location for example), and Windows Live offers more than silly chat gadgets…movie maker, and a basic email client for example, but there are others.

So I wondered if WD has been alerted to this issue and if they’ve indicated they’re working on it, or not.  It’s a nice little media player with so many good features and extras, it seems a shame to have such a glaring glitch…I just can’t imagine them expecting people to disable passwords or uninstall valid applications to be able to fully use it.

Flyinby,  exactly what problem are you talking about?

I think that your problem has been solved but I would like to add this post to help anyone else struggling with shares.

It took me about two weeks to get Network Shares and Windows Media Player (WMP) as a media server working reliably with WD TV Live. In order to get it working I had to learn a lot about Windows 7 shares, libraries and windows media centre (WMC).  These notes are for anyone else who is having problems setting it up and I have built on several other posts in this forum.

I have Windows 7 Ultimate (32 bit) with three user accounts, for home, work and Guest.  The latter does not need to be enabled I just have it for when my children visit to limit what they can do.  I do not have a Windows ‘homegroup’ enabled but the following guide will probably work if you do.

WD TV Live Setup

My WD TV has firmware - 1.02.21.

If you have been trying to get shares working by changing lots of settings in WD TV then it is probably best to do a ‘Reset to factory defaults’ in the WD TV System Setting page.

WD TV Live uses the anonymous login account with a null password to connect to Windows.  In previous versions of Windows ‘anonymous’ was a member of the ‘everyone’ group which is used to control access to network shares and the media server, see http://technet.microsoft.com/en-us/library/cc772211.aspx  In Windows 7 ‘anonymous’ was taken out of ‘everyone’ so WD TV Live can’t login unless ‘anonymous’ is put back in by the following:

WARNING: This requires editing your PC’s registry which, if edited incorrectly, can cause Windows systems to become unstable and unusable. Follow the instructions below at your own risk and you should backup the registry before you start. I take no responsibility for any damage caused by following these steps which have been taken from other posts.

  1. Navigate to the following location in the registry editor: MACHINE\System\CurrentControlSet\Control\Lsa\
  2. On the right side, double-click on ‘everyoneincludesanonymous’ and change the ‘Value data’ from ‘0’ to ‘1’
  3. Double-click on ‘NoLmHash’ and change the ‘Value data’ from ‘1’ to ‘0’
  4. Navigate to the following location in the registry editor: MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters
  5. Double-click on ‘restrictnullsessaccess’ and change the ‘Value data’ from ‘1’ to ‘0’
  6. Close the registry editor

Even when ‘anonymous’ is enabled you may still have error message from WD TV Live if Windows Live Sign In Assistant is loaded.  If it is go to W7 control panel programmes and Features and uninstall it.

Turn auto logon ‘on’ in WD TV Network settings.

If you have changed the WD TV Live from anonymous, ‘Clear login info for network share’ in the WD TV Network settings.

WD TV also has the Network Workgroup name set to ‘WORKGROUP’, the default Windows network name.  Mine is set to something else so I changed WD TV to be the same.

These were the only settings that I had to change in WD TV Live.

Windows 7 Setup

To setup W7 network sharing go to control panel, network and sharing centre, choose homegroup and sharing options, change advanced settings and set:

Network Discovery – ON

File and printer Sharing - ON
Public Folder Sharing – OFF

Printer Sharing – ON

Media Streaming – OFF, for now

File sharing protection – Use 128 bit

Password Protected Sharing – OFF

Homegroup Connections – User accounts and passwords

Click ‘Save changes’

Create a Network Share

Go to the folder(s) that you want to share with WD TV Live, e.g. you video folder.

Right click and select ‘Share with’

Select ‘Specific people …’

Type Everyone and click Add and make sure Everyone has Read access

Click Share

Just to be sure reboot the PC

Switch on the WD TV

Enjoy you shares!

W7 Media Streaming

There is a lot of discussion about the merits of various media servers, e.g. Windows Media Centre (WMC), Windows Media Player (WMP), Twonky, TVersity, etc.  As I have W7 Ultimate I wanted to use WMP and/or WMC as a preference.

The plus side is that you can stream any media directly from your PC to WD TV via the ‘Play To’ option.  In W7 or WMP right click on the media you want to stream and select WD TV Live.

The down side is that WMP is not compatible with some file formats, e.g. MKV but this can be overcome.

NOTE that W7 uses the Windows Media Player library as its media streaming source.  If you don’t want to use WMP then stop here and you are on your own. 

If the above instructions get your network shares going and you want to use WMP then in W7 click control panel, network and sharing centre, choose homegroup and sharing options, change advanced settings and set:

Media Streaming – on

This will take you to a ‘media streaming options’ page where you can set the name of your media library (your login account name by default) and you should be able to see WD TV Live listed on the network.

If you haven’t used WMP before then open it and it will build the Media Library to be used by WD TV Live.

If you are using the default W7 media libraries, i.e. pictures. videos, music, to contain all your pictures, videos and music then you should be able access all you media through the WMP Media Library, except MKVs.  If you have stored your media in other folders then you must add these folders to the WMP Library, .e.g. in WMP click Organise, Manage libraries, select a library, e.g. Videos and you will be presented with a ‘Videos Library Locations’ screen, click Add and browse to the folder that use and include it.  You will be asked if you want to share it, click yes. WMP will then include the media in the folder to its library for access through WD TV.

Go to the WD TV and select videos or music and then select ‘Media servers’.  You should see the name of your media library.  Select it and the screen should then present you with further selections for your media, e.g. genre, etc.  Choose and enjoy.

I will include a more detailed post about how to use Windows Media Player as the media server for WD TV, including MKV files later.

Tony, I was talking about all the problems connecting to network shares with Windows 7…just looking at the forum posts shows there’s an issue.  I’d already posted the problem I was having, but in a nutshell when I got the WD about 3 weeks ago, I connected to everything fine, using (for the Win7/64 machine) a user name and password to access the shared folders.  Suddenly it no longer could connect, and kept insisting on the wrong password.  Then, after a while it would again connect, then it quit again and that’s where it stands.  Perhaps it was the Windows live getting updated that caused it (I disabled the login assistant as I didn’t ask for it to begin with), but it connected fine without disabling password-protected access, and now all the posts seem to indicate it has to be disabled.  But it did work fine before, with PW on.

If it’s caused by the Windows Live doing something it shouldn’t, then perhaps MS will deal with it or issue a fix or update; I just wondered if WD was aware of the issue and either expecting a bugfix from MS, or if it was a glitch in their own firmware that was to blame, and something they could fix.  While there are a couple of WinLive features I’d like to make use of, if it’s causing other problems I’ll wait until they fix it.

Fortunately I’m able to access the files through the media server, including the .mkv’s (it just doesn’t offer the “play to” right-click option, but no big deal), so I decided to hang on to the WDLive as it’s really a nice unit overall.

Kruk01, thanks for a VERY detailed and thorough step-by-step; very nice of you to spend the time putting all that together.  If uninstalling Windows Live doesn’t fix it back to where it was (working), I may try the registry hacks for the anonymous login, or perhaps a system restore first (to 2 weeks ago when it worked).  If that still doesn’t get it, at least the media server is usable, though a little less straightforward than just copying movies into the folder I want for network shares.

Yes, WD is certainly aware of it.  It’s broken GPL code (meaning, it’s not WD’s “fault,” it’s broken third party code.)    The WDTV Live and Live+ use Samba version 3.0.28a, and that version of Samba is not wholely compatible with Microsoft’s new “Enhanced Security” protocols.

Only version 3.4.x and 3.5.x (with extra patches), or version 3.5.6, which is fixed (and VERY VERY NEW) will correct the issue.  This problem was only first remedied with a patch from the Samba developers in July, and they JUST released a stable version with that fix permanently in it within the last few weeks.

Only time will tell if WD will re-do the required codebase to support a much newer version of Samba than that for which it was originally designed…

Thanks Tony.  i did uninstall Windows Live, rebooted and it does indeed connect again to network shares on the Win7/64 machine, so I didn’t have to disable the password-protected shares or add the anonymous login to get it back to the way it was working before.  If I need to add something from Windows Live in the future, at least I know what it’s going to “cost” if I do.

So for those who had the network shares working and it suddenly quit, they may not need to go through the whole checklist of settings; it’s worth uninstalling Live and then rebooting and giving it a try before doing anything else.

I agree with Flinby, i.e. before eidting the registry uninstall Windows Live,  I suspect that the registry edits in my previous post may not be required if you don’t have Windows Live installed or you uninstall it but now that its working reliably I am not prepared to try undoing the edits to check it out.